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Introduction

Autodesk Maya 2010 release notes
The Maya 2010 release notes contain known limitations and workarounds for
Maya and is organized into chapters according to Maya’s functionality.

To find out which limitations were fixed for this release, see the following:

■ What's fixed in general on page 3

■ What's fixed in Modeling on page 4

■ What's fixed in Animation on page 4

■ What's fixed in Character setup on page 4

■ What's fixed in Rendering on page 5

■ What's fixed in Fluid Effects on page 6

■ What's fixed in nCloth on page 6

■ What's fixed in API on page 8

■ What's fixed in Scripting on page 8

■ What's fixed in Python on page 9

1
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What's fixed in Autodesk
Maya 2010

What is What's Fixed?
In Autodesk® Maya® 2010, we've corrected some problems in the Maya software
that have been reported by our customers. For new features and improvements,
see What’s New in Autodesk Maya in the What’s New in Maya guide.

The following sections list the software limitations that were fixed in Maya
2010.

What's fixed in general
The following lists general limitations that were fixed in Maya 2010.

Maya Software renderer requesting a license

If you render with the Maya Software renderer, Maya no longer requests a license,
even if the environment variable MAYA_LICENSE is set.

What's fixed in Assets
The following lists Assets limitations that were fixed for Maya 2010.

Transparency on custom container icons

In previous versions of Maya, custom container icons in the hypergraph did
not support transparency. This has been fixed.

2
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What's fixed in Modeling
The following lists modeling limitations that were fixed for Maya 2010.

Automatic mapping does not respect world space

In previous version of Maya, moving an object which had a texture map
assigned via Automatic Mapping in perspective view with Hardware Texture
mode on caused the texture to shift. This has been fixed.

What's fixed in Animation
The following section lists Animation limitations that were fixed for Maya
2010.

Animation layer fixes

The following issues with animation layers have been fixed.

Using animation layers with character sets

A problem that occurred when merging animation layers containing character
sets has now been fixed. You can now merge animation layers containing
character sets, and the character set connections to the animation layer are
preserved as expected.

Merging imported animation layers

A problem that prevented you from properly merging imported animation
layers has been fixed. You can now import animation layers into a scene, then
merge them together as expected.

Import layers from MotionBuilder

The FBX plug-in included with Maya now supports the import of
MotionBuilder animation layers into Maya. However, note that the FBX plug-in
does not support the export of Maya animation layers into MotionBuilder.

For more information on the FBX plug-in for Maya and to check for the latest
releases of the FBX plug-ins go to http://www.autodesk.com/fbx.

What's fixed in Character setup
The following lists Character setup limitations that were fixed for Maya 2010.
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Using curve influence objects with the wrap deformer

A problem that caused unexpected deformations when using curve influence
objects for the wrap deformer has been corrected. You can now use curves to
deform surfaces with the wrap deformer as expected.

What's fixed in Rendering
The following lists rendering limitations that were fixed for Maya 2010.

Enable Overrides when baking

Previously, the Enable Overrides attribute in the object's Shape node, Object
Display section, Drawing Overrides sub-section, was not respected during
baking. This has now been fixed.

Color per vertex shading

Due to an optimization in CG 2.0, color per vertex shading was incorrectly
rendered in the Render View and in batch rendering. This has been fixed.

Stereo cameras and ATI graphics cards

Due to an update in CG 2.1, stereo cameras in Maya caused display errors
when using an ATI graphics card. This has been fixed.

mental ray for Maya rendering

mia_material_x_passes shader and photons and shadows

mia_material_x_passes shader now works correctly with photons and shadows.

mia_material_x_passes shader Cutout Opacity attribute

Previously, when you used the mia_material_x_passes shader with the Cutout
Opacity attribute, Maya sometimes unexpectedly stopped when rendering.
This has now been fixed.

BSP2 and building motion structure

Previously, BSP2 was only looking at the motion statement "on/off" to build
the motion structure, without looking at the shutter value. For example, it
built the motion structure even if the shutter was 0.0 0.0. This problem has
now been fixed.
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Rendering passes with files converted from Maya to .mi format

Previously, when the command line was used to convert Maya files to .mi
format, the passes in the .mi file did not render. This has now been fixed.

mental ray for Maya and processor limits

Previously, the mental ray for Maya renderer was not using all available
processors when hyperthreading was turned on. This has been corrected so
that all available processors are used for rendering.

Fixed possible wrong texture space setup for raytraced hair if both per-hair
and per-vertex textures were used

Previously, when per-hair and per-vertex textures were used, it was possible
to have the wrong texture space setup for raytraced hair. This has now been
fixed.

Link to Layer Set option now set correctly for PSD file nodes

Previously, if Maya cannot find the texture file on a PSD File texture node, it
will set the Link to Layer Set option to Composite. This has now been fixed.

What's fixed in Fluid Effects
The following lists Fluid Effects limitations that were fixed for Maya 2010.

nCaching high resolution grid fluid effects causes Maya to crash

Previously, in Maya 2009, caching high resolution grid fluid effects, which
were supported with the previous fluid cache system, caused Maya to crash.
This problem has been fixed. You can now nCache fluid effects with grids
that are comparable to the size of those that could be cached with Maya 2008.

What's fixed in nCloth
The following lists nCloth limitations that were fixed for Maya 2010.

Exclude Collisions on nCloth Transform constraint

Previously, if an nCloth object with a Transform constraint had Exclude
Collisions enabled on its dynamicConstraintShape node, any constraints
subsequently added to the nCloth object would also apply the exclude collision
behavior. This problem has been fixed.
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nCloth caching failures with selected objects or Dynamic Relationship editor

nCloth caching no longer fails if you select both an nCloth object and its
output mesh, or if the Dynamic Relationships editor is open (which
automatically selects the nCloth object and its output mesh) when you nCache
an nCloth object.

Connections not created for velocity channels when nCloth objects are
cached in same file

You can now cache Position and Velocity of two nCloth objects in the same
cache file. This means that you no longer need to make additional connections
for the velocity channels or specify the names of the channels you want to
associate with each of the data outputs on the cache node. Note that cache
blending of velocity channels is not yet supported.

nCloth caching and settling

Previously, a cached nCloth object that was constrained along one edge would
continue to settle after an Append to Cache. This has been fixed.

What's fixed in nParticles
The following lists nParticle limitations that were fixed for Maya 2010.

nParticle Age calculations in expressions

Previously, using Age in nParticle expressions resulted in the age being
computed incorrectly, which caused nParticles to die off (disappear from the
scene) prematurely, and in some cases, caused Maya to stop unexpectedly.
This problem has been fixed.

Caching nParticles with spriteTwistPP requires Cacheable Attributes set
All

Previously, if you cached an nParticle object that included the spriteTwistPP
attribute with Cacheable Attributes set to Position, Position and Velocity, or
Dynamics and Rendering (on the nParticleShape node), Maya stopped
unexpectedly when the cached scene was saved and then reopened. In some
cases, this behavior also occurred when an nParticle object included one of
the spriteScalePP attributes.

Now, the spriteTwistPP attribute is cached using the Dynamics and Rendering
or the All setting. If Position or Position and Velocity are selected as Cacheable
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Attributes, Maya ignores the spriteTwistPP and spriteScalePP attributes if they
are not cached, rather than crashing.

What's fixed in API
The following lists API limitations that were fixed for Maya 2010.

MFnMesh::setStringBlindData and MFnMesh::setBinaryBlindData on data
meshes

MFnMesh::setStringBlindData and MFnMesh::setBinaryBlindData no longer
introduce instability into Maya when used on data meshes.

Using MPxModelEditorCommand in edit or query mode

A custom MPxModelEditorCommand is set up by using the 'scriptedPanelType'
command to specify callback scripts which are used to create the panel, parent
it to a layout, and so forth. Previously, if those scripts used the custom
MPxModelEditorCommand in edit or query mode, it was possible for Maya
to become unstable and possibly stop unexpectedly. This has now been fixed.

MUiMessage when setting a callback on UI

Previously, MUiMessage would sometimes fail when trying to set a callback
on a piece of UI. This has now been fixed.

What's fixed in Scripting
The following lists Scripting limitations that were fixed for Maya 2010.

pymel crashes in Maya 2008

Using pymel command crashed in Maya 2008. This has been fixed.

fileBrowserDialog fileCommand flag function in Python

Previously in Maya fileBrowserDialog fileCommand flag did not funtion in
Python this has been fixed.

fileBrowserDialog fileCommand flag crash CER in scanStringConstant on
start up

Previously in Maya using scanStringConstant on start up would cause a CER
crash. This has been fixed.
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Unable to import md5 in the Python

Previously md5 format could not be imported in Python this has been fixed.

What's fixed in Python
The following lists Python limitations that were fixed for Maya 2010.

Executing MPolyMessage::addPolyComponentIdChangedCallback

Previously, executing the
MPolyMessage::addPolyComponentIdChangedCallback callback caused Maya
to stop unexpectedly. This has been fixed.

Callback parameters passed as pointers

Callback parameters which are passed as pointers, such as the 'decision' variable
passed to several MLockMessage callbacks, are now handled properly in Python.

NOTE Since these parameters are pointers, you must use the appropriate
MScriptUtil.set*() method to set a return value into them.

Environment variables when using mayapy.exe or maya.standalone

Previously, when using mayapy.exe or maya.standalone, the Maya
environment variables (MAYA_APP_DIR, MAYA_SCRIPT_PATH, and so forth)
were not set to their platform defaults since they are not immediately accessible
to os.environ. This has now been fixed.

Opening a file using maya.cmds.file with loadReferenceDepth (lrd)

Previously, when opening a file using the maya.cmds.file command with
loadReferenceDepth (lrd) set to either "all" or "topOnly", Maya sometimes
stopped unexpectedly after loading some of the references. When this occured,
Python also stopped unexpectedly. This problem has now been fixed.

Removing plug-level callbacks

MMessage.removeCallback() no longer generates a Python exception when
removing plug-level callbacks such as those set up by
MLockMessage.setPlugLockQueryCallback().
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Installation and Licensing

General installation limitations
The following limitations and workarounds relate to installation and licensing
issues.

(Linux) Incorrect syntax for registering Maya using rpm utility

In the Maya 2010 Installation and Licensing Guide, step 9 of the instructions to
install Maya using the rpm utility give incorrect syntax for registering Maya
using one product key.

The correct syntax to run the adlmreg command and register Maya with
Autodesk licensing includes two product keys, as follows:

■ (Stand-alone licensing)
/usr/autodesk/maya2010-x64/bin/adlmreg -i S <productKey1> <pro

ductKey2> 2010.0.0.F <serialNum>

/var/opt/Autodesk/Adlm/Maya2010/MayaConfig.pit

■ (Network licensing)
/usr/autodesk/maya2010-x64/bin/adlmreg -i N <productKey1> <pro

ductKey2> 2010.0.0.F <serialNum>

/var/opt/Autodesk/Adlm/Maya2010/MayaConfig.pit

where <productKey1> and <productKey2> are your product keys, and <serialNum>
is your serial number.

NOTE If you purchased Maya alone and received only one product key, you can
enter the same product key for both <productKey1> and <productKey2>.

For example:

3
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/usr/autodesk/maya2010-x64/bin/adlmreg -i S 657B1 657B1 2010.0.0.F

000-00000000

(Windows) Maya not added to the Path variable by default

Maya is no longer set up in your system Path variable by default during
installation. Adding Maya to your Path variable is useful if you plan to run
Maya from the command line, or if you want to batch render without
specifying the full path to the command.

The Maya installation wizard does provide the option of turning on Add to
System Path, but you can also manually add the Maya 2010 program folder
to the Path environment variable for your system.

For more information, refer to the Rendering and Render Setup guide in the Maya
Help, and navigate to the following topic: Rendering Utilities > Command line
renderer > Render from the command line.

(Windows 64-bit) FLEXnet License Finder fails to find network license

When running Maya on a Windows 64-bit operating system using a network
license the FLEXnet License Finder window opens to allow you to identify a
suitable license server. This occurs when the client’s license file doesn’t exist,
the server’s lmgrd is not running, or the license server cannot be found.

Despite entering the server information in the required fields, Maya does not
launch successfully and multiple error messages are displayed in succession.

Workaround

Manually edit the client license file on the client machine and add the license
server name. For example:

SERVER maya-licenseserver 0

USE_SERVER

By default, this file is located at: <drive>:\FlexLM\Maya2010.lic

Firewall on license server can block client machines

If you have a firewall running on your license server machine, you need to
add an exception for adskflex.exe and lmgrd.exe in order to allow client
machines to access licenses from your server.

If you receive a networking error when you try to run Maya on a client
machine, verify that the license server is running, and make sure that you
have set up these exceptions.

12 | Chapter 3   Installation and Licensing



(Windows) License server fails on first reboot

If the lmgrd.exe process fails the first time you reboot a license server machine
after setting it up as a Maya license server, start the license server manually
using LMTOOLS.

NOTE Only the first time starting the license server needs to be done manually.
On subsequent reboots the license server starts normally.

To manually start the license server

1 Select Start > All Programs > Autodesk > Network License Manager >
LMTOOLS.

The LMTOOLS window opens.

2 Click the Start/Stop/Reread tab and click Start Server.

SAMreport-Lite support

Autodesk offers a version of SAMreport called SAMreport-Lite to help you track
network license usage.

The Maya 2010 Installation and Licensing guide incorrectly states that a version
of SAMreport-Lite is included on your Autodesk product disc. SAMreport-Lite
is not included on the Maya 2010 DVD. To download SAMreport-Lite, visit
the Autodesk Web site at: www.autodesk.com/samreportlite.

In addition, the Maya 2010 Installation and Licensing guide states that you can
find the SAMreport-Lite User’s Guide in your Autodesk product menu browser.
The SAMreport-Lite documentation is not available inside Maya.

Uninstall limitations
Uninstall previous versions of Backburner

If you have a previous version of Backburner installed and you choose to
install Backburner with Maya 2010, the installer gives you the option to
uninstall or repair your existing version of Backburner. Depending on which
version of Backburner you have installed, the uninstall and repair options
may not remove Backburner as expected.
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Workaround

Manually uninstall any older version of Backburner before installing with the
Maya 2010 installer.

(Windows Vista) Uninstall progress bar updates very slowly

When you uninstall Maya 2010 on Windows Vista, the progress bar indicating
the status of the uninstall does not move for several minutes. Maya does
uninstall properly and the progress bar displays at full completion when the
uninstall finishes.

(Windows Vista SP 1) Uninstalling Maya, MatchMover, and DirectConnect
prevents you from running 3ds max

On Windows Vista with Service Pack 1, if you uninstall Maya, MatchMover,
and DirectConnect, you will be unable to run 3ds max.

Workaround

Re-install Maya, MatchMover, or DirectConnect. You can then launch 3ds
max as expected.

Notes for Beta program participants
The following release notes apply only to customers who installed Maya as
part of the Maya 2009 or Maya 2010 Beta programs.

(Windows) Saved Maya 2010 Beta installation files prevent proper DVD
install

If you participated in the Maya 2010 Beta program, you may have saved
installation files on disk that can prevent you from installing Maya 2010 and
the Maya 2010 documentation from the DVD.

When you launch the Maya installer from your Beta download package, the
install wizard gives you an option called Leave files on disk after Setup has
finished. This option is off by default. If you turned this option on, the
installation files are saved in the following directory by default:
C:\Autodesk\Maya2010\win\.
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Workaround

Manually delete any cached Beta installation files from the
C:\Autodesk\Maya2010\win\ directory before installing Maya 2010 from the
DVD.

(Windows) Maya 2009 Beta licensing files interfere with Maya 2010 licensing

If you participated in the Maya 2009 Beta program, you may need to manually
delete some Beta licensing files before you can install Maya 2010.

The following error message may appear during installation if you have the
Maya 2009 Beta licensing files on your machine:

1:5:2: adlmPITSetProductInformation failed 3:25.

Workaround

If you installed a Beta version of Maya 2009, complete the following steps to
ensure the previous licensing files are removed from your system before
installing Maya 2010:

1 Uninstall any Maya 2009 Beta version.

2 Manually delete the following folders:

■ C:\Documents and Settings\All users\Application

data\Autodesk\Adlm

■ C:\Program Files\Common Files\Autodesk Shared\adlm\R1
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Basic interface

General UI limitations
The following limitations and workarounds relate to general UI issues. For
platform-specific UI issues, see:

■ Maya for Windows limitations on page 126

■ Maya for Linux limitations on page 127

■ Maya for Mac OS X limitations on page 128

Non-compound numeric multis missing Add New Item button in Attribute
Editor

Numeric multis do not have the Add New Item button in the attribute editor.
For example, the +/- Average shading node does not have the Add new Item
button in the Input 1D section.

Various display problems with Nvidia GeForce G80/G92 based graphics cards

When using Maya with an Nvidia GeForce G80/G92 based graphics card, you
may experience a variety of problems related to screen refreshes.

Workaround

Add the environment variable MAYA_GEFORCE_SKIP_OVERLAY=1 to the
Maya.env file.

Script filters don’t invoke filterChanged callback

Script filters don’t invoke filterChanged callbacks when script changes, for
example, if you create an item filter like this:

4
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itemFilter -byScript userScript filter1;

If you modify the script, you will not be informed that the filter has changed.

Workaround

Reassign the same script to the filter to trigger the workaround.

itemFilter -edit -byScript userScript filter1

Maya leaves UNIX shell key repeat turned off

Occasionally, Maya will leave your UNIX shell key repeat turned off.

Workaround

Use the xset UNIX command to turn it back on:

xset r on

Loaded shelves cause scripts to appear twice

When you load a shelf Maya duplicates and displays every script it contains.

Workaround

Edit the scripts/others/loadNewShelf.mel script and remove the following
line:

eval($proc);

Maya 3D Shockwave Exporter

Maya 3D Shockwave Exporter is no longer provided as part of Maya.

Tear-off menus and Windows XP

Tear-off menus in Maya have display problems when using Windows XP Style
UI schemes.

Workaround

Select Start > Control Panel and double-click the Display icon. Select the
Appearance tab and change UI scheme to Windows Classic.

Hotkeys disabled when using Attribute Editor in main window

If you have the Attribute Editor open in the main window, and you click it,
type in a new value, and then press Enter, the keyboard focus stays in the
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Attribute Editor. This means your hotkeys will not work until you return focus
to the modeling window.

Workaround

To get the focus back into the modeling window without changing anything
else, move the mouse over the window and click with the middle mouse
button.

Speeding up interactive performance on Linux machines

On Linux machines, you can speed up Maya’s interactive performance by
closing or hiding the Attribute Editor when you are not using it.

Selecting components with the Lasso Tool

The Lasso Tool, when the Selection Mode is set to Object, can sometimes fail
to select objects or highlighted components. This will typically occur when
the lasso approaches an item of higher Selection Priority.

Workaround

If selecting components, set the Selection Mode to Component.

Power saver software causes problems

If you are using power saver software or some screensavers that use OpenGL,
Maya may shut down abnormally or cause system problems at the end of a
Maya session or batch render. This problem has been reported on 64-bit
systems.

Workaround

Disable power saver software when working with Maya.

Using menuItem in startup scripts breaks existing menus

When launching Maya with a mel script that contains the menuItem
command, only the custom menus in the script appear in the main menu
bar.

Workaround

Run the following .mel script before the script with menuItem in it.
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global proc buildDeferredMenus()

{

// File Menu

buildFileMenu();

// Edit Menu

global string $gMainEditMenu;

string $editMenu = "MayaWindow|" + $gMainEditMenu;

buildEditMenu( $editMenu );

// Assets Menu

global string $gMainAssetsMenu;

buildAssetsMenu( "", $gMainAssetsMenu );

// Window Menu

global string $gMainWindowMenu;

buildViewMenu ( $gMainWindowMenu );

// Help Menu buildHelpMenu();

// Paint Effects menu

global string $gMainCreatorMenu;

string $creatorMenu = "MayaWindow|" + $gMainCreatorMenu;

buildCreatorMenu ( $creatorMenu );

}

Japanese user interface
Custom install paths

It is recommended that custom install paths for Maya be specified using only
ASCII characters. That is, typing multibyte text as part of the install path may
produce unexpected results.

Multibyte node names and attributes

Maya does not support multibyte text when specifying node names and
attributes.

Workaround

Do not use multibyte text for node names or attributes; only single-byte
characters form valid node and attribute names.
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Panel names appear in English when launching Maya files earlier than version
8.5

When loading pre-8.5 Maya files in the Maya 8.5 Japanese version, panel
names may appear in English.

Workaround

Save the scene in Maya 8.5 and then re-open it to reset the panel names to
appear in Japanese.

Syntax errors when using localized version of Maya

While most commands in Maya deal with multibyte text correctly, it is possible
that using multibyte text in certain text fields of the user interface may result
in a syntax error.

Workaround

Remove the multibyte characters from the text field and try again.

Scripting using multibyte text in Maya

Localized text in MEL that uses multibyte characters is only accepted when
placed within quotation marks (“textstring”). Text strings comprised of
multibyte characters not placed within quotation marks produce a syntax
error when executed as part of a MEL command.

User interface panel/configuration name limitations

MEL and Python scripts that use English language panel/configuration names
must be updated before they'll execute correctly on a localized version of
Maya.

Workaround

Change the syntax of the script using the example below as a guide. For
example, replace lines like:getPanel -withLabel "Graph Editor"with
this:getPanel -withLabel (localizedPanelLabel("Graph Editor"))

Multibyte text when setting environment variables

Using the Maya.env file to initialize environment variables with multibyte
characters may result in incorrect behavior or character corruption.
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Workaround

Do not use multibyte text when initializing environment variables through
Maya.env.

Multibyte text for defining name clash prefixes for file referencing

Maya does not support multibyte text when defining name clash prefixes for
file references.

Workaround

Do not use multibyte text for name clash prefixes; only single-byte characters
work.
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General

Assets limitations
Loading a container from Maya 2008 or earlier may result in a warning message

In Maya 2010, containers can no longer contain non-container nodes from
other files. These disallowed nodes are automatically removed from the container
at file read time. A warning message will be issued for any impacted nodes.

Workaround

Open the referenced file and place the referenced nodes into a container. Then
make that container a subcontainer of the parent scene’s container.

Custom container icon shows noise when selected in the Outliner

After assigning a custom icon to a container and then selecting the container
in the Outliner, the background of the icon may appear noisy.

Workaround

When using a PNG or XPM file, make sure the background color for the icon
is a uniform flat color.

First loaded template errors always report as Types.template

Maya periodically gives an invalid error message saying that Types.template has
errors. This actually means that the first container template file that Maya tried
to load has errors in it.

5
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Workaround

Determine the actual template file that has errors and delete it or fix it.

Too many published attributes make selection slow when the Channel Box
is open

By default, the Channel Box displays a maximum of 400 attributes to prevent
Channel Box generation from interfering with selection speed.

Workaround 1

In the Channel Box, select Show > Containers > Selected object attributes.

Workaround 2

Create a template with a variety of views that group together the attributes
of interest. Then set the container's View Mode to Use Template and choose
the view you want. Only those attributes will be shown in the Channel Box.

Workaround 3

You can modify the limit used by the channel box with the optionVar's
containerChanBoxMaxWithTemplate and containerChanBoxMaxNoTemplate.

For example:

optionVar -intValuecontainerChanBoxMaxWithTemplate 1000

A negative value here prevents the channel box from culling any attributes.

Slider for published float value may not have desired range

Dynamic attributes that are published to a container and do not have assigned
min and max values are displayed in the container UI with default soft min
and soft max values as follows:

■ unitless attributes: -25 to 25

■ linear attributes: -100 to 100

■ rotation attributes: -360 to 360

■ scale attributes: -10 to 10
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Workaround

Use the softMinValue and softMaxValue flags on the addAttr command to
assign custom soft min and soft max values to an attribute.

Asset Editor refreshing after Undo

The Asset Editor does not auto-refresh after you undo a bind or publish
operations. Although the undo works properly, the Asset Editor does not
reflect the results.

Workaround

Unpin the container and then pin it again or click the Refresh button.

Remove from container options

By default, when a transform is removed from a container, the relevant shape
node is removed with it. This is similar to turning on Include Hierarchy and
setting it to Shapes, when using the Add to Container option.

Workaround

The optionVar "containerRemoveIncludeHier" can be used to modify this
behaviour. Setting it to the following values will have the indicated effect:

■ 0 - Include Hierarchy is off

■ 1 - Include Hierarchy is on and set to Shapes

■ 2 - Include Hierarchy is on, and set to Below (includes shapes)

■ 3 - Include Hierarchy is on, and set to Above

■ 4 - Include Hierarchy is on, and set to All (below and above)

The default value is 1.

Asset Editor and Attribute Editor performance with many attributes

When a container is displayed in Flat view mode, with more than 40 published
attributes, any attributes beyond the first 40 are organized into groups in the
AttributeEditor and Asset Editor. Each group is displayed in its own frame to
improve UI performance.You can set the size of these groups with the
FlatViewCap optionVar. The values and results are as follows:

■ 0 disables the grouping entirely
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■ a value greater than 12 sets the groups to that size.

■ any other value will result in a group size of 12.

The default value is 12.

Create a container on top of a nested current container

If you attempt to create a container at the top-level of a current nested
container, Maya freezes.

Workaround

Set the Current Container to None, create the container at the top-level, then
set the Current Container again.

Include Hierarchy Below does not include referenced containers

When creating a container and choosing the Include Hierarchy Below
(including Shapes) option, Maya does not include referenced containers.

Workaround

After creating the container, select the referenced containers and add them
manually either by middle-dragging them in the Outliner or by using Assets
> Add to Container.

General limitations
Creating a new project with defaults causes an error

If you have the Autodesk Packet File plugin loaded and then attempt to create
a new project (File > Project > New) with default settings, Maya returns an
error.

Workaround

Unload the AutodeskPacketFile.mll plugin before creating a new project.

Display layer limitations

The following known limitations affect display layers when you are using the
Playback On and Playback Off options. (In the Display Layer Editor, select
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Layers > Set All Layers > Playback On or Layers > Set All Layers > Playback
Off.)

■ Setting Playback On may not re-start animation playback on all objects as
expected.
Workaround 1: Select each object you want to start animating again.

Workaround 2: Execute the command: dgdirty -a

NOTE This command will update all objects even if they are on display layers
set with Playback Off.

■ Object positions may update unexpectedly when you select Playback Off.
Workaround: Middle-drag in the Time Slider to update the time without
updating the animation. Play your animation with nothing selected and
middle-drag one frame forward and back to maintain your object placement
as expected.

■ Animated ikHandles on display layers keep animating when you set
Playback Off.
Workaround: Use constraints with ikHandles.

Dynamic compound attribute

If you add a dynamic compound attribute to a node with other dynamic
attributes, and then delete the compound attribute, you will not be able to
recreate another dynamic attribute with the same name.

Workaround

Do one of the following:

■ Save your scene and reload it.

■ Duplicate the object, delete the original, and rename the duplicate to
match the original.
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Animation

General animation limitations
The following limitations and workarounds relate to general animation issues
in Autodesk® Maya®.

Caching objects with changing topology

Caching produces useful results on objects whose topology does not change
over time. Some animated modeling construction history operations result in
topology changes over time. While you can create a cache for these objects, it
may distort the object during playback since a constant topology is assumed.

In addition, if you make topology changes to a mesh after caching, then create
a new cache, the new cache may not be created as expected. For example, if
you cache a low resolution model, add a PolySmooth node, then cache the
model again, Maya creates the cache on disk correctly, but may connect the
new cache node at an incorrect location in the dependency graph.

To ensure that your new geometry cache works as expected, use the following
workaround.

Workaround

1 Create the new geometry cache.

2 Select Edit > Delete All By Type > History.

3 Select Geometry Cache > Import Cache to attach the cache of the smoothed
geometry.
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Cut Keys with Shape option only works when shape is expanded in Channel
Box

You can only cut keys from an object if its shapeNode it is expanded in the
Channel Box.

Workaround

To Cut Keys on Shapes, you need to have the Shapes option enabled, and you
must also have the shape node expanded in the Channel Box.

Pair blend/quaternion animation curve combination can cause jump on
creation

If your rotation curves default to synchronized quaternion interpolation,
setting a key on a constrained object can cause the orientation of the object
in question to jump.

Workaround

Re-enter the rotation values you wanted to key to, and re-key the rotation
channels.

Quaternion animation curves not correctly converted to Trax clip

Workaround

Quaternions in clips will only work properly if all three rotate channels are
included in the character. This happens automatically if you use Maya's
automatic character creation. However, if you create your character manually,
you need to include all three rotate channels in the character if you want to
use quaternions.

Synchronized quaternion curve

For synchronized quaternion curve, all three rotation channels on the object
should exist at all times. Deleting one of the rotation channels will have
unexpected results, such as changing the animation on the remaining
channels.

Workaround

Convert the curve to Euler angles before deleting the channel. Or set the
rotation keys on the channel to a static value rather than deleting the channel.
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Synchronized Quaternion rotation interpolation limitation

When keyframing rotations using the Synchronized Quaternion preference,
rotations will be clamped between +/- 360 degrees.

Unexpected behavior of animation if all three channels unsynchronized
when modifying using the API

If you modify the keys of a synchronized animation curve (quaternion or
synchronized Euler) using the API, you must keep all the keyframes
synchronized on the three rotation channels. If all three rotation channels
are not synchronized, your animation will behave unexpectedly and eventually
crash.

Options in option windows (Edit > Keys menu) disabled for current characters

When a character is current, options in several option windows are disabled.
The options are disabled because they operate on all the attributes of the
current character. The option windows affected are the ones under the Edit >
Keys menu item.

Workaround

Set the current character to None.

Ghosting and simulated objects

Attempting to apply ghosting to simulated objects such as particle simulations,
soft bodies, rigid bodies, cloth and jiggle deformers may result in unpredictable
reactions.

Workaround

Create a disk cache for the simulation.

Preferred angles on joints controlled by IK handles

Using Skeleton > Set Preferred Angle on joints in a chain controlled by an IK
Handle will appear to have no effect.

Workaround

■ Create the IK Handle after setting the preferred angles of the joints.

■ Delete the IK Handle and then invoking "Undo" to restore yields an IK
solution that respects preferred angle.
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Deleting the top level character

If a character with subcharacters is deleted, and the subcharacters are not
deleted, the subcharacters will no longer be recognized by the Maya UI because
they are no longer part of the character partition.

Workaround

Manually add the characters that are now the top-level characters into the
characterPartition by typing:

partition -add characterPartition <subCharacterName>;

FBIK and Auto Key

When working with full body IK, Auto Key will always set keys for the full
body, even if your keying mode is set to Body Part or Selected.

Workaround

To set only Body Part or Selected Keys on full body IK rigs, you must disable
Auto Key and set the keys manually.

Exporting animation curves creates file that can’t be imported

Occasionally, if you select animation curves in the Outliner and then export
them (File > Export Selected), Maya creates a file that cannot be imported.
This often happens when exporting animation at the root level, or animation
for child objects with non-unique names.

Workaround

Select both the animation curves and the object and then export (File > Export
Selected).

Alternately, turn on the animImportExport plugin (Window >
Settings/Preferences > Plug-in Manager), then export the curves as an
animExport file in the Export Selection Options window.

Animation layer notes and limitations
The following notes and limitations relate to animation layers in Maya.
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Maya and MotionBuilder layer interoperability

As a result of the logistics required to deliver both Maya and the independent
release of FBX and all its plug-ins, exporting layers from Maya to MotionBuilder
is not currently supported by the FBX plug-in for Maya.

For more information on the FBX plug-in for Maya and to check for the latest
releases of the FBX plug-ins go to http://www.autodesk.com/fbx.

Animation playblast limitations
The following limitations and workarounds relate to the Playblast window in
Maya.

Playblast escape limitation

Before you can escape from playblast you have to wait for entire sound track
to record.

Large imported audio files delay Playblast

The playback time of Playblast may be severely delayed in scenes with large
imported .aiff audio files. For example, a 40MB .aiff file may cause a 20+ second
delay between the initial command call and playback.

Workaround

View and play all (as long as your audio clips do not overlap) your loaded
audio files from the Trax Editor or use multiple short audio files rather than
single large audio files.

Sync problems with long aiff files

If you are playblasting sound with large negative offsets, you may encounter
audio synchronization problems.

Workaround

Shorten your audio files so you don't need to use large negative offsets.

Dope Sheet limitations
The following limitations and workarounds relate to the Dope Sheet in Maya.
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Dope Sheet Manipulator disappears

When using the Dope Sheet manipulator, expanding or compressing any
channels in the Dope Sheet will cause the manipulator to disappear.

Workaround

Redo your selection to restore the manipulator.

Cut and Paste hotkeys do not use their settings from Edit > Copy or Edit >
Paste in Dope Sheet

When using the Cut (default: Ctrl+x) or Paste (default: Ctrl+v) hotkeys with
the Dope Sheet Manipulator, the hotkeys do not use the settings in their
respective Dope Sheet menu option windows. Instead, they always shift your
animation to accommodate the removal or insertion of time and keys.

Graph Editor limitations
The following limitations and workarounds relate to the Graph Editor in Maya.

Copy/paste keys in Graph Editor

When cutting and pasting keys that include multiple animation curves to
multiple attributes, pay particular attention to the order that you select them,
as this will impact the order in which they are pasted.

When cutting keys from multiple attributes in the Graph Editor or Dope Sheet,
select the attributes from the Outliner-not the view area-of the respective
editor.

Trax Editor limitations
The following limitations and workarounds relate to the Maya® Trax™ Editor.

Merging characters copies clips but not the blends between clips

Workaround

Restore the blends manually after merging.
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Clips in Trax that have the same start time or end time may jump

Clips in Trax that have the same start time or end time may jump when the
clip starts/ends if there is a blend between them.

Workaround

Do one of the following:

■ Modify the hold on the final clip to control how long it plays.

■ Use “Merge” on the blended clips to create a single clip.

■ Create a pose that corresponds to the start or end point of the blended
clips, then drag and drop the pose into Trax immediately before or after
the blended clips to force the character to keep the pose before or after.

Unable to create layered animation on top of a relative clip

Workaround

Merge the relative clip to replace the relative clip with an absolute clip, then
create the layered animation on top of the absolute clip.

Blends not working for certain clip configurations

When an absolute clip is followed by a relative clip and then blended into
another absolute clip, the blend may behave incorrectly.

Workaround

Create a hold for the first absolute clip and drag it to the end of the relative
clip. Blend this with the second absolute clip. You should now have the correct
animation.

Changing animation frame rate can cause Trax time warp and blend problem

If you change the animation frame rate, Trax time warps and blend curves do
not scale properly.

Workaround

All time warp and blend curves must be scaled to compensate for the frame
rate change. They are supposed to always be between 0 and 1, but when the
frame rate changes they get scaled to fit the new frame rate. You must scale
the curves to fit between 0 and 1 in the time range.
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Parenting a Cloth object to a Trax character

When a Cloth object is parented to a Trax character, the Trax Editor will not
evaluate Cloth correctly.

Workaround

Select the object and cloth node and unparent them from the main character's
hierarchy. Delete the Cloth cache and run the simulation.

Path animation limitations
The following limitations and workarounds relate to path animation in Maya.

Geometry popping out of flow lattice

If a transform object with several pieces of geometry grouped under it is
animated with path animation, and then flow is applied with the lattice
around the object option, occasionally some of the geometry may “pop out”
of the flow lattice.

Workaround

Do one of the following:

■ Set the Outside Lattice attribute for the FFD to “All” so that all the geometry
grouped under the transform object is affected by the flow lattice.

■ Select the base lattice of the flow’s FFD and scale it a little larger until the
geometry “pops back” inside the flow lattice.
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Character setup

General character setup limitations
The following limitations and workarounds relate to general character setup
issues in Autodesk® Maya®.

When you delete a top-level character set, Maya no longer recognizes its
subcharacters

If a character with subcharacters is deleted, and the subcharacters are not deleted,
the subcharacters will no longer be recognized by the Maya UI because it is no
longer part of the character partition.

Workaround

Manually add the characters that are now the top-level characters into the
characterPartition by typing:

partition -add characterPartition <subCharacterName>;

Skeleton and Inverse Kinematics limitations
The following limitations and workarounds relate to skeleton and inverse
kinematics issues in Maya.

Advanced twist attribute on ikSpline only works for joint orientation +x

The advanced twist attributes on the ikSpline solver assumes a joint orientation
of +x.
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Insert joint tool does not work at certain angles

The insert joint tool does not work if joint pivot display is off and the camera
is tumbled to some specific camera angles.

Workaround

Enable joint pivot display or move the camera slightly.

Set Preferred Angle limitation

Using Skeleton > Set Preferred Angle on joints in a chain controlled by an IK
Handle will appear to have no effect.

Workaround

Create the IK handle after setting the preferred angles of the joints.
Alternatively, deleting the IK handle and then performing an Undo operation
to restore it will yield an IK solution that respects preferred angle.

Skinning limitations
The following limitations and workarounds relate to smooth and rigid skinning
issues in Maya

Colorized skin weight display for vertices does not work for NURBS or
Subdivision Surfaces

The colorized skin weight display on vertices (set by the Colorize Skeleton
option in the Smooth Bind Options window) is only supported for polygonal
objects. However, skin weight coloring for surfaces is supported on all geometry
types.
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Deformers

General deformer limitations
The following limitations and workarounds relate to deformers (non-skin
deformations) in Autodesk® Maya®.

Using target blend shapes in a referenced file

If you are using target blendshapes from a referenced file to deform a base object,
the base object may change position unexpectedly if you open the main scene
with the references unloaded. Specifically, the unloaded targets will be treated
as if the Origin attribute is set to World even if the Origin attribute is set to
Local.

Workaround

Load the referenced file the first time you open and save the scene. You can
then unload the referenced file if you choose, and keep working with the base
objects as expected.

Adding a new influence object to a smooth skin

If you add a new influence object to a smooth skin, it will not immediately
appear in the Component Editor.

Workaround

Close the Component Editor and reopen it.
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Unpredictable results when changing an object’s topology upstream from
a deformation

Changing an object’s topology upstream from a deformation causes
unpredictable results. When you deform an object, Maya generates references
to some of the object’s components (CVs of NURBS curves or surfaces, polygon
vertices, or deformed lattice points).

There are several ways to change the topology (for instance, the number of
such components the object has) “upstream” of the deformations. For example:

The Rebuild Curve operation may change the number of CVs in a curve,
changing the sections or spans attributes of a makeNurbSphere node may
change the number of CVs in the resulting NURBS surface, and the Polygons
> Smooth operation can drastically change the number of polygon vertices
in the smoothed object. Unfortunately, Maya does not yet have a way to
communicate these changes to the nodes downstream in a way that allows
the “right thing” to happen.

Workaround

If the object being modified is being deformed: remove the object from the
deformer’s deformation set, apply the topology-changing operation, and then
restore the modified object to the deformation set. If the deformation was a
cluster and you had edited the associated percentages, you must repeat that
step after changing the object’s topology.

If the object being modified is bound as skin to a skeleton: Detach it from the
skeleton (Skinning > Detach Skin), apply the topology-changing operation,
and then rebind the skin (Skinning > Bind Skin).

If the object being modified is a curve used as a wire curve (for instance, it is
the “influence object” for a wire deformation): Remove the curve from the
wire deformer, change its topology, and then add it back to the wire.

Other examples of this limitation

■ Wrap behaving unpredictably

If you modify the face or CV count of shapes used as wrap deformers, the wrap
behaves unpredictably.
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Workaround

Remove the shape as an influence object and then add it as an influence object
again. This will reset the data for the wrap so that it will work again.

■ Changing the CV count of a deformed object downstream

If you change the CV count of a deformed object downstream (after) the
deformation, translate, rotate and scale of the CVs of the object may affect
the wrong CV. Examples of operations that would cause this problem are:
inserting or removing a knot on a NURBS surface, or deleting a polygon face
or vertex.

Workaround

Disconnect the message attribute connection between the deformed shape
and the tweak node. To do this, select the shape and display its history in the
Hypergraph. You will see a connection between a tweak node and the shape.
Select the connection and press the Delete key to break the connection.

Lattices with partial resolution may distort target geometry

The loss of accuracy caused by the Partial Resolution Lattice deformer setting
may severely distort lattice deformed geometry.

Workaround

Decrease the value of the Lattice deformer’s Partial Resolution attribute, or
use Full Resolution.

Jiggle deformers may not evaluate properly when used in combination with
Fur or motion blur

Workaround

Batch rendering of Fur objects and motion blur with the jiggle deformer
requires the creation of a jiggle disk cache.

Ghosting is not reliable on jiggle deformations

Workaround

Creating a jiggle disk cache will typically allow ghosting to work on the jiggle
object.
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NURBS modeling

NURBS modeling limitations
Bevel Plus limitation

In some rare occasions when Bevel at Start is turned off, undesirable results may
occur if the end face becomes self-intersecting.

Workaround

Turn on Bevel at Start, turn off Bevel at End and set the Bevel Depth and Extrude
Distance to negative values (precede the value with a “-”). If required, modify
the original curve to ensure desired results.

Convert NURBS to Subdiv for groups returns an error

Sometimes when using the Modify > Convert > NURBS to Subdiv option on
groups of NURBS objects, Maya returns the following error:

// Error: More than one object matches name

Workaround

Select Modify > Convert > NURBS to Subdiv >  . In the NURBS to Subdiv
window, turn on Keep Original and then click Create. A converted version of
your NURBS group appears on top of the original group. Delete the original
group.
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Create Adobe Illustrator Object limitations
Illustrator version compatibility

Maya is only compatible with Adobe Illustrator 8 files. Attempting to import
Illustrator files created in other versions may yield unexpected results.

Workaround

If you are working in a version of Illustrator other than 8, convert the files to
Illustrator 8 format.

Unexpected results when importing an Illustrator file

In certain cases, you may find that an imported Adobe Illustrator file shows
points shooting off or other strange geometry.

Workaround

You may be able to fix the problem by changing the position of the origin or
type in the Illustrator file and re-importing.

Adobe Illustrator file does not import

In a compound path if the inside path is behind the outside path you get the
following error message when attempting to import the file into Maya:

// Error: bevelPlus1 (Bevel Plus Node): Group 2 curve 4 is not inside

the previous curve. Group these curves appropriately in Adobe (R)

Illustrator (R)

// Error: Failed to create bevel output //

Workaround

You may need to fix the groupings and compound paths in the Adobe
Illustrator file. To do this:

1 Open the file in Adobe Illustrator.

2 Select the compound path.

3 Select Object > Compound path > Release.

4 Select the outer path.

5 Select Object > Arrange > Send to Back.
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6 Select both paths.

7 Select Object > Compound Path > Make.

8 Save the file and import it into Maya.

If Maya doesn’t import anything, you need to perform the Create > Adobe
Illustrator Object operation again.

Beveled text does not tessellate correctly when rendered

Sometimes the surface created using Create > Adobe Illustrator Object and
Bevel appears fine in wireframe mode, but displays poorly in shaded mode.
These kinds of surfaces do not render well in the Maya renderer because of
poor tessellation.

Because mental ray uses a different tessellation algorithm, rendering with
mental ray can produce significantly better results.
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Subdivision Surfaces

Subdivision Surfaces limitations
Weight field for a subdivision surface vertex member of a deformer set may
appear blank

The weight field for a subdivision surface vertex member of a deformer set
(cluster, skinCluster, or jointCluster) may sometimes appear blank, and entering
new weight values has no effect.

Workaround

Pick the cluster handle or joint and select the cluster members by using Edit
Membership Tool. Use the Component Editor to now display and edit weight
values for the cluster members. If you turn off List >Auto Update in the
Component Editor window, clicking the name of the component in the first
column of the table will identify the cluster member by selecting it in the scene
view.

Unexpected results with non-proportionally scaled Subdivision surfaces

Subdivision surfaces with non-proportional scale and hierarchical edits may
not behave properly when a rotation is applied to the coarse mesh components
(including base).

Workaround

Use Modify > Freeze Transformations with the scale option set to remove the
non-proportional scale from the object in question.
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Selecting UV vertices on texture borders in the UV Texture Editor

In the UV Texture Editor, selecting UV vertices that are on texture borders
may sometimes result in multiple vertices being picked.

Clean Topology in the UV Texture Editor causes UV distortion

Using the Subdiv Surfaces > Clean Topology option on a subdivision surface
in the UV Texture editor may distort the UVs.

Workaround

Right-click the subdivision surface and select Polygon from the marking menu.
Open the Hypergraph Hierarchy and select the polyToSubdShape1HistPoly
node. Select Subdiv Surfaces > Clean Topology.

File referencing with Subdivision UVs

When referencing a file that contains a subdivision surface with UVs, the UV
information is included in the parent file.
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Polygons and games

General polygon and games limitations
The following lists general polygon and games limitations and workarounds.

Selecting a Vertex or Face loop mis-documented

In the documentation for selecting a vertex loop or a face loop on a polygon
mesh, step 3 states that you must double-click an adjacent vertex or face in the
direction you want the loop. In actuality, you must hold the Shift key and then
double-click an adjacent vertex or face in the direction you want the loop.

Crease node with history can affect Smooth Mesh performance

The interactive performance of vertex edits to polygon meshes displayed in
Smooth Mesh Preview mode may be adversely affected whenever a crease node
is contained in the construction history. This is noticeable immediately after
the first click-drag of the mouse.

Workaround

Avoid having a crease node in the polygon meshes construction history, or
delete the construction history before performing the vertex edits.

Magnet tolerance when using Insert and Offset Edge Loop tools

The Insert and Offset Edge Loop tools only snap to the ends of a selected edge
whenever the Snap magnets preference setting is greater than 0 and the Magnet
tolerance setting is set to a high value (for example, 10).
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Workaround

Reduce the Magnet tolerance setting to a lower value, or set the Snap magnets
setting to 0.

Shared faces with opposite UV winding may have normals reversed

When working with UV maps on a mesh that has two faces with opposite
winding orders, but that share UVs across one edge, the normals on one face
may display incorrectly, as if the face was split down the middle and flipped.

Workaround

For many scenes with this problem, unshare either the UVs or the normals
along the shared edge to correct the problem.

Combining instanced polygon meshes may delete geometry

Combining two instanced polygon meshes using the Combine command can
result in one of the two polygon meshes being deleted without prior warning.
This occurs when the transform node for one of the selected polygon meshes
has more than one DAG path from the root level.

Workaround

If this occurs, duplicate the polygon meshes using the Copy option prior to
using the Combine command.

Shell option in Constraint Selection feature selects UV texture shells instead
of polygon shells

In previous versions of Maya, the Select Using Constraints feature (Select >
Select Using Constraints) selected polygon shells when the propagation option
was set to Shell. In Maya 8.5 this behavior changed so that only UV texture
shells became selected.

Workaround

Select a component on the object where you want to select a polygon shell
and then convert the selection by selecting Select > Convert Selection > To
UV Shell.

UV layouts appear different on other platforms and versions

Recent changes to how floating point calculations are computed in Maya has
resulted in changes to the order in which UV shells are calculated. As a result,
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the layout of UVs may appear different when the file is subsequently loaded
in Maya on a different hardware platform or a later version, particularly when
the original UV layout has been edited.

Workaround

Delete the history in the original file and then save it before attempting to
open it on another platform or version.

Black color per vertex values are not saved on corner vertices

Black color per vertex values that are assigned to corner vertices of a polygon
mesh are not retained when the file is saved. The CPV information on the
corner vertices of the mesh values appears white or grey when the file is
subsequently opened.

Workaround

If you need to apply black CPV values to corner vertices, use a small numerical
value instead of 0. (For example, 0.01)

Maya does not maintain the order of selected components

The global selection list does not preserve selection order of polygon mesh
vertices, faces, edges.

Workaround

Use the following script to collect each selected component in an array, and
then use the array as desired.
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global proc selectProc() {

global string $gSelectedComponents[];

string $selC[] = `ls -sl -flatten`;

if (size($selC) > 0) {

int $match = 0;

for ($newSel in $selC) {

$match = 0;

for ($oneComponent in $gSelectedComponents) {

if ($newSel == $oneComponent) $match = 1;

}

if ($match == 0)

$gSelectedComponents[size($gSelectedComponents)] = $newSel;

}

}

else {

clear ($gSelectedComponents);

}

int $debug = 1;

if ($debug && (size($selC) > 0)) {

print ("Selected components (in the order) ...\n");

print ($gSelectedComponents);

print ("\n"); } } // to load the scriptJob

int $jobNum = `scriptJob -e "SelectionChanged" "selectProc"`; //

to unload the scriptJob scriptJob -kill $jobNum;

Blend weights limited to 0 to 1 range in Color Set Editor

Blending color sets using the Blend option in the Color Set Editor results in
the blend weights being limited to the 0 to 1 range when the image is rendered.
That is, blend weight values higher than 1 are clamped to a maximum value
of 1. This is a known limitation of the OpenGL default rendering pipeline.

Polygonal faces disappear in shaded mode

When you apply a Freeze Transformations operation on an object, the
“opposite” rendering option is automatically turned on. This means front-faced
polygons are culled when in back-face culling mode in 3D views.

However, when back-face culling (Shading > Backface Culling) is also on in
the polygon display options, back-faced polygons are also culled. If the object
is not selected, all the polygonal faces are culled in shaded mode display
making it seem as though the object has disappeared.
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cp attribute limitation

On polygonal objects, the cp attribute is supposed to represent the actual
position in local space of a vertex, while the pnts attribute represents the tweak
value (its offset relative to the rest position).

The cp attribute is a compound attribute with child attributes named xv/yv/zv.
When you get the value of the parent attribute, Maya incorrectly returns the
same value as for the pnts attribute.

Workaround

Use the xv/yv/zv child attributes individually instead of the entire cp
compound attribute.

For example:

polyCube; select -r pCube1.vtx[0] ; move -r .1 .1 .1; getAttr

pCube1.cp[0]; // Result: 0.1 0.1 0.1 // getAttr pCube1.cp[0].xv;

// Result: -0.4 // Real X position (-.5 + .1)

polySeparate command

The polySeparate command fails if the object is invisible.

The error message in this case can be misleading:

Warning: polySeparate works only on polygonal objects.

Workaround

Make the object visible.

Booleans do not preserve color per vertex and component level blind data
info

Mesh > Booleans operations do not preserve color per vertex or component
level blind data information.

Flipping edges from multiple objects

Flipping edges from multiple objects at the same time can lead to a crash.

Workaround

Select and flip edges from one object at a time.
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Color per vertex animation not working for polygonal objects without history

Color per vertex animation will not work for polygonal objects which do not
have modeling/construction history.

Workaround

Introduce some benign construction history (such as a move component
operation that doesn't actually move anything).

Unexpected results in Cleanup when removing lamina faces and
non-manifold geometry

When using Cleanup, combining the removal of lamina faces with the removal
of non-manifold geometry can lead to unexpected results.

Workaround

Clean up the lamina faces first. In many cases, this also eliminates the
non-manifold geometry.

MfnMesh limitations

The MFnMesh::assign UVs() method does not properly support history. As a
result, UVs can be removed as history rebuilds the object.

The MFnMesh::create UVSet() method does not work if the MFnMesh is using
mesh data.

Envelope attribute for Transfer Attributes

The Envelope attribute is not supported for TransferAttributes.

User defined normals ignored on skinned polygon mesh

User defined (locked) normals are ignored on a non-uniformly scaled polygon
mesh when it is subsequently skinned.

Workaround

Freeze transformations on the polygon mesh prior to skinning.

Soft Selection causes UVs rotated 180 degrees to flip

When Soft Selection is on and you attempt to rotate a set of vertices 180
degrees, the selection flips from positive to negative rotation (or vice versa).
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Workaround

Rotate the selected vertices in several, smaller increments.

Tweak mode hotkey problem for non US-EN keyboards

When using a non US-English standard keyboard, the Tweak mode hotkey (`)
does not work.

Workaround 1

Toggle Tweak mode on and off through the Tweak mode option in the Move
Tool settings.

Workaround 2

1 Select Window > Settings/Preferences > Hotkey Editor.

2 In the Hotkey Editor, under Categories, select Modify. Then, under
Commands, select STRSTweakModeOn.

3 Under Assign New Hotkey, enter the key but do not use a modifier.

NOTE  If you do not want to interfere with Maya's default hotkeys, set this
value to the '9' key.

4 Set Direction to Press.

5 Click Assign.

6 Select STRSTweakModeOff under Commands.

7 Repeat steps 3 - 5 using the same information, but set Direction to Release
in step 4.

Workaround 3

Set your keyboard to English - United States IME while using Maya. For more
information see your operating system documentation.

Remember This Layout option unavailable for Polygons tabs in the
Component Editor

When working in the Component Editor, the Options > Remember This Layout
option is unavailable for the Polygons tab and the AdvPolygons tab.
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Selection Constraint Angle doesn’t work for edges

If you select an edge and then attempt to modify that selection in the Selection
Constraint window (Select > Select Using Constraints), the selection remains
unmodified.

Workaround

Copy and paste the following script to the script editor and run it.
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import maya.OpenMaya as OpenMaya

import math

def selectEdgesByAngle(angle):

cosangle = math.cos(math.radians(angle))

edgesToSelect = OpenMaya.MSelectionList()

selection = OpenMaya.MSelectionList()

OpenMaya.MGlobal.getActiveSelectionList( selection )

iter = OpenMaya.MItSelectionList ( selection, OpenMaya.MFn.kMesh

)

while not iter.isDone(): edgeArray = OpenMaya.MIntArray()

dagPath = OpenMaya.MDagPath()

iter.getDagPath( dagPath )

mObj = OpenMaya.MObject()

iter.getDependNode( mObj )

meshFn = OpenMaya.MFnMesh(dagPath)

edgeIter = OpenMaya.MItMeshEdge( mObj )

while not edgeIter.isDone():

status = OpenMaya.MStatus

connectedFaceIds = OpenMaya.MIntArray()

edgeIter.getConnectedFaces(connectedFaceIds)

if connectedFaceIds.length() != 2:

edgeArray.append(edgeIter.index())

else:

normal1 = OpenMaya.MVector()

normal2 = OpenMaya.MVector()

meshFn.getPolygonNormal(connectedFaceIds[0], normal1)

meshFn.getPolygonNormal(connectedFaceIds[1], normal2)

dotProduct = normal1 * normal2

if dotProduct <= cosangle:

edgeArray.append(edgeIter.index()) edgeIter.next() compList

= OpenMaya.MFnSingleIndexedComponent()

components = compList.create( OpenMaya.MFn.kMeshEdgeComponent )

compList.addElements( edgeArray )

edgesToSelect.add( dagPath, components )

iter.next()OpenMaya.MGlobal.setActiveSelectionList( edgesToSelect

)

After you’ve run this script, select an edge and run the following command:

selectEdgesByAngle.selectEdgesByAngle(30)
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You can substitute the number 30 for the angle of your original intention.
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Artisan, 3D Paint, and Paint
Effects

Artisan limitations
The following lists Artisan limitations and workarounds.

Paint Vertex Color Tool

Map Import/Export cannot be used when painting vertex faces as opposed to
vertices.

Color feedback in Artisan tools

■ Although they work the way they should, trimmed surfaces do not display
color feedback in Artisan tools.

Exporting attribute maps from NURBS surfaces

Exporting attribute maps will not work correctly for NURBS surfaces with a
degree other than 3.

Importing subdiv edge selection map

Importing subdiv edge selection map will not work.

Workaround

Import them as Vertices and convert the selection to edges.
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3D Paint Tool limitations
The following lists 3D Paint Tool limitations and workarounds.

Unable to paint on textures assigned to layered shaders

You cannot paint on textures assigned to layered shaders.

3D Paint slow with large textures

If you find a large slowdown in performance when editing larger than 1K by
1K images then this could be due to insufficient video card memory to display
textures at that resolution.

Workaround

You have the option to clamp the maximum size of textures used for display
by setting the Maximum Texture Display Resolution, which is in the Display
category of the Preferences window (Window > Settings/Preferences >
Preferences). It is recommended that you restart Autodesk® Maya® in order
for these settings to take effect.

Texture placement

The 3D Paint Tool ignores any changes you make to texture placement
parameters.

Workaround

Convert the texture with modified texture placement to a file texture (Edit >
Convert to File Texture, in Hypershade) and paint on the converted texture.

Painting with Fast Interaction

The 3D Paint Tool doesn’t work when Display > Fast Interaction is turned on.

Workaround

Turn Fast Interaction off while painting.

Paint Effects limitations
The following lists Paint Effects limitations and workarounds.
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Paint Effects do not update on Linux

On Linux, Paint Effects strokes do not appear in the viewport if they are the
first strokes applied to the scene immediately after the Paint Effects Panel has
been opened or initialized. Also, a system bell is heard, but no warning message
appears.

Workaround

Refresh the viewport, by tumbling the scene for example, and the Paint Effects
strokes appear in the viewport as expected.

Self-shadowing and directional lights

When rendering Paint Effects with a directional light, self-shadowing may
not compute correctly.

Workaround

Replace the directional light with a narrow spot light that is located far enough
away from the objects in the scene that the light is effectively directional.

Lighting Based Width not assigned to Paint Effect brush on toon line

When you assign a Paint Effects brush to a toon line, the Lighting Based Width
attribute is not set for the Paint Effects brush.

Workaround

Set the Lighting Based Width attribute (in the Illumination section of the
brush’s Attribute Editor ) to the Lighting Based Width value of the toon line.

pfxStrokes MEL command not supported by Toon node

The pfxStrokes MEL command does not output the profile curves for Paint
Effects toon objects.

Workaround

Convert the toon object to a NURBS curve by selecting Modify > Convert
Paint Effects to Curves. Run the pfxStrokes MEL command on the converted
NURBS curve.
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Paint Effects strokes that had transformations applied to the strokes
themselves may sometimes appear different from 6.5 to 7.0.

Prior to 7.0, if a stroke painted on the view plane was rotated, and useNormal
was ON, the stroke may not be drawn correctly if it was dependant on the
stroke normal. If you have older files where you have adjusted some paint
effects brush attributes to compensate for the draw problems with transformed
strokes, these strokes may appear different in 7.0. Strokes painted on a surface
should not have this problem.

Workaround

Re-adjust those same attributes that were used to compensate originally, if
that information is still available. If it is not, you can convert the strokes to
polygons in 6.5 and delete history for an accurate match. You may also find
that modifying the normal on the stroke node may help you to match the
pre-7.0 look of the stroke.

Missing comma in output of pfxstrokes command

The file output of the pfxstrokes command was modified in Maya 7.0 to add
a missing comma. The comma location is following the normalZ value for
pfxHair nodes.

Workaround

Any user scripts created in Maya 6.5, or an earlier version of Maya, that
previously worked around this missing comma will need to be updated.

Pop-up menu on color boxes in Paint Effects Brush Settings window

The Paint Effects Brush Settings window has various color slider attributes on
which you can right-click and a pop-up menu appears. Of the items displayed
in this menu, only the Color Chooser item has any effect. The rest of these
items should be ignored as they will not change the behavior of the color
value.

Paint Effects Mesh brushes

The interpolation for Paint Effects triangles with Mesh brushes may result in
distorted textures where the triangle count is low.

Workaround

Increase the triangle density on the brush or convert the Paint Effects strokes
to polygons to render.

62 | Chapter 12   Artisan, 3D Paint, and Paint Effects



Film fit adversely affects Paint Effects

Workaround

Set the film aspect ratio to match the xres/yres, or the value shown in the
Device Aspect Ratio in the Render Settings window. Be careful not to push
the film aspect too far (too low in the example file) or the perspective will
change.

Renaming strokes with brush springs

If a Paint Effects stroke has brush springs and the brush is renamed, the springs
may no longer evaluate correctly.

Workaround

Rename the brush back or edit the expressions to reference the new brush
name.

Interactive Performance Settings and redrawing strokes

If the Performance Settings for Paint Effects are set to Interactive, then
immediately following playback, updates to the selected stroke/brush will not
cause the stroke to be redrawn.

Workaround

Select some other object, then re-select the stroke. Interactive updates will
now work.

Strokes rendering white with light fog

Light fog causes Paint Effects strokes to render white.

Workaround

If the lights in your scene have light fog, turn off "Real Lights" for any brushes
that have "Illuminated" turned on.

Turbulence stops working during playback

Once it is turned off, turbulence stops working on Paint Effects stroke during
playback.

Workaround

Open the Flow Animation block in the Attribute Editor.
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Paint Effects canvas wrapping with Mesh and ThinLine brushes

Paint Effects brushes with a ThinLine or Mesh brushType do not wrap when
scene or canvas wrap is on.

Stroke shadows in IPR

Paint Effects strokes do not show up in IPR, but their cast shadows do.

Workaround

Hide the strokes before rendering to prevent the shadows from being shown.

Light linking

Paint Effects does not support light linking.

Field rendering

Paint Effects does not support Field Rendering.

Workaround

Render with the By Frame value set to 0.5 and interlace in a compositing
package.

Popping near the edge of a frame

Paint Effects renders can sometimes ‘pop’ where the stroke is near the edge
of the frame.

Workaround

Increasing the stamp density and transparency may fix this.

Scaled objects and jumping strokes

On objects that are scaled very large, Paint Effects strokes may ‘jump’ when
crossing isoparametric lines on the surface.

Workaround

To prevent this, apply the Freeze Transformations command to the object.

Z-up environment

Paint Effects gives unexpected results in a Z-up environment.
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Workaround

Set the environment to Y-up and restart Maya.

Freeze Transformations

Freeze Transformations does not work for Paint Effects strokes.

Transformations and units

Paint Effects can give unexpected transformation results if the units are not
set to centimeters.

Playing back scripts

Parameters that are dynamically set on stroke creation, such as pressure values
and settings, are not arguments to the stroke command itself. Playing back
scripts will therefore not exactly match what you created.

Changing Screenspace Width option

If you turn on Screenspace Width for an object like a tree, the tree size is now
based on the canvas scale, not the scene scale.

Workaround

Make the canvas scale equal to the scene scale, and then scale down the widths
of the tubes, flowers and leaves to the desired levels.

Modifying 3D Paint Tool textures in the Paint Effects canvas

A file texture may not update correctly when you try to use the Paint Effects
canvas to edit a texture map created with the 3D Paint Tool.

Workaround

Save the scene before trying to edit the texture in the Paint Effects canvas.

Most recent brushstroke gets re-drawn several pixels off

Using paint effects, some graphics cards may redraw the last stroke drawn a
few pixels off from where it was.
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Workaround

Before running Maya, set the environment variable
MAYA_RENDERVIEW_USE_TEXTURES to 1. Maya will then use an OpenGL
texture call to draw the stroke instead of the normal glDrawPixel call.

Particle clouds and Paint Effect Strokes don’t mix

After creating a Particle cloud emitter with Paint Effects strokes, the strokes
become clipped by cloud shapes in front of them.

Workaround

Composite the particle cloud seperately.

3D Paint issues with mental ray for Maya

When painting a texture with 3D Paint, mental ray for Maya will not pick up
new paint strokes automatically.

Workaround

Save either the texture being painted or the entire scene before rendering with
mental ray to ensure that all strokes are rendered correctly.
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Dynamics

Dynamics limitations
Particle system can have inconsistent results between disk cache and non
disk cache when using rand() in expression

Workaround

Seed the random number. For example, if(frame < 2) seed(1).

Rigid bodies have a different playback result after saving the scene

The cycle involved with the rigid solver causes a different evaluation order. This
problem has to do with to the DG evaluation order in a cycle.

Workaround

Before you save the scene that contains rigid bodies, do the following:

1 Select Solvers > Memory Caching > Delete.

2 Select Solvers > Memory Caching > Disable.

Interactive Playback limitations

Interactive Playback does not currently work with passive rigid bodies. For
example, if a passive rigid body is moved while the solver is playing, active rigid
bodies will only collide with the passive rigid body in its original position.
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Surface emission from a trimmed surface won’t reflect new holes

With surface emission from a trimmed surface, if you add more trims or untrim
the surface, the emission won't reflect the new holes.

Workaround

Bring up the geoConnector node associated with the emitter, and change the
tessellation value a little, for instance, from 200 to 201. This forces
re-tessellation, and the re-tessellation picks up the new trims correctly.

Rigid body keyframed passive to active resets incorrectly

Rigid body keyframed passive to active resets incorrectly if you don't freeze
transform.

Workaround

Model your object first, select Modify > Freeze Transformations, then set
active/passive keys, adding any fields as the last step.

Flow effects and curve flow don't work if units not in cm

Workaround

Set the scene units to cm, create a new scene, then reopen original scene.

File referencing not supported for particle expressions

Workaround

Put your particle expressions in the main file.

Fields and emitters don't convert particle positions

Fields and emitters don't convert particle positions for non-standard units

Workaround

Use standard units.

Particles may collide on creation

Particles may collide on creation when surface emitter is also a collision object.
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Workaround

Reverse the normal speed parameter of the surface emission.

Rotate pivot and instancing

Instancing does not handle situations where the rotate pivot is not at the
origin.

Workaround

See the script, createInstancerPivot.mel in the scripts/unsupported directory
(under the main Maya install directory). The script contains directions for use.

Hardware rendering with motion blur limitation

Hardware rendering with motion blur works only if the multipass value is set
at least as high as the motion blur value.

Identical rigid bodies may not collide

Two identical rigid bodies on top of one another may not collide.

Workaround

Scale, rotate, or translate one of the rigid bodies slightly.

Rigid bodies do not recognize non-planar polygons

Workaround

Triangulate the non-planar polygons.

Copying a rigid body/rigid constraint systems

When copying a rigid body/rigid constraint system, the copied constraint
does not connect to the copied rigid body.

Workaround

Turn on Duplicate Input Graph in the Edit > Duplicate options window.

Ghosting is not reliable on simulated objects such as particle simulations,
soft bodies, and rigid bodies

Ghosting is not reliable on simulated objects such as particle simulations, soft
bodies, rigid bodies, classic cloth and jiggle deformers.
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Workaround

Creating a disk cache for the simulation will typically allow ghosting to work
on the object.

Particles may not evaluate properly when using emit command to emit
particles

This problematic behavior may be the result of the expression not being
executed or Maya may be getting the incorrect amount of particles during
batch mode or prompt mode.

Workaround

Invoke getAttr on the count attribute in the order where the events are
expected to happen. The getAttr can be called from within a MEL script or
a regular expression as long as it happens once every frame.

Error messages appear if you modify soft body polygon topology

Modifying a polygon object's topology (by editing its upstream construction
history) after making it a soft body will result in error messages.

Workaround

Adjust the construction history as desired before creating the soft body, or
delete and recreate the soft body after such changes.

Exporting to .mi with dynamics

Exporting to .mi interactively may produce incorrect results with dynamics.

Workaround

Do one of the following:

■ Manually run up the scene to the current frame and export

■ Use batch export to .mi
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Rendering

General rendering limitations
The following lists miscellaneous rendering limitations and workarounds.

Incorrect path in Rendering documentation

A note in the topic “Render from the command line” states that Maya Terminal.term
sources a simple (Bourne) shell script to set up the environment:
/Applications/Autodesk/maya2009/Maya.app/Contents/bin/MayaENV.sh.

The correct path is:
/Applications/Autodesk/maya2010/Maya.app/Contents/bin/MayaENV.sh

mayabatch -render command obsolete

The mayabatch -render flag on Windows (maya -render on Linux/Mac OS X)
is obsolete and has been removed. Use the Render -r command instead.

Batch rendering from within Maya on Mac OS X writes to console and
mayaRender.log

On the Mac OS X platform, when you batch render from within Maya, the
output is sent to the Console Application as well as logged in
~/Library/Logs/Maya with the name mayaRender.log.

Batch render process does not exit upon completion

If you launch a batch render from within Maya, then launch another after the
first one is complete, you may receive a message asking you if you want to cancel
the current render. You can select yes if you are certain that your first batch
render is complete.
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Start frame/End frame/By frame values become corrupted when switching
renderers

Occasionally, when you set prefs for your Start frame, End frame, and By frame
values in the Render Settings: Common tab, these values may become
corrupted when you switch renderers.

Legacy scenes with connection error when switching render layers with
per-face assignment and material overrides

Occasionally, when switching render layers with per-face assignment and
material overrides in legacy scenes, an error may occur and the material
assignments may not appear correctly. To workaround this problem, run the
fixRenderLayerOutAdjustmentErrors.mel script as follows:

1 Open the Script Editor and select File > Source Script. Select
fixRenderLayerOutAdjustmentErrors.mel from the \scripts\others
directory of your installation directory.

2 In the Maya MEL command input line, enter
fixRenderLayerOutAdjustmentErrors.

Stereo support on Mac OS X platform

Stereoscopic feature is only supported on Mac OS X 10.5.6 and above.

Horizontal interlace mode inverted on Windows and Mac OS X

On the Windows and Mac OS X platforms, the horizontal interlace mode in
the stereo camera has inverted line drawing.

Workaround

Input the following command into the command line:

stereoCameraView -e -swapEyes StereoPanelEditor;

Note that this will swap the eyes for all stereo camera modes, so you must run
the command again to restore them to their previous state.

Video card switches to Basic mode when creating quad-buffer stereo on
Windows Vista

When creating quad-buffer stereo on Windows Vista, the video card driver
switches from Aero to Basic.
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Maya rendered PSD file not readable by PSD file texture

Rendering a layered PSD file, then attempting to load it back into Maya as a
PSD file texture results in a black texture.

Workaround

Use PSD and not PSD Layered when rendering out the texture.

Live controls do not work if you are not in Live mode

If you are having issues with the live controls not working, switch to Maya
Live mode.

Rendering workflow issues

Light-linking with plug-in lights

There are some problems involving light-linking with plug-in lights:

■ They do not appear in the Light-linking Editor or Relationship Editor.

■ The query option to the lightLink command does not work for plug-in
lights. This results in Lighting/shading > Select Objects Illuminated by
Light and Lighting/shading > Select Lights Illuminating Object failing.

Light Linking Editor and deleting lights

The Light Linking Editor sometimes gets confused when you delete lights
while using it. You may see error messages such as: “Error: No object matches
name: directionalLight1” after deleting a light. Also, the display of which
lights are selected can be incorrect after undoing a light’s deletion.

Workaround

Deselect everything in a modeling view to clear the editor.

Maya Software rendering limitations
The following lists miscellaneous software rendering limitations and
workarounds.
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Per-patch shading assignment

Per-patch shading assignment is currently not respected when software
rendering.

Optimized scene file location when using the -optimizeRender flag

When using the -optimizeRender flag, the location for the optimized scene
file to be created is based on the current project defined by the preferences or
by the MAYA_PROJECT environment variable.

Workaround

Provide the absolute path where you would like the optimized file to be created.

Raytraced shadows are not supported for Paint Effects

Raytraced shadows do not work with Paint Effects.

Workaround

Convert Paint Effects objects to polygons.

mental ray for Maya rendering limitations
The following lists the software limitations and workarounds for this version
of mental ray for Maya.

mental ray impacted by Hyperthreading

Intel CPUs offer hyperthreading as a feature to simulate additional logical
processors which are actually running on a single physical CPU. This feature
is intended to accelerate applications which make use of additional processors
for parallel execution like mental ray. However, since hyperthreads are not
able to deliver a performance gain like a physical processor but only about
15-25%, the performance increase may be small or not visible.

Workaround 1

Turn off hyperthreading when using mental ray.

Workaround 2

Disable “Auto Render Threads” and set the number of render threads manually.
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IPR and mental ray for Maya rendering and animated parameters

mental ray for Maya does not update animated parameters, including changes
to the time slider, when using IPR (Interactive Photorealistic Rendering).

IPR for mental ray for Maya limitations

Currently, IPR for mental ray for Maya does not support the following:

■ Level of detail camera updates

■ Smooth mesh preview using the hotkey 3

Shadow method is set to Simple by default; simple shadows are not
compatible with volume effects

The Shadow Method in the Quality tab of the Render Settings window: mental
ray tabs is set to Simple by default. Simple shadows are not compatible with
volume effects such as fluids, volume fur, particles and volume shaders and
therefore may not render shadow volume effects correctly.

Solution

Use Shadow Method Segments.

Light position and intersection point values are reversed when using the
Simple Shadow Method versus the volume engine

When using the Simple Shadow Method, the shadow ray passes the light
position in state->org and the intersection point in state->point. However,
these values are reversed when using the volume engine. This behavior is what
we expect of the current software.

Non-manifold geometries should be removed before rendering

Non-manifold geometries with approximation may cause Maya to stop
unexpectedly when using mental ray for Maya rendering. This is a known
limitation for mental ray for Maya. Therefore, non-manifold geometries should
be removed before rendering.

Material swatches do not update during mental ray IPR

When rendering in mental ray IPR, mental ray material swatches in the
Hypershade and Attribute Editor do not update with adjustments.

To get swatches re-rendered with mental ray, stop mental ray IPR.
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Fast subsurface scattering now more accurate but slower with final gather

Beginning Maya 2008, fast subsurface scattering is now more accurate when
used with final gather but it is also slower. This is because the
misss_lightmap_write() shader and all phenomena that use this shader now
perform additional calculations to assure quality.

Mayatomr plug-in must be loaded before importing files

Ensure that the Mayatomr plug-in is loaded before importing files. Otherwise,
if you import a file before loading the Mayatomr plug-in, you may encounter
errors when attempting to render in mental ray.

Final gather map visualizer limitation

When using the Enable Map Visualizer option or Final Gathering in the Render
Settings: Indirect Lighting tab, using the default final gather file name causes
no points to appear in the visualizer.

Workaround

Enter an absolute path for the Primary Final Gather File attribute instead of
using the default setting.

Particle rendering

You can render the following particle types with mental ray: Points, MultiPoint,
Spheres, Sprites, Streak, MultiStreak. The implementation builds on a geometry
shader that creates actual geometry from per-particle data which is then passed
on to mental ray for rendering.

Hardware particles are shaded in a way that is similar to software particles: a
shading group must be assigned to the particle shape, and its surface shader
completely determines the appearance of the particles. This implies that none
of the shading-related attributes are supported when rendering hardware
particles with mental ray.

spriteNumPP is unsupported; therefore, assigning different sprites on a
per-particle basis is impossible. mental ray and Maya Hardware may render
particles slightly differently.

Warning messages appear when importing scene files in Hypershade

When importing scene files containing mental ray nodes, you may see warning
messages such as:
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// Warning: 'Draft.message' is already connected to 'mentalray

ItemsList.options'. //

These warning messages, about pre-existing connections between mental ray
related node, are harmless and can be safely ignored.

A warning dialog box also appears when these warnings occur. If you are
importing many files and wish to avoid manually closing the warning dialog
box for every file, you may want to use the file command with -prompt false.

mental ray for Maya framebuffer only outputs 32-bit depth framebuffer

mental ray for Maya only outputs 32-bit depth framebuffer and not 16-bit.

Workaround

Use external tools to clamp the depth into the limited range for specific
applications. Compositing packages that cannot read 32-bit depth are rather
inappropriate and inconvenient for use with mental ray, since even color
values are 32-bit per component (HDR).

mental ray for Maya transfer maps limitation

If, in addition to baking a mental ray transfer map, you also:

■ bake a Maya transfer map with the .tif file format, and

■ you choose the Connect maps to shader option,

then, when you bake a mental ray transfer map for a second time, mental ray
generates an error.

mental ray does not understand the the LZW compressed TIF format.

Workaround:

You may do one of the following to avoid this error:

■ Use a mental ray friendly file format for your Maya transfer map, for
example, EXR or DDS.

■ Assign a different material to the source surface before baking your mental
ray transfer map for the second time.

■ Unselect the Connect maps to shader option.
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mental ray for Maya transfer Maps custom shaders limitation

When creating a Custom Map, Transfer Maps does not support baking Contour
shaders or Geometry shaders to texture. Only Material shaders (shaders listed
under the Materials section of the mental ray tab in the Create Render Node
window) can be baked to texture. Ensure that your custom shader is recognized
as a material shader in Maya.

Removal of Zpic support

The Softimage Depth (Zpic) file format is no longer supported for mental ray
for Maya rendering.

mental ray mia_roundcorners shader to be used with double-sided geometry

The mental ray mia_roundcorners shader must be used with double-sided
geometry.

Batch render may not generate an output image file if mental ray output
shader contains a parameter of type ‘geometry’

If a scene contains a mental ray output shader that has a parameter of type
'geometry', then a batch render will not generate an output image file. No
error messages appear, but there will not be an image file when the render
completes.

Workaround

Change the parameter to another type such as 'integer'.

Surface changes during animation is not supported for mental ray for Maya
motion blur

Surface changes (for example, changes to the number of vertices) during
animation is not supported for mental ray for Maya motion blur. If the motion
interval is large, so that the topology change occurs within this interval, mental
ray issues the warning message “Shapes are not equivalent, no motion vectors
computed” and skips motion data computation on the shape.

Baking to one map in mental ray uses wrong UV set

When Bake to one map is enabled, mental ray currently only bakes the default
UV set, regardless of the specified current UV set on the object.
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Workaround

Use override mesh UV set assignments, and rename all UV sets to that name.

mental ray does not support multiple motion transforms

Multiple motion transforms is not supported by mental ray for Maya. To
obtain curved motion blur, animation should be applied to the shape node
and not to the transform. In addition, you must enable the Export Motion
Segments option in the Render Settings: Options tab, under the Translation
section, Performance sub-section.

Image plane renders darker when mia_physicalsun shader is used

When you add the mia_physicalsun and mia_physicalsky to your scene using
the Create button in the Environment section of the Render Settings, a network
of nodes is automatically created, which includes the mia_exposure_simple
shader that adjusts exposure. The mia_exposure_simple shader is added to the
network because the mia_physicalsun and mia_physicalsky shaders create
physically correct high dynamic range images that, when viewed without
exposure control, will appear all white in the render view. The
mia_exposure_simple shader not only affects the sun and sky but rather the
entire scene including image planes. A standard image plane will appear darker
relative to the bright sky. You can adjust the image plane's brightness using
its Color Gain and Color Offset attributes, or using the attributes of the
mia_exposure_simple shader.

mental ray volume fur may produce artifacts on tile edges

Occasionally, mental ray volume fur may produce artifacts in the shadowing
on tile edges.

Workaround

Use a single tile for the whole image. However, the drawback is that a large
amount of memory is required and only one core on the machine is used for
rendering.

Incorrect bounding boxes reported for fur node

Maya reports incorrect (zero) bounding boxes for its FurFeedback nodes.

Workaround

Enable Show > Locators and the bounding boxes will be correct.
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Multi-render passes limitations

2D Motion Vector pass limitations

File format for 2D Motion Vector pass

The 2D Motion Vector pass requires a 32-bit output. Therefore, when creating
this pass, you must select openEXR as your file format. However, since you
cannot select a different file format for each render pass, all passes must be
written to an openEXR file whenever your list of passes include the 2D Motion
Vector pass. This limitation does not apply to the Normalized 2D Motion
Vector pass.

Using the 2D Motion Vector pass with Toxik

The 2D Motion Vector pass in mental ray for Maya is 3-channel, and does not
support 4-channels.

Workaround

To use the extend option on the blur node in Toxik, you can render a coverage
pass and use Set Alpha in Toxik.

mental ray sun and sky shaders may cause passes to be brighter than normal

Passes may appear brighter than usual when you use the mia_physicalsun and
mia_physicalsky shaders with the multi-render passes. In particular, the
refraction pass produces the most noticeable difference.

Workaround

Avoid using the mia_physicalsun and mia_physicalsky shaders with the
multi-render passes feature. If you must use these shaders in your scene, you
can workaround the problem by rendering to .exr format and then do the
necessary tone mapping in the compositing software (for example, Toxik).

Rendering motion vectors increases memory consumption

When rendering motion vectors with BSP2, memory consumption may be
higher, just as with rendering with motion blur. If memory runs low, try using
BSP or Large BSP instead.

80 | Chapter 14   Rendering



Render proxy limitations

■ If your render proxy contains textures, then, when you export your render
proxy, you must select the Absolute option under the Texture file category
in the Export Selection Options window, Export file paths section.

■ Render proxy is currently only supported for static geometry. Therefore,
if you put a deformer on a file and animate it and export it as a proxy,
mental ray for Maya will only read the last frame when it is loaded in a
new file.

■ You cannot load a proxy into a file and try and put a deformer on it. You
should avoid modifying the proxy shape (in other words, avoid changing
the bounding box size in the Maya scene), otherwise, you may get
clamping.

Using autovolume may cause a render with shadows even if there are no
lights in the scene

Using autovolume may cause shadows to appear in the render even when
there are no lights in the scene.

Short name displayed incorrectly when adding a new attribute to a mental
ray base shader

Appending a new attribute to any of the mental ray base shaders cause the
shortname of the output value to be displayed incorrectly.

Workaround

Add explicit short name to the output parameters in the .mi declaration, then
save the Maya file with the option Use full names for attributes on nodes
enabled under the File Type Specific Options section in the Save Scene As
Options window.

Changing the Verbosity Level via mentalrayGlobals does not work

Changing the Verbosity Level for messages through the mentalrayGlobals
does not work.

Workaround

Change the verbosity level through Render > Render Current Frame > 
instead.
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.mi file created from Maya 2009 does not render in Maya 2010 standalone

If you export a scene as a .mi file using Maya 2009, issues may occur if you
try and render the .mi file using Maya 2010 standalone.

Workaround

To workaround this problem, open the scene in Maya 2010 and re-export it
as a .mi file.

Hardware rendering limitations
This section contains information about the unsupported features, limitations
and workarounds for Hardware rendering.

Known limitations

Cube map is not affected by translation and scale

The translation and scale on the environment cube map are not taken into
consideration by the hardware renderer. The cube map will render very
differently compared to software rendering. There is no workaround for this
limitation.

Hardware renderer performance is slow when baking projected textures

The hardware renderer performance is slow when baking projected textures.

Workaround: Reduce the baking resolution (Color resolution, Bump resolution)
in the Render Settings: Maya Hardware tab.

Hardware renderer limitation with displaying mental ray area lights

When displaying mental ray area lights, the hardware renderer does not
provide the same results as an actual render, but instead produces a very rough
approximation that can be viewed in High Quality mode.

The Maya hardware renderer supports the following configuration for mental
ray area lights:

■ A Maya area light must be used.

■ Only the Rectangle mental ray area light shape is supported.

■ Basic light parameters such as Color, Intensity, Decay Rate are supported.
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■ An approximation of shadows is supported.

■ A fixed point sampling rate is used for both diffuse and specular highlights.
Sampling artifacts may occur, especially for specular highlights where the
area of the light is large and the light is close to the surface.

■ Other light shapes and options such as High Samples, High Sample Limit
and Low Samples are not supported.

Hardware renderer doesn't correctly sort transparent polys and there are
artifacts on transparency mapped objects

If objects or parts of objects with different shaders have overlapping 3D
bounded regions with respect to the camera, then the transparency sorting
may not be as expected with respect to a software rendering.

This is due to the fact that the hardware renderer does not sort on a per pixel
basis. There are basically two modes for transparency sorting in the Render
Settings:

■ Per Object

■ Per Polygon

The axis aligned world space bounding box of objects is used as the main
criteria for depth sorting with respect the current camera used for rendering.

For Per Object, objects are sorted from furthest to closest in depth to the
camera. The distance measurement is from the center of the bounding box
to the camera “look from” position. If more than one shader is assigned to an
object, then each part of the object will have its bounding box computed.
Each distinct part is called a shader section and the box, the shader bounds.
If the whole object uses one shader then the shader bounds" are equivalent
to the bounds for the entire object. The shader bounds are sorted from back
to front.

Per Polygon provides further sorting refinement. The polygons are sorted for
each object from back to front. When drawing the depth-sorted shader bounds
the polygons are drawn from back to front. If this option was not turned on,
then the polygons would be drawn in arbitrary order per shader bounds.

Workaround

For possible better sorting, the you can either:

■ Split up polygons of the object into separate objects.
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■ Split up single shader regions on single objects into separate objects with
one shader per object.

Hardware renderer clipping planes deviates from the default behavior of
the software renderer and the mental ray renderer

For the software renderer and the mental ray renderer, if part of an object is
beyond the far clipping plane, the entire object is rendered, including the part
beyond the far clipping plane.

However, for the hardware renderer, if part of an object is beyond the far
clipping plane, then only the part of the object that is in front of the far
clipping plane is rendered. Parts of the object that is beyond the far clipping
plane is clipped and not rendered.

Ashli shader plug-in now part of Bonus Tools

As of Maya 2009, the ASHLI plug-in is now available as part of the Maya Bonus
Tools. Bonus Tools is a free collection of useful Maya scripts and plug-ins that
are available from the Autodesk Web site
(http://www.autodesk.com/maya-bonustools).

ATI Ashli hardware shader plug-in unstable on 64-bit Linux

The ATI Ashli hardware shader plug-in is unstable on 64-bit Linux, and can
cause Maya to crash when loading in shader files for display.

Shadows broken with newest version of Cg on nVidia cards

(Windows, Linux) We have supplied the beta 2 version of the Cg 1.5 libraries.
Shadows do not work properly with later versions of these libraries on nVidia
cards (on all platforms). ATI cards do not appear to have this problem.

(Mac OS X) Because a universal binary library version is required, we have
supplied the 1.5.0012 version of the Cg libraries. On nVidia cards using Mac
OS X 10.4.8, shadows do not render properly.

You can replace the Cg libraries in the run-time area with new versions for
CgFx plugin shader development. However, we do not qualify or support
newer versions of the libraries (for example, they will show this shadow
problem).

Vector rendering limitations
The following lists the Vector rendering limitations and workarounds.
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Do not combine frames created from different operating systems

Do not combine frames created from vector rendering on different operating
systems (for example, a 32-bit operating system and a 64-bit operating system)
as there may be slight differences in the renderer output.

Backburner rendering limitations
When rendering with Backburner as a service, Maya may not use all
processors available

When rendering with Backburner server setup as a service, Maya may not use
all the processors available on the computer when rendering.

Workaround

1 After installing the Backburner service, go to the Services Control Manager.

2 Open the Backburner Service properties.

3 In the Log On tab select Log on as this account.

4 Specify a username and password.

5 Start Maya and create preferences for the username and password created
in step 4.
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Maya nDynamics

General nDynamics limitations
The following lists miscellaneous nDynamics limitations and workarounds.

Combining hidden and visible Nucleus objects

If you have both hidden and visible Nucleus objects in a scene and assigned to
the same Nucleus solver, the simulation may not play back the same way as it
would if all Nucleus objects were visible in the scene.

Workaround

To hide Nucleus objects or animate their visibility during a simulation, but have
the simulation play back as if all Nucleus objects were visible, cache the
simulation with all objects visible. Select and hide any Nucleus object you don’t
want visible in the final simulation.

Caching nParticles with previously cached nCloth objects

When you cache an nParticle object at the same time as two or more nCloth
objects that are already cached in the same cache file, the nCloth objects in the
resulting cache do not behave as expected if the One file per geometry option
is not used.

Workaround

If you want to cache nCloth and nParticle objects together in the same scene,
make sure you select One file per geometry in the Create nCache Options
window when setting your nCloth and nParticle nCache options.
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Cached nParticles do not collide with nCloth

If you nCache an nParticle object that collides with nCloth, the nParticles do
not collide with the nCloth object when the simulation is played back.

Workaround

nCache the nParticle and nCloth object at the same time. Ensure that you
select One file per geometry in the Create nCache Options window when
setting your nCloth and nParticle nCache options.
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Maya nCloth

General nCloth limitations
The following lists miscellaneous nCloth limitations and workarounds.

Assign Solver does not assign an orphaned nCloth object to a Nucleus solver

If an nCloth is created but not assigned to a Nucleus solver, using the nSolver
> Assign Solver menu item to assign the object to a solver does not work. Instead,
a “Selected object does not belong to an nSolver" error message appears and the
object does not get connected to the solver.

Workaround

Use the addActiveToNSystem MEL proc to connect the new nCloth object to an
existing nucleus solver. For example, use addActiveToNSystem("nClothShape2",
"nucleus1");

nRigid collision display off from nRigid objects

If all the nCloth objects in a scene are cached, the nRigid collision display will
appear one frame off from nRigid after caching the objects.

Workaround

Add a very small un-cached nCloth object to the scene.

Changing the topology of a passive collsion object after the start frame

If you change the topology of a passive collision object with an nConstraint
after the start frame, and the resulting frame has fewer vertices or faces, Maya
may stop indefinitely if you immediately resume playback.
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Workaround

Go to the start of the playback range before playing back the scene.

Weld Adjacent Borders constraint and file saving

If an nCloth object is constrained using the Weld Adjacent Borders constraint
and the file is saved at a frame other than the start frame and then re-opened,
the re-loaded scene will not update the constraint properly during playback.

Workaround

Return to the start of the playback range before saving.

nConstraints on wrapped surface

If an nCloth object uses a mesh as a wrap deformer and then an nConstraint
is created between the nCloth and the mesh surface, the constraint will have
no affect.

Workaround

Make the wrap shape a passive collision object and then create the constraint.

Removing tearable constraints

If you remove a tearable constraint from a surface using Remove Dynamic
Constraint, the nCloth will still tear when you simulate.

Workaround

In the Hypergraph, select and delete the polySplitVert, polyMergeVert and
polySoftEdge nodes.

High Max Distance values on the dynamicConstraintShape node may cause
Maya to crash

When using Max Distance on an nConstraint (dynamicConstraintShape node)
to specify which Nucleus object components participate in the constraint, the
resulting connections may be such that each component of each object are
constrained to each other. This results in poor performance, and, in some
cases, for large nCloth meshes or nParticle systems, may use all available
memory.
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Workaround

On the dynamicConstraintShape node, lower the Connection Density to a
value that leaves the connections sparse enough for good performance, but
also leaves enough connections between the objects’ components to maintain
the original simulated behavior.

Topology changes during simulation

Topology changes (modifications to the mesh surface that change vertices)
while simulating nCloth are not supported for Maya 2008. Changing the
topology of nCloth objects may result in collision failures.

Vertex maps and constraints

In Maya 2008, you can only create painted vertex maps for constraints that
connect vertices to vertices.

Creating nCloth from referenced files

When creating cloth objects using geometry from referenced files, if you
unload the reference and then save the file, you may see erroneous geometry
on the reference node.

nCloth does not cache properly when its input mesh is driven by a geometry
cache

If the input mesh on an nCloth object is driven by a geometry cache, many
nCache operations will work on the geometry cache instead of on the nCloth
cache.

Workaround

1 Select the nCloth object, and then from the Animation menu set, select
Edit Deformers > Display Intermediate Objects.

All the upstream shapes, including the nCloth input mesh and the
pre-geometry-cache mesh are displayed.

2 To select the output mesh shape, either pick-walk down from the
Transform node, and then pick-walk right until the output cloth mesh
is selected. Or, in the Attribute Editor, select the OutputMesh tab.

3 Hide the upstream mesh, by selecting Edit Deformers > Hide Intermediate
Objects from the Animation menu set.

4 From the nDynamics menu, select nMesh > Display Current Mesh to
hide the input mesh.
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Smoothing and caching

If you create a low resolution model and create an nCache for it, then add a
polysmooth and create an nCache the new smoothed model, Maya will
re-cache the old the low resolution model instead.

Workaround

After creating the new cache for the smoothed object, select Edit > Delete All
by Type > History. Then select Geometry Cache > Import to attach the cache
of the smoothed geometry.

Caching nCloth objects with changing topology

Caching produces useful results on objects whose topology does not change
over time. Some animated modeling construction history operations result in
topology changes over time. While you can create a cache for these objects,
it may distort the object during playback since a constant topology is assumed.

Painted wrinkle maps do not work after Initial State is set

If a wrinkle map is applied to nCloth using Paint Vertex Properties, it may
only affect the nCloth object during the first simulation playback. If you set
the Initial State of the nCloth object, and then play back the simulation, the
painted wrinkle map may not affect the nCloth object's behavior.

Workaround

Animating the Wrinkle Map Scale will force the wrinkle to update. You can
do this by using a simple expression to set the Wrinkle Map Scale value. For
example add an equal sign (=) before the Wrinkle Map Scale Value.

Last Tool and painting nCloth

When painting nCloth property texture maps, painting cannot be reinvoked
with the Last Tool (default hotkey “y”) function.

Component to Component constraints updating per frame

Setting the Connection Update attribute on the dynamicConstraint node to Per
Frame, when using a component to component constraint has no effect.

Thickness map in shaded mode

When painting the collision thickness of an object with Face collisions in
shaded mode, it may be difficult to see mapped variations in thickness.
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Workaround

View your scene in Wireframe mode (Shading > Wireframe).

Collision Thickness display

When modifying an nCloth passive collision object with the Solver Display
(nClothShape node) set to Collision Thickness, the scene view may not
immediately update to match your adjustments.

Workaround

Advance a frame, or rewind to the start frame to update the scene view.

nCloth jiggles or oscillates when Push Out Radius is less than collision
Thickness

When an nCloth object's Push Out Radius is set to a lower value than its
collision Thickness, the nCloth may jiggle or oscillate after colliding with
other Nucleus objects.

Workaround

Set the nCloth object's Push Out Radius to a value that is greater than its
collision Thickness value.

Transference of downstream connections from nCloth input meshes to
output meshes

Downstream connections from an nCloth’s input mesh are not, in general,
transferred to the output mesh when the input mesh is turned into nCloth.

The only exceptions are connections between the input mesh’s World Space
values (worldMesh on the poly mesh node) and a wrap node’s Wrap Attributes
(driverPoints on the wrap node). These connections are transferred.

Workaround

Transfer the connections from the input mesh to the output mesh manually,
or with a script.

Negative Push Out values

Negative Push Out (nClothShape node) values are intended for objects with
normals reversed. The current behavior only flips the sense of normal when
the Push Out value is -1.0, or less. This makes it impossible to create subtle
push outs on the reverse side of a surface.
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Workaround

To get expected results, flip the normals on the surface, and use a positive
Push Out value.

Lift attribute affected by nCloth object size

When the same nCloth object is scaled to different sizes that have the same
Lift attribute value, the scaled nCloth objects may behave differently when
simulated.

Workaround

Adjust the Lift attribute of each scaled nCloth object until the desired behavior
is achieved.
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Maya nParticles

General nParticles limitations
The following lists miscellaneous nParticle limitations and workarounds.

Resetting the nParticle Tool reverts to the classic Particle Tool window

Selecting Reset Tool when using the nParticle Tool, the Tool Settings window
changes from the nParticle Tool settings to the classic Particle Tool settings.

Workaround

1 After resetting the nParticle Tool, close the Tool Settings window that
appears.

2 Reopen the nParticle Tool settings window by selecting nParticles > Create

nParticles > nParticle Tool >  .

Undoing nParticle creation may not immediately remove nParticles from the
scene

If you want to undo the creation of an nParticle system, you may need to
perform an Undo (Edit > Undo) two or more times before the nParticle system
is removed from your scene.

Duplicate nParticle objects with no connections do not play back in saved
scene files

Duplicate nParticle objects play back correctly in your scene; however, if the
scene file is saved and then opened in Maya, the duplicate nParticle object does
not play back correctly. This occurs because the duplicated nParticle object must
be assigned to a Nucleus solver and must be connected to time.

17

95



Workaround

1 Use the addActiveToNSystem MEL proc to connect the new nParticle
object to an existing nucleus solver. For example, use
addActiveToNSystem("nParticleShape2", "nucleus1");

If you connect the duplicated nParticle object to a different solver (than
the original) you will need to save, and then reopen the file before the
simulation plays back properly.

2 Connect the nParticle object to time using the following command line:
connectAttr time1.outTime nParticleShape2.currentTime;

3 To assign your duplicated nParticle object to an emitter, use the Dynamic
Relationships editor to make the connection.

An nParticle object duplicated at an advanced frame may crash Maya

If you duplicate an nParticle system at an advanced frame of a simulation,
and then continue to play it back, Maya may crash.

Workaround

Do one of the following:

■ Create the duplicate nParticle system at or before the start frame of the
simulation

■ Rewind the simulation immediately after duplicating the object, and then
play it back.

Assign Solver does not assign an orphaned nParticle object to a Nucleus
solver

If an nParticle is created but not assigned to a Nucleus solver, using the nSolver
> Assign Solver menu item to assign the object to a solver does not work.
Instead, a “Selected object does not belong to an nSolver" error message appears
and the object does not get connected to the solver.

Workaround

Use the addActiveToNSystem MEL proc to connect the new nParticle object
to an existing nucleus solver. For example, use
addActiveToNSystem("nParticleShape2", "nucleus1");
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nParticle to nParticle collisions unstable when Bounce is 0

Collisions that occur between the individual nParticles of two nParticle systems
(not nParticle self-collisions) are exaggerated when the Bounce attribute on
both nParticle objects is set to 0.

Workaround

Set the Bounce attribute on one of the colliding nParticles objects to a very
low value such as 0.001.

Leading frames without nParticles are omitted from nParticle cache

If you cache an nParticle system in which the leading frames have no particles,
the leading frames will not be included in the nCache. Maya then sets the
cache range to the first frame that a particle appears in the scene, and the
leading frames of the simulation are treated as uncached. This means that an
unlimited license will be necessary to batch render the simulation which
includes the empty leading frames.

Workaround

If all the objects in your simulation are cached, disable the Nucleus node (turn
off Enable in the Nucleus node Attribute Editor) when batch rendering.

nParticle cache blend and merge not working

Maya 2010 does not support blending and merging of nParticle caches.

Error message appears when caching nParticles

If you created an nParticle nCache in which no particles are present in the
initial frames of the simulation, an error message appears, indicating that
there is no cache file or an empty cache file for those initial frames. The error
message may also appear if you create a cache immediately after starting Maya
with newly created preferences. This is due to some preferences not being
initialized.

Workaround

Play back your nParticle cache. If the simulation behaves as expected, ignore
the error message. If your simulation does not behave as expected, delete the
cache, if one exists, and then open the Create nCache Options window. Create
the cache again.
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nParticle collisionTime only accurate to the nearest frame

For nParticles, collisionTime returns a value that is only accurate to the nearest
frame.

Workaround

Estimate collision time by calculating the value from the nParticle position
and velocity in the previous frames of the simulation.

Scripting nParticle creation invokes other commands

Using the nParticle command, the particleFill command, or the
NCreateEmitter script, invokes some lower level scripts with evalDeferred.
If you want to use these commands in a script and then access any per-particle
dynamic attributes in the same script, you need to first allow the deferred
commands the chance to catch up.

Workaround

Insert a command that lists each evalDeferred such as to flush out all the
deferred commands.
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Maya Fur

General Fur limitations
Fur stamp unexpectedly renders above paintFX stroke stamps

The camera renders fur stamps above paintFX stamps unexpectedly.

Workaround

To correct this, create a new camera and match the camera with the broken
camera.

PolySmooth node causes Fur to flicker

If pre-Maya 6.5 files have polygon objects with Poly Smooth applied after
skinning, and the Smooth UVs option turned on, there will be flickering in the
animation of rendered Fur, or the motion blur.

Workaround

To correct this, execute setAttr smoothNode.ma 1; in the Script Editor and turn
off Smooth UVs in the smooth node.

This does not happen for scene files created in Maya 6.5, as long as Smooth UVs
is turned off.

Using Chord Height Ratio can cause Fur to flip

Fur that is applied to a NURBS surface, for which Use Chord Height Ratio has
been turned on, may flip and point in the opposite direction on some frames
of a multi-frame render. The Chord Height Ratio attribute is located under
Secondary Tessellation Attributes in the Advanced Tesselation section of the
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Attribute Editor. Confirm that Use Chord Height Ratio is not turned on before
rendering.

Fur doesn’t recognize volume light

Fur does not recognize volume lights - light emitted from a volume light will
have no effect on the fur render.

Rendering high resolution

Fur runs out of memory when you render at 8K x 8K or higher resolution.
There is no workaround.

Limitations when rendering Fur in the Maya
Software renderer

Degree 1 NURBS surfaces tessellate extremely highly

Degree 1 NURBS surfaces produce extremely heavy geometry when tessellated
for Fur, thus taking longer to process and producing large intermediate files.

Workaround

Convert the geometry to polygons.

Fur does not render correctly in orthographic views

Fur renders at an incorrect size in the orthographic views in the Maya software
renderer.

Workaround

Render Fur in mental images® mental ray® for Maya.

Fur does not support Field Rendering

If Field Rendering is turned on in Maya, Fur will ignore it and render frames.

Workaround

Render with the By Frame value set to 0.5 and interlace in a compositing
package.
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Fur does not render at all if the camera is scaled negatively

Fur cannot be rendered with a negatively scaled camera.

Fur renders as a grid when a spotlight has a Penumbra Angle

Fur may render as a grid when a spotlight with a shadow map has a Penumbra
Angle.

Workaround

Set the value for Penumbra Angle to zero. Alternatively, increase the size of
the shadow map until the grid artifacts disappear.

Fur does not support any of the 16 bit image formats

Fur does not support any of the 16 bit image formats.

Workaround

Fur will be correctly composited when rendered to a 16 bit file format; however,
the Fur pass itself will still be 8 bit. Set the rendered image format to a
supported image format.

Or render in mental ray for Maya.

Using spotlight penumbras and drop-off with fur shadowing

Although fur shadow maps can be used with spotlight penumbras and drop-off,
the fur shadows are not affected by these values, so there is no fall-off to the
fur shadow. The fur shadows may look too sharp at the edges.

Fur does not support texture mapped lights

Fur does not support texture mapped lights.

Workaround

Render in mental ray for Maya.

Using Chord Height Ration can cause Fur to flip

Fur that is applied to a NURBS surface for which Use Chord Height Ratio has
been turned on may flip and point in the opposite direction on some frames
of a multi-frame render. The Chord Height Ratio attribute is located under
Secondary Tessellation Attributes in the Advanced Tesselation section of the
Attribute Editor.
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Workaround

Confirm that Use Chord Height Ratio is not turned on before rendering.

Maya may run out of memory when rendering Fur with very large shadow
maps

Rendering Fur with very large shadow maps can cause Maya to run out of
memory.

Workaround

Reduce the size of the shadow map and/or the Hairs/Pixel value for Shadow
Map Rendering in Fur Globals.

Limitations when rendering Fur in mental ray for
Maya

Fur on instanced objects not rendering

Fur cannot be rendered in mental ray for Maya on instanced objects if Group
Under > New Group was selected in Duplicate Options.

Motion blur not working

If the Segments attribute is keyframed, motion blur won’t work in mental ray
for Maya.
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Maya Live

General scene limitations
The following limitations and workarounds relate to general scene issues with
Autodesk® Maya® Live™.

Forced to set distance value to zero

Values set as Distance Constraints in the Survey Panel sometimes get reset to
zero.

Workaround

Enter the desired value in the Attribute Editor or by using MEL commands.

Errors if you open a file before loading Maya Live plug-in

If you open a Maya Live file before loading the Maya Live plug-in you get errors.

Workaround

Load Maya Live plug-in before starting work in Maya Live.

Resizing Live window

Some Maya Live functionality goes out of view when you resize the window to
a smaller dimension.

Workaround

Use Maya Live in its full screen display for all options to be accessible.

19

103



Save changes prompt

Choosing Scene > New Matchmove sometimes prompts you to save
changes—even if you have not made any changes in the scene.

Setup limitations
The following limitations and workarounds relate to setup issues with Maya
Live.

Display of Softimage image files

If the Use Cache check box is turned off, Avid® Softimage® image files that
lack the .pic extension will not display.

Workaround

Do one the following: rename images to include .pic extension, convert to
another format, or turn on the Use Cache check box on the Setup Cache
control panel.

Image plane streaks

Occasionally, images do not display correctly on the image plane and the
pixels on the right side of the image appear as streaks.

Workaround

This problem occurs when there is not enough texture memory on the
machine. Open the Setup Cache control panel and choose None in the Texture
Method parameter.

Track limitations
The following limitations and workarounds relate to track issues with Maya
Live.

Deleting track points

If you undo the deletion of a track point that was used in a solution, only the
associated 3D locator reappears.
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Workaround

Choose Edit > Undo again to bring back the track point.

Manipulating track boxes

You may have difficulty selecting and resizing track boxes in the
pointCenteredCamera view panel.

Message from positioning track boxes

When you position a track box, the following message appears in the Script
Editor:

// Undo: dragTrackedPoint_doDrag //.

Workaround

Ignore the message.

Refresh of track point names

When you change the name of a track point or a survey constraint in the
control panel, the label name does not change in the view panels.

Workaround

Wait for the next time the view panels refresh.

Deselected Track Box Tool

Saving your scene deselects the Track Box Tool.

Workaround

Re-select the Track Box tool if you want to drag a point.

Ready-to-Solve bar remains red

When you prepare to solve for object motion (using the As Object checkbox),
the Ready-to-Solve indicators in the Track Summary may remain red. This
occurs because the Ready-to-Solve indicators are based on camera solvability.

Workaround

Ignore the red indicators and continue with the Solve task.

Track limitations | 105



Solve limitations
The following limitations and workarounds relate to solve issues with Maya
Live.

Undo of Start, Continue, or Refine

Errors occur if you undo the Start, Continue, or Refine step.

Workaround

Delete the resulting solution instead of choosing Edit > Undo.

Root Frame solver failure

Occasionally, the Root Frame solver fails and the following message appears
in the Script Editor:

// Error; // Exception. // // Error; // Solve Failed. //

Workaround

Click Solve or Start again and the solver will work.

Playblast frame range

The Playblast button on the Solve control panel plays the entire frame range
rather than the frames specified in the Solve control panel.

Workaround

Select the frame range in the Time Slider bar instead.

Survey constraint Variance fields

The solver performs poorly if you enter a value of zero in any of the survey
constraint Variance fields.

Workaround

Avoid entering zero in the survey constraint Variance fields.
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Maya Fluid Effects

Fluid Effects limitations
Fluids with temperature turbulence and backward compatibility

If you have old fluids from 7.0.1 or earlier that use temperature turbulence,
their simulations will play back differently each time they are played due to the
backward compatibility settings.

Workaround

If you don't want to keep this random behavior, run the following MEL script
for each fluidShape that uses temperature turbulence:

setAttr fluidShape.usePre70Dynamics false;

Like-named fluids cause cache problems

If you have a scene that contains 2 or more fluids, and their fluidShape nodes
have the same name, then fluid caching will not work correctly for those fluids.

Workaround

Make sure that the fluid nodes in your scene have unique names if you intend
to cache them.

Fluids cache nodes may be named incorrectly

If you create a cache or initial state for a referenced fluid or a fluid in a
namespace, the cache nodes will be named incorrectly. For example, if you
create a cache for fluffy:fluidShape1, the cache node may be named fluidShape1.
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Workaround

Rename the cache node to initialState_fluidShape1 or cache_fluidShape1 as
appropriate.

Source caches of merged fluid nCaches must be disabled or deleted

When fluid nCaches are merged, each source cache file must either be disabled
or deleted. Otherwise, the cached fluid simulation may not play back as
expected.

Workaround

Disable or delete the source fluid caches by doing one of the following:

■ To disable caches, select the fluid objects, and then from the Dynamics
menu set, select Fluid nCache > Disable All Caches On Selected.

■ To delete the source caches clips after they have been merged, in the Merge
Fluid Cache Options window, select Cache: Delete existing caches after
merge.

Fluid cache files that contain more than one fluid object may not play back
as expected

Fluid cache files that contain more than one cached fluid object may not play
back as expected. This is especially the case when the caches are blended or
merged with other fluid nCache files.

Workaround

Select, and then cache each fluid object separately so that the cache files
contain only one fluid object.

Maya does not re-simulate missing fluid caches during batch renders

During batch renders from the cache, Maya no longer attempts to re-simulate
when it cannot locate a fluid cache. With fluids nCaching, Maya issues an
error message indicating that it cannot locate a fluid cache file. This behavior
differs from the previous version of fluids caching.

Cached channels do not attach properly when attaching an existing fluid
cache

Attaching an existing fluid cache file (using Attach Existing Cache File) does
not attach all the channels from the cache file. Even if the cache, which is to
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be attached, has the same channels as the cache node connected to the fluid,
the names of the channels are not specified in full, and only the Density data
(first channel) is sent to the fluid.

Workaround

Specify the channels you want to cache in the order they were connected.
Ensure that you use the full name of each channel as it’s listed in the XML
file. For example:

setAttr -typ "string" fluidShape1Cache1.channel[0] "fluid

Shape1_density";

setAttr -typ "string" fluidShape1Cache1.channel[1] "fluidShape1_ve

locity";

If the attached cache contains additional channels, open the Hypergraph to
see the names that are associated with each channel.

Append to Cache does not work for painted, non simulated fluid frames

There are two associated limitations:

■ Append to Cache (Fluid nCache > Append to Cache) does not work for
non simulated fluid frames that are painted using the Paint Fluids Tool.
To append a paint cache frame, you must use Replace Cache Frame.

■ Replacing a painted cache frame only works when the Replace Fluid Cache
Frame(s) Options window is open.

Workaround

To append a painted or imported frames to the end of a fluids cache, do the
following:

1 Append the unmodified frame (Fluid nCache > Append to Cache).

2 Make the desired modifications to the frame.

3 Replace the appended frame by selecting Fluid nCache > Replace Cache

Frame >  .

In order for the replace frame operation to work, you must leave the
Replace Fluid Cache Frame(s) Options window open.

4 Click Replace.
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MR render does not read fluid names properly

mental ray for Maya will render an animation incorrectly if fluid names are
not unique.

Workaround

Ensure that each fluid shape in your scene has a unique name; when
duplicating a fluid, make sure that Assign Unique Name is turned on.

Fluid texture not updating

A fluid texture does not update if not connected on outColor. When rendering
in mental ray for Maya if the fluid is only connected on outAlpha, it does no
t update.

Workaround

Insert a luminance node between your fluid texture and the shader.

Surface shaded 3D fluid with Opacity Texture looks different in software
render

If the dropoff shape is off, or the edge dropoff is 0, and your 3D fluid has
density (greater than the surface threshold) in the boundary voxels, you won't
see an outside boundary in hardware draw.

Workaround

If you need to see the outside boundary in the hardware draw, set the dropoff
shape to cube, and the edge dropoff to 0.01.

2D texture collision missing some areas

The fluid doesn't enter some regions around the collision object.

Workaround

Triangulate the poly mesh explicitly using Mesh > Triangulate in the Polygons
menu set.

Fluid object doesn't render in the exported file

If you exported a fluid with inputs off, you may end up losing the fluid shading
connection to itself, and the fluid will not render.
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Workaround

Open Hypershade, Assign the fluidShape to itself and it will render again.

Referenced file initial state cache may be modifiable from parent file

If your referenced file has an initial state cache, you can modify it from the
parent file.

Workaround

Don’t modify it—either by painting or save initial state (unless you really
mean to).

Floating object animation limitation

Floating object animation only works correctly if units are in centimeters.

Workaround

Look at the extra attributes on the associated locator shape, and modify to
compensate for the change of units. The scene scale is normally used to match
the ocean shader scale, but it can also be used to compensate for the units
relative to centimeters. Or you can modify gravity, or some of the other
physical constants to get the desired motion in your units.

Alpha in image plane expands when used with volume fluids

Alpha in image plane expands when used with volume fluids.

Workaround

Make a second render.

1 Set the colorGain to zero and the color offset to 1 in the image plane.

2 On the fluid node set the Color ramp to all black and then set the
Incandescence ramp to white.

Different blending cutoff in attribute presets for multis than strings, enums

If you apply an attribute preset with blending for a node that has ramp
attributes and there isn’t a one-for-one match between the entries on the
corresponding ramps, you may get unexpected results. If these results are not
satisfactory, you may have to adjust the results by hand. If you undo this kind
of blend, you may end up with an extra index entry with a position and value
0. If so, delete the extra entry.
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Ocean Shader: How do you create a tiling looping texture from it?

Here is a more detailed recipe for looping an ocean: LOOP_FRAMES = number
for frames after which animation repeats.

1 Create an ocean or ocean shader. Set the numFrequencies and waveHeight
both to zero so that the ocean is totally flat and more optimal to render.

2 Map the oceanShader waveHeightOffset with an ocean
texture.asProjection = ON and newTexturePlacement OFF. On the
projection set the rotateX to 90.

3 Map the colorOffset of this texture with another ocean texture as
Projection = OFF and newTexturePlacement = OFF

4 Animate the time values of the two ocean textures such that the start of
one is the same as the end of the other.

In the time field on oceanTexture1 type:

= frame/30 (the time parameter generally expects seconds, not frames)

In the time field on oceanTexture2 type:

= (frame-LOOP_FRAMES)/30

5 Keyframe the waveHeight on the two textures to do a cross dissolve:

oceanTexture1 frame 1 = desired height, frame LOOP_FRAMES = 0

oceanTexture2 frame 1 = 0, frame LOOP_FRAMES = desired height

The ocean animation should now loop across the number of frames specified
by LOOP_FRAMES above. For it to work the two ocean textures must have
identical values (apart from the wave height and time). With this method you
cannot preview the displacement of the ocean using the heightfield node
(convert displacement to poly will work). Also buoys and boats will not animate
with wave height (texturing on the ocean shader is currently not taken into
account for these effects).

Ocean horizon appearance

Large Ocean objects may appear blurry near the horizon when rendered in
either mental ray for Maya or Maya renderers.

Workaround

Lower the horizon filter value from 1.0 to 0.1 on the ocean shader.
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Ocean horizon and waves

When the camera is positioned such that a wave obscures the horizon line, a
line artifact may appear on the wave.

Workaround

■ Make the Horizon Filter value zero on the ocean shader. Note that a higher
antialiasing setting may be required to avoid jitter along the ocean horizon.

■ Render the scene using in mental ray for Maya renderer.

Increased intensity of lights when multiple lights are used to illuminate fluid
objects

When multiple lights are used to illuminate a scene with a fluid object, the
intensity of each light is incorrectly increased.

Workaround

1 Create lights specifically for illuminating the fluid object.

2 Using the Light Linking Relationship Editor (Window > Relationship
Editors > Light Linking), link the lights to the fluid object.

3 Adjust the intensity of each light accordingly.

Volume light Emit Ambient attribute not updating in IPR

When you select Emit Ambient with IPR running, you won't get an update.

Workaround

Reselect the area or change another attribute to update the render.

Multiple processors for fluid rendering may result in artifacts

When using four or more processors for fluid rendering, you may experience
artifacts.

Workaround

Reduce the number of processors to four or less and try again.
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Texture does not return to its original position

If your Texture Coordinate Method is set to grid and you are painting your
fluid with autosave on, the texture does not return to its original position.

Workaround

Rewind, change coordinate method to fixed then back to grid again. Avoid
saving unwanted grids, make sure that your saveInitialState options are set to
indicate which grids should be saved.

Unexpected results when self shadowing on a surface rendered fluid

When self shadowing on a surface rendered fluid, you may get unexpected
dark regions and artifacts.

Workaround

This only happens if the fluid has no transparency. Increase the quality until
the artifacts disappear. Alternately, set the transparency to a non-zero value
and it behaves as expected.

Hardware display issues with Caching

When Node Behaviour > Caching is turned on in the Attribute Editor, you
may get unexpected results in the hardware display.

Workaround

Don't turn on Node Behaviour > Caching for Fluid Effects. If you did, turn it
off, save your file, and restart Autodesk® Maya®.

Depth buffer inaccurate for surface fluid

When rendering a fluid with depth output and a surface style fluid, you would
expect the surface to appear correctly in the depth buffer, especially if the
fluid surface transparency is zero. By default nothing will appear in the depth
buffer. You must set the camera depthType to the closest visible depth to see
the fluid in the depth output. However the depth value will be the near
intersect with the fluid bounds, rather than the actual depth of the blobby
surface. This could create problems for composites with objects (or paint
effects) within the fluid bounds.
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Workaround

You can get closer to the correct depth by enabling volumeSamplesOverride
and increasing the volume samples on the fluidShape. Note this may create
artifacts with surface type fluids and it will take longer to render.

Fluid wireframe draw (particles) does not work if voxels too small

If the Resolution is set low, nothing appears in the Fluid wireframe draw
(particles).

Workaround

Use shaded mode or rectangles.

Can't create partial presets if node has multi attributes

You may want to edit the preset file so that it only contains a subset of the
node's attributes, but when applying a preset to a node with multi attributes,
it empties out all the multis first, and then adds entries to the multis from the
preset. Do not alter these files, particularly the entries for any multi attribute,
such as ramps.

Convert Fluid to polygon full of holes with smooth interpolation

When converting a Fluid to a polygon with smooth interpolation, you will
most likely get holes in the mesh.

Workaround

Use linear interpolation and then average the vertices, or, with smooth
interpolations, using fillHole will deal with these holes except when the
boundary has non-manifold vertices. In this case we recommend increasing
the threshold until the geometry is no longer non-manifold.

Surface rendered 2d fluid image is not consistent with Display: As Render

A surface render of a 2d fluid may not look like a fluid in Display: As Render
mode.

■ The drop off shape for the cone (and double cone) isn't capped, so you
still end up with the ends open. This is intentional.

■ In a 2D fluid, not enough triangles are generated along the depth, so in a
deep 2D fluid, the sphere will look like a cylinder and the cone will look
like 2 cylinders.

Fluid Effects limitations | 115



■ You will get ribboning if your drop off shape is off, or the edge dropoff is
0, whatever the shape.

Noise and volumetric objects

When using 2D textures on volumetric objects, they must be used as
projections.

Older presets are not removed when Maya uninstalled

Uninstalling Maya does not remove the presets folder (in case you have added
your own presets to it). So if you have previously installed an older version
of Maya (for example, if you are a beta site), some old presets which no longer
work correctly may remain in your new install.

Workaround

Manually remove the presets folder or just the unwanted presets from your
install location before re-installing Maya.
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Maya Hair

Hair limitations
Stiffness Scale no longer affects curve attraction

In Maya 2009, Stiffness Scale no longer affects curve attraction. Instead, the
new Attraction Scale ramp lets you control the value of Start Curve Attract along
the length of a single hair clump or an entire hair system. This means that Hair
in pre-Maya 2008 scene files that uses non-default Stiffness Scale values will
now behave differently.

Hair width incorrect when rendered with mental ray for Maya

When rendering hair in mental ray for Maya, hair width is defined relative to
clump width, while the Maya interactive and Software Renderer use the hair
width directly in world space.

Workaround

Change hair width before rendering in mental ray for Maya. If you are modifying
the clump width per follicle with the Clump Width Mult, you may need to put
different sized clumps into separate hair systems, or use an alternate method
such as the Baldness Map for controlling hair placement

IK solver may crash Hair render

If your mode has dynamic curves that affect an IK solver, it may crash when
rendering in mental images® mental ray® for Maya on Linux®.

Workaround

Bake the IK before rendering and make sure that the IK solver is not enabled.
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3D motion blur on Hair

The thinline brush type used by the internal default brush for hair does not
support 3D motion blur.

Workaround

You can assign a Paint Effects brush to the hair system and use the Paint Brush
Type (Brush Type = Paint). Keep in mind rendering will be slower with the
Paint Brush Type and also the hairs may appear too thick when viewed from
a distance.

NOTE 2D motion blur works with hair and the ThinLine Brush Type.

Simulation rate problems due to over and undersampling

Simulation rate does not affect hair solver oversampling, and undersampling
dramatically changes the speed of the motion.

Workaround

Do not over or undersample when caching hair and do not change the
playback rate. If you change your time units, you may need to change the
dynamic properties of your hair system to compensate.

Lock Length not working with clusters

Lock curve length does not work with cluster or other deformers.

Undo not working when using Lock Length

With Lock Length, undo does not return curve to original position.

NOTE Lock Length is intended for use while transforming CVs. It is not currently
supported in conjunction with other animation techniques. You may wish to save
before editing your curve with Lock Length turned on.

Setting Rest or Start curves from Current on referenced hair system doesn't
work

Setting Rest or Start curves from Current on referenced hair system doesn't
work.

Workaround

Modify Rest or Start curves in the referenced file instead.
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Problems with non unique hair curve names and namespaces

If you import multiple hair systems with the same curve names using
namespaces, set Rest Position and set Start Position will be unable to distinguish
the curves.

Workaround

Although we generally encourage the use of namespaces, in this case it may
be better to import hair with prefixes to resolve clashing names.

Gravity not working with Hair

Gravity doesn't work well with Hair in Z-up system.

Workaround

Use a gravity field instead of the built in gravity

A default dynamic curve behaves differently at each end

The tip point lock locks to the end CV position, but not to end segment
direction.

Workaround

Apply a transform constraint at the end of the hair.

Hair jittering with collision constraint

If your collide sphere constraint is non-proportionately scaled so that one
dimension is much thinner than another, stiff hair will jitter when touching
the constraint.

Workaround

Reduce the stiffness until the hair stops jittering or make the constraint more
uniform in scale.
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Maya Toon

Toon limitations
Lighting Based Width does not work with Offset Mesh

Lighting Based Width for toon lines is not supported for Offset Mesh profile
lines.

Workaround

Use Paint Effects profile lines if you need lighting based width.

pfxStrokes command does not support pfxToon node completely

The pfxstroke command does not output the profile curves for a pfxToon object.

Workaround

Use ConvertPaintEffectsToCurves to extract the NURBS curves for the toon
outline.

Reverse surfaces only work for polygons

When using Toon Lines with Offset Mesh for the profile lines, Reverse Surface
is only supported for Polygons.

Workaround

For NURBS surfaces and Subdiv surfaces, if you need to reverse the surface,
convert the surface to polygons and create the offset mesh on the poly surface.
For NURBS surfaces, you can also Reverse Surface Direction on the NURBS surface
itself.
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Translators and
Platform-specific

Translator limitations
The following limitations and workarounds relate to translator capabilities of
Maya.

StudioImport limitations

(StudioImport) StudioTools aim constraints have different axes

In StudioTools, if the aim constraints on one object have different axes, when
they come into Maya, they will share the same axis—the one used by the first
aim constraint on your object.

(StudioImport) StudioTools faces become trimmed surfaces

StudioTools faces become trimmed surfaces when brought into Maya. Sometimes,
the trimmed surface may look different than the original face.

(StudioImport) srand (seed) replaced by rand (seed) when translated into
Maya

If you use function srand(seed) in your expression, it will be replaced by
rand(seed) when the expression is translated to Maya.
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Workaround

Please replace “rand(seed)” with “rand(1)” if you want a random number from
0 to 1. If you do want to change the seed of the random number in the
expression, please use the “seed” function which is available in Maya.

(StudioImport) Texture mapped onto color in StudioTools becomes image
planes on all renderable cameras

The texture mapped onto the color of the StudioTools environment becomes
image planes on all the renderable cameras. The size of this image plane is
not necessarily correct.

Workaround

Adjust its size to get the desired result.

(StudioImport) Light glow transfer not perfect between StudioTools and
Maya

The transfer of light glow is not perfect between StudioTools and Maya. The
two main components are the light intensity and light decay. If your
StudioTools light intensity is 1.0 and light decay is 0, then you do not need
to be concerned.

Workaround

To get a perfect match between StudioTools and Maya light glows, just adjust
your Maya glow intensity to:

glow_intensity = original_glow_intensity * light_intensity / decay

where decay is:

■ 1 if no decay

■ light_decay if decay is 1

■ light_decay**2 if decay is 2

■ light_decay**3 if decay is 3

(StudioImport) Layered shader created in Maya for layered StudioTools
shaders

If several shaders in StudioTools are layered on an object, a layered shader is
created explicitly in Maya for these shaders.
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(StudioImport) StudioTools image plane placement

For StudioTools image plane placement to correctly convert, set the Persp
window in StudioTools to the same resolution as the default render resolution,
and also choose Screen as the image space type.

(StudioImport) Backdrop image and texture on background color in
StudioTools conversion limitation

Both the backdrop image and the texture on the background color in the
StudioTools environment are converted to image planes on the renderable
cameras. The depth of the image plane for the backdrop image is set to 90%
of the far clipping plane. The depth of the image plane for the background
color texture is set to 95% of the far clipping plane.

(StudioImport) Losing animation sequence number during conversion

The animation sequence number appended to the end of the image filename
in StudioTools could be lost in Maya during the translation.

(StudioImport) StudioTools start/end mode in render settings conversion
limitation

The start/end mode in the render settings does not translate properly into
Maya, as Maya has no such mode. In this mode, the start and end frames,
when transferred to Maya, may end up very different from the range in
StudioTools.

Obj limitations
The following limitations and workarounds relate to Obj.

.obj suffix on obj filename necessary

You need a “.obj” suffix on the filename for Maya to recognize it as an obj
file.

Workaround

Append .obj to the end of the filename.

MTL textures

MTL textures only work with file textures.
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IGES import and export

Level Mapping is not working on export

When using IGES export, level mapping (layers) is not supported.

Additional transform nodes are created for trimmed surfaces

When using IGES export, trimmed surfaces can be exported with extra
transform nodes.

Miscellaneous translators

Compression not working using VRML2, OpenInventor export

To use compress in Export Vrml2 and Export OpenInventor please ensure that
a zip utility such as gzip is installed and in the path on your machine.

Platform-specific limitations

Maya for Windows limitations
The following limitations and workarounds relate to Maya for Windows issues.

(Windows) Deleting menu items from tear-off menu on Maya

Deleting a menu item from a menu that has been torn off will cause Maya
(for Windows) to crash.

(Windows) Maya does not start from Japanese/multibyte path

If you install Maya to a custom location containing Japanese/multibyte
characters and then attempt to open Maya, Windows returns an error.

Workaround

Do not install Maya to a custom location containing Japanese/multibyte
characters.
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(Windows) Maya confuses decimal point and decimal comma

When working in a Windows regional setting that uses decimal commas,
Maya occasionally swaps decimal points for decimal commas.

Workaround

In the Windows regional settings, exchange the decimal comma for a decimal
point.

Maya for Linux limitations
The following limitations and workarounds relate to Maya for Linux issues.

(Linux) getModifiers command doesn’t seem to work on Linux

Maya for Linux may not recognize the Ctrl+click key/mouse sequence.

(Linux) Display differences—with/without hardware overlays

What is displayed as red with hardware overlays is displayed as gray and black
on cards without hardware overlays.

If there are no hardware overlays, plug-ins written assuming overlays will
probably not work as expected.

(Linux) Dragging and dropping

Dragging and dropping from the desktop to Maya may not work.

(Linux) Window sizes

Some windows may have no height or width initially. Also, a window’s default
size may prevent option menus from being visible and readable.

Workaround

This usually occurs the first time the window is opened when its size has not
been previously set. Resize the window manually.

(Linux) Interface Preferences settings for Show Title Bar in Main Window
and In Script Editor

(Window > Settings/Preferences > Preferences > Interface) The states of these
window’s title bars are not affected by the settings in the Interface: General
Interface Preferences window.
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(Linux) Maya windows disappear

Depending on the window behavior defined in the Window Manager control
panel, windows may automatically raise (come to the front) on focus or when
clicking in them. This may result in Maya child windows to disappear. They
have been pushed down, and the new window is brought forward.

Workaround

Change the default settings for the following:

■ For KDE, and Gnome, see Additional Linux notes in the Installation and
Licensing guide.

(Linux) Maya for Linux does not support creation of movie files

Maya Linux does not support creation of movie files. This prevents certain
other functions, such as Playblast, from working. This also means that Maya
Live pointblasts cannot output in movie format.

Playblast can still output a series of images and play it back using FCheck.

(Linux) Input connections do not appear in Hypershade

In Hypershade, when you connect a node1 output to a node2 input, the full
menu list of input connections does not appear when you click the node2
input arrow.

Workaround

Click the node2 image itself instead of the input arrow. The full selection is
then listed.

(Linux) Home variable not always set

Under certain conditions, the Home environment variable may not always
be set which cause various errors in Maya.

Workaround

Make sure the Home environment variable is set to the correct user profile.

Maya for Mac OS X limitations
The following limitations and workarounds relate to Maya for Mac OS X issues.
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(Mac OS X) Snapping gets stuck

When holding down any key to enable snapping (for example, v, c, or x)
snapping may remain active after the hotkey is released.

Workaround

Click the middle-mouse button again without the hotkey held down.

(Mac OS X) G4/Hardware rendering support

In our efforts to take advantage of recent improvements in the graphics cards
available on the Mac, it was necessary to make changes that prevent the use
of hardware rendering on machines with G4 processors.

All other Maya functionality available on Mac OS X functions properly on a
G4-based machine; however, if you attempt to use hardware rendering, you'll
get a warning message that hardware rendering is not supported.

(Mac OS X) Symlinks have been removed from /usr/sbin

In previous versions of Maya, symlinks to licensing software and Maya
command-line software were installed in /usr/sbin so that users could just
type the name of the command at the Terminal (/usr/sbin/ is included in
the default path).

These symlinks have been removed, as they caused problems when multiple
versions of Maya were installed or when uninstallation took place.

To get access to these command-line functions, either give the fully-qualified
path within Terminal, or use the custom Terminal (.term) provided with Maya.

(Mac OS X) Default location to install plug-ins

Maya for Mac OS X provides a default location where you can install plug-ins:

/Users/Shared/Autodesk/maya/2009

Refer to the topic Load or unload Maya plug-ins in the Basics guide.

(Mac OS X) Features for Mac OS X not available for Windows or Linux

The following features are available in Mac OS X but not Windows or Linux
versions of Maya.

■ Tear-off menus in Hot Box

■ Posting menus in Hot Box
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■ QuickTime integration

■ Threaded sound playback in time line during scrubbing

■ AppleScript executes Maya MEL commands with results returned. (Refer
to the topic Calling MEL from AppleScript and vice-versa in the MEL and
Expressions guide.)

3rd party programs not available for Mac OS X

■ Motion capture drivers

Limitations of Maya for Mac OS X

■ Ability to read in pre-Maya 3.0 files

(Mac OS X) Mac OS X file fails to open on Windows XP

A reliable way to transfer Maya ASCII files between Macintosh computers and
other platforms running Maya is to use ftp in ASCII mode.

(Mac OS X) Can't use a back slash code in MEL (Korean and Japanese systems
only)

Workaround

Type the string on the same line (do not use a back slash to carry the string
to the next line).

(Mac OS X) Texture placement manipulator disappears

The Texture Placement manipulator disappears when you make placement
changes.

Workaround

Click with the middle mouse button anywhere in the empty space of the scene
view to get back the manipulator

(Mac OS X) Interacting with Speed buttons in Fcheck has no effect

In Fcheck, when Every Frame is on, interacting with the Speed buttons (-, +)
has no effect on the playback speed.
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(Mac OS X) Display problem when selecting isoparm of NURBS surface

A strange pattern may display when you select an isoparm of a NURBS surface.

Workaround

Select the isoparm again to remove the pattern.

(Mac OS X) Tabbing doesn’t always work as expected in Add Attribute
window

Tabbing in the Add Attribute window (in the Attribute Editor, select Attributes
> Add Attributes), does not always work as expected.

(Mac OS X) FBX symbols are not exported

If you are writing your own plug-ins, note that symbols in the version of the
Maya FBX plug-in included with this service pack are not exported.

Workaround

Download and re-install the Maya FBX plug-in from
http://www.autodesk.com/fbx.

(Mac OS X) Playback performance issue

If you experience stuttering during playback, it is recommended that you
change the number of threads Maya is using during playback.

Workaround

Enter the following using the Maya Command Line:

threadCount -n # of threads

(Mac OS X) Maya doesn’t recognize IGS file format

If you open the file browser and change the Files of Type field to IGES_DC
(*iges; *igs), Maya doesn't recognize files with the extension IGS.

Workaround

Change the capitalization of the file's extension to .igs or .iges from .IGS.
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(Mac OS X) Maya removes last character of a shelf command not ending in
semicolon

If you have a .mel file in which the last command does not end in a semicolon
and then add that .mel file to the Shelf, Maya removes the last character of
the last command.

Workaround

Load the .mel file into the Script Editor, replace the missing character, and
save the .mel file again.

(Mac OS X) Maya cannot load from a remote mounted file system

Sometimes when working in an environment with multiple client PCs and a
central file server, attempting to load a file directly from the file server results
in an error. This happens particularly often when multiple clients attempt to
load the same file at the same time.

Workaround

Copy the Maya scene file from the file server to your local client machine and
then open it. When you are finished with the scene, copy the same file back
to the file server.

(Mac OS X) Interactive Primitive creation doesn’t work after IME change

When running Maya in a JP environment with the IME mode set to EN, if
you attempt to switch the IME mode to JP and then back to EN, Maya loses
the ability create polygons with Interactive Creation.

Workaround

Turn off Interactive Creation and then create the polygon.
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Maya commands

New Maya commands
The following new commands have been added in Maya 2010. Refer to the MEL
Command Reference (Help > MEL Command Reference) for documentation on
each new command.

■ attributeName

■ containerProxy

■ containerTemplate

■ containerView

■ copyAttr

■ frameBufferName

■ getLastError

■ getProcArguments

■ license

■ nBase

■ particleFill

■ polySelectSp

■ renderPassRegistry

■ reorderContainer

■ setRenderPassType
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■ softSelect

■ stereoCameraView

■ stereoRigManager

■ targetWeldCtx

■ texSmoothContext

■ treeView

■ vectorize

Updated Maya commands
The following commands have been updated for Maya 2010. Refer to the MEL
Command Reference (Help > MEL Command Reference) for more information.

animCurveEditor

Flag added:

■ -constrainDrag

animLayer

Flag added:

■ -copyAnimation

artAttrCtx

Flags added:

■ -alphaclamp

■ -alphaclamplower

■ -alphaclampupper
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artAttrPaintVertexCtx

Flags added:

■ -alphaclamp

■ -alphaclamplower

■ -alphaclampupper

■ -vertexColorRange

■ -vertexColorRangeLower

■ -vertexColorRangeUpper

artAttrSkinPaintCtx

Flags added:

■ -alphaclamp

■ -alphaclamplower

■ -alphaclampupper

artFluidAttrCtx

Flags added:

■ -alphaclamp

■ -alphaclamplower

■ -alphaclampupper

artPuttyCtx

Flags added:

■ -alphaclamp

■ -alphaclamplower

■ -alphaclampupper
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artUserPaintCtx

Flags added:

■ -alphaclamp

■ -alphaclamplower

■ -alphaclampupper

attrControlGrp

Flags added:

■ -annotation

■ -handlesAttribute

bakeResults

Flags added:

■ -bakeOnOverrideLayer

■ -destinationLayer

■ -minimizeRotation

■ -removeBakedAttributeFromLayer

■ -resolveWithoutLayer

■ -smart

bakeSimulation

Flags added:

■ -bakeOnOverrideLayer

■ -destinationLayer

■ -minimizeRotation

■ -removeBakedAttributeFromLayer

■ -resolveWithoutLayer
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■ -smart

bevelPlus

Flag added:

■ -bevelInside

cacheFile

Flags added:

■ -cacheFormat

■ -cacheableAttrs

■ -creationChannelName

■ -replaceWithoutSimulating

■ -runupFrames

camera

Flag added:

■ -displayGateMask

channelBox

Flags added:

■ -attrBgColor

■ -attrColor

■ -attrFilter

■ -attrRegex

■ -containerAtTop

■ -nodeRegex

■ -update
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colorIndex

Flag added:

■ -debug

commandPort

Flag added:

■ -listPorts

container

Flags added:

■ -asset

■ -assetMember

■ -bindAttr

■ -connectionList

■ -current

■ -fileName

■ -includeHierarchyAbove

■ -includeHierarchyBelow

■ -includeNetwork

■ -includeShaders

■ -includeShapes

■ -includeTransform

■ -nodeNamePrefix

■ -parentContainer

■ -preview

■ -publishAndBind

■ -publishAsChild
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■ -publishAsParent

■ -publishAsRoot

■ -publishAttr

■ -publishConnections

■ -publishName

■ -unbindAndUnpublish

■ -unbindAttr

■ -unpublishChild

■ -unpublishName

■ -unpublishParent

■ -unsortedOrder

convertLightmap

Flag added:

■ -useLensBake

cycleCheck

Flag added:

■ -query

dgtimer

Flag added:

■ -hide

■ -overhead

■ -rangeLower

■ -rangeUpper

■ -returnType
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■ -show

■ -sortMetric

■ -sortType

■ -trace

■ -uniqueName

■ -updateHeatMap

displayPref

Flag added:

■ -displayGradient

displayString

Flag added:

■ -delete

dynParticleCtx

Flag added:

■ -nucleus

editorTemplate

Flags added:

■ -annotation

■ -listExtraAttributes

■ -queryLabel

evalDeferred

Flags added:

■ -evaluateNext
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■ -list

file

Flags added:

■ -lastFileOption

■ -lockContainerUnpublished

Flags removed:

■ -objectType

■ -subType

fileBrowserDialog

Argument type changed for -fileCommand from string to script.

fileDialog

Flags added:

■ -defaultFileName

■ -title

gradientControlNoAttr

Flags added:

■ -asString

■ -changeCommand

■ -currentKey

■ -currentKeyChanged

■ -currentKeyColorValue

■ -currentKeyCurveValue

■ -currentKeyInterpValue

■ -dragCommand
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■ -rampAsColor

headsUpDisplay

Flags added:

■ -getOption

■ -setOption

headsUpMessage

Flags added:

■ -uvTextureEditor

■ -viewport

help

Flags added:

■ -listUnconverted

■ -syntaxOnly

hudSliderButton

Argument types changed:

■ For -buttonPressCommand from string to script.

■ For -buttonReleaseCommand from string to script.

hyperGraph

Flags added:

■ -graphDescription

■ -heatMapDisplay

■ -imageForContainer

■ -layoutSelected
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■ -mergeConnections

■ -opaqueContainers

■ -range

■ -showRelationships

Flags removed:

■ -invertRegularExpressionFilter

■ -regularExpressionFilter

iconTextButton

Flag added:

■ -commandRepeatable

itemFilterAttr

Flag added:

■ -published

layoutDialog

Argument type changed for -uiScript from string to script.

listAttr

Flags added:

■ -hasNullData

■ -ramp

■ -usedAsFilename

listHistory

Flags added:

■ -futureLocalAttr
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■ -futureWorldAttr

■ -historyAttr

■ -query

lockNode

Flag added:

■ -lockUnpublished

ls

Flags added:

■ -deletable

■ -internal

■ -nonDeletable

■ -preSelectHilite

manipMoveContext

Flags added:

■ -postDragCommand

■ -preDragCommand

■ -preserveUV

■ -tweakMode

manipOptions

Flag added:

■ -preselectHighlight
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manipRotateContext

Flags added:

■ -postDragCommand

■ -preDragCommand

■ -preserveChildPosition

■ -preserveUV

■ -tweakMode

manipScaleContext

Flags added:

■ -postDragCommand

■ -preDragCommand

■ -preserveChildPosition

■ -preserveUV

Mayatomr

Flags added:

■ -fragmentMaterialAssignments

■ -passContributionMaps

■ -passUserData

■ -render

■ -useLensBake

memory

Flags added:

■ -dump

■ -kiloByte
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■ -mark

■ -megaByte

menu

Flag added:

■ -fullPathName

modelEditor

Flags added:

■ -cameraSetup

■ -editorChanged

■ -nParticles

modelPanel

Flag added:

■ -barLayout

move

Flag added:

■ -preserveUV

nParticle

Flags added:

■ -attribute

■ -cache

■ -conserve

■ -count

■ -deleteCache
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■ -dynamicAttrList

■ -floatValue

■ -gridSpacing

■ -inherit

■ -jitterBasePoint

■ -jitterRadius

■ -lowerLeft

■ -name

■ -numJitters

■ -order

■ -particleId

■ -perParticleDouble

■ -perParticleVector

■ -position

■ -shapeName

■ -upperRight

■ -vectorValue

Flags removed:

■ -clearCachedTextureMap

■ -clearStart

■ -stuffStart

■ -textureToVertex

nameCommand

Flag added:

■ -sourceType
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nodeCast

Flag added:

■ -copyDynamicAttrs

outlinerEditor

Flags added:

■ outlinerEditor

■ -autoExpandLayers

■ -containersIgnoreFilters

■ -organizeByLayer

■ -showAnimLayerWeight

■ -showAssets

■ -showContainedOnly

■ -showContainerContents

■ -showPublishedAsConnected

playblast

Flags added:

■ -activeEditor

■ -cameraSetup

pluginInfo

Flags added:

■ -activeFile

■ -cacheFormat
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pointOnCurve

Flag renamed:

■ -n to -no

pointOnSurface

Flag renamed:

■ -n to -no

polyBoolOp

Flag added:

■ -preserveColor

polyColorSet

Flags added:

■ -currentPerInstanceSet

■ -perInstance

■ -shareInstances

■ -unshared

polyCrease

Flag added:

■ -operation

polyMergeVertex

Flag added:

■ -mergeToComponents
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polyMultiLayoutUV

Flags added:

■ -offsetU

■ -offsetV

■ -prescale

■ -sizeU

■ -sizeV

polyPrism

Flag added:

■ -numberOfSides

Flag renamed:

■ -ns to -nsi

polyPyramid

Flag added:

■ -numberOfSides

Flag renamed:

■ -ns to -nsi

referenceQuery

Flags added:

■ -showDagPath

■ -showNamespace
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renderSettings

Flags added:

■ -camera

■ -customTokenString

■ -fullPath

■ -fullPathTemp

■ -genericFrameImageName

■ -imageGenericName

■ -layer

■ -leaveUnmatchedTokens

renderWindowEditor

Flags added:

■ -currentCameraRig

■ -displayImageViewCount

■ -nextViewImage

■ -resetViewImage

■ -stereo

■ -stereoImageOrientation

■ -stereoMode

■ -viewImageCount

renderer

Flags added:

■ -batchRenderOptionsStringProcedure

■ -iprOptionsProcedure
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rotate

Flags added:

■ -preserveChildPosition

■ -preserveUV

scale

Flags added:

■ -preserveChildPosition

■ -preserveUV

scriptCtx

Flags added:

■ -debug

■ -meshComponents

■ -nParticle

■ -nParticleShape

scriptJob

Flag added:

■ -nodeNameChanged

scriptedPanelType

Flag added:

■ -copyStateCallback

selectMode

Flag added:

■ -debug
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selectPref

Flags added:

■ -containerCentricSelection

■ -manipClickBoxSize

■ -paintSelect

■ -paintSelectWithDepth

■ -preSelectHilite

■ -preSelectHiliteSize

■ -straightLineDistance

■ -useDepth

selectPriority

Flags added:

■ -debug

■ -nParticle

■ -nParticleShape

selectType

Flags added:

■ -debug

■ -meshComponents

■ -nParticle

■ -nParticleShape

setEditor

Flag added:

■ -debug
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setKeyframe

Flags added:

■ -animLayer

■ -dirtyDG

■ -identity

shelfButton

Flag added:

■ -commandRepeatable

snapMode

Flags added:

■ -pixelCenter

■ -pixelSnap

stackTrace

Flags added:

■ -parameterCount

■ -parameterType

■ -parameterValue

symmetricModelling

Flags added:

■ -preserveSeam

■ -reset

■ -seamFalloffCurve

■ -seamTolerance
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texRotateContext

Flags added:

■ -snap

■ -snapRelative

■ -snapValue

texScaleContext

Flags added:

■ -snap

■ -snapRelative

■ -snapValue

timeControl

Flags added:

■ -animLayerFilterOptions

■ -animLayerShowWeight

■ -forceRefresh

transferAttributes

Flag added:

■ -searchMethod

undoInfo

Flags added:

■ -closeChunk

■ -openChunk

■ -printQueue
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viewManip

Flags added:

■ -fitToView

■ -frontParameters

■ -goDefault

■ -goHome

■ -homeParameters

■ -levelCamera

■ -resetFront

■ -resetHome

■ -restoreCenter

■ -selectionLockParameters

■ -setFront

■ -setHome

■ -toggleSelectionLock

viewPlace

Flag added:

■ -animate

wrinkle

Flags removed:

■ -geometry

■ -remove
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xform

Flag added:

■ -preserveUV

Maya commands limitations
General

Menu bar layouts

Menu bar layouts are not visible until a child control is added.

Workaround

Create the menu bar layout and children and then show the window.

MEL

Using a string as an integer may crash Maya

Maya may crash if you source a MEL script that tries to operate on a string as
an integer.

MEL array limitation

When a MEL array is specified using the {} notation then the type of the array
is inferred from the first argument in the array. Therefore, an array declared
with an integer as its first argument will generate a warning if a float value is
specified later. These values will be converted to integers. Here is an example:

float $arr[] = { 1, 2.5 };

// Warning: Casting from float to int may result in a loss of

precision. //

print($arr[0] + “ “ + $arr[1] + “\n”);

1 2

The value of the second element in $arr is 2, not 2.5 as expected.

Workaround

Make sure you declare the first element of the array as the type that you want
the array to have. In the case above, this would mean declaring the array as:
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float $arr[] = { 1.0, 2.5 };

By declaring the "1" as "1.0", the type of the array is indicated to be float.

Polygon create command texture flag is no longer supported

The -texture flag (-tx) for the polygon create commands is no longer
supported as of Maya 8.0. The -createUVs flag (-cuv) should be used instead.

Using a dash in MEL strings

If the first character of a string begins with a dash, the MEL interpreter assumes
it is a command flag.

However, this is now a specific case where you can use strings that begin with
dashes in MEL commands: the setAttr command can now set an attribute of
type string with a value string that begins with a dash.

We strongly recommend against using strings in MEL that begin with dashes
because they will not work in any other command. If you try to use these
strings as attributes in any other command, you will get incorrect results.

stringArrayIntersector

In batch mode, the MEL function stringArrayIntersector does not work.

Connected attributes in MEL must be of identical type

Maya may stop unexpectedly when attempting to connect two
multi-dimensional array attributes of different types in MEL.

Workaround

Ensure the connected attributes are identical in type.

Python

Use asUnits() method instead of as() method to avoid conflict in Python 2.6

Python plug-ins and scripts which previously used the as() method from the
MAngle, MDistance or MTime classes must be changed to use the new asUnits()
method to avoid conflict with Python 2.6's as keyword.

Script editor cannot source .py file

Attempting to source a .py (Python) script in the Script Editor (File > Source
Script) returns errors, as it is being read as MEL.
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Workaround

Use the import directive. The script must be in your PYTHONPATH or sys.path.

The script node does not accept Python

You cannot use Python in script nodes.

Workaround

Write your Python script in a .py file and save it in your scripts directory. Use
the MEL command below in a script Node.

python("\ \ import myPythonScript;\ myPythonScript.pyCommand();\

\ "); 262522 nf 10.0

Can't import a Maya Python module twice in Toxik

There is a known issue that prevents Toxik from importing a Maya Python
module a second time in a new Python embedded interpreter.

Runtime commands from Python and hotkeys

Menu items that are runtime commands from Python don’t display hotkeys.

Python commands in menuItems on the Shelf produce an error

Python commands attached to menuItems that are part of Shelf buttons
produce an error when Maya is restarted. Although this works the first time
around, because it is being created with the menuItem command (-command
flag is SCRIPT type), the second time it is being created in the saved shelf.mel
file, with the shelfButton command whose -mi flag takes the String String
(multi-use) arguments.

Workaround

1 Wrap your Python commands in the MEL python command:

mc.menuItem(checkBox = True, label = "menuItem 1", command

="python(\"print 'MENU ITEM 1 PRESSED'\")")

mc.menuItem(checkBox = True, label = "menuItem 2", command =

"python(\"print 'MENU ITEM 2 PRESSED'\")")

2 Keep a Python script in your local maya/scripts folder that has the
functions you want to call from the Shelf:

"python(\"import shelfScripts;shelfScripts.thisFunction();\")"
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You must restart Maya once you add the Shelf commands, before you use
the menus.

Python runtime commands produce an error

Python runtime commands do not find their procedures when Maya is
restarted; the are being incorrectly interpreted as MEL commands.

Workaround

1 Wrap your Python commands in the MEL python command.

2 Keep a Python script in your local maya/scripts folder that has the
functions you want to call from the runtime command:

"python(\"import myRunTimes;myRunTimes.thisFunction();\")"

When you re-start Maya, Maya uses the MEL interpreter and correctly executes
your functions.

Missing Python modules from 64-bit systems

The following modules are not included in 64-bit distributions of Python
(Windows and Linux):

audioop, imageop, rgbimg

For more information, see http://svn.python.org/projects/python/trunk/README

Possible error referencing files when using PyQt

When using PyQt in your production, if you experience a glibc detected error
when referencing files into a scene through maya.standalone, you may try
adding:

from PyQt4.QtCore import *

before attempting the reference.

Maya commands that expect MEL strings only

Some Maya commands with callbacks expect MEL strings only.To identify
flags with this behavior, look at the help for this command in the Script Editor.
If the type is Script, it can accept Python or MEL; if the type is String, it can
only accept MEL.
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Workaround

Use the 'python' MEL command in your MEL callback string:

-c 'python "import myScript;myScript.myFunction()"'

See also User Guide > General > Python > Tips and tricks for scripters new to Python
in the Maya Help for information on how to register a Python function as a
MEL procedure.
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File formats

File formats limitations
Sets on .obj files imported into Maya considered shading groups

All sets on .obj files imported into Maya are considered shading groups. This
means that adjustment of an object’s rendering groups within Maya causes
simultaneous modification of the membership of the sets that were imported
from the .obj file.

Workaround

In Maya, for each .obj file set whose membership you wish to preserve, select
the contents of the set and create a new set.

Importing Adobe Illustrator 9.0 eps files into Maya

Importing an Adobe illustrator 9.0 eps file into Maya results in a transform
node, but there is nothing in the view.

Workaround

In Adobe illustrator 9.0, save as an eps file and specify that it be in Adobe
Illustrator 8.0 format.

(Mac OS X) Maya doesn’t recognize IGS file format

If you open the file browser and change the Files of Type field to IGES_DC (*iges;
*igs), Maya doesn't recognize files with the extension IGS.
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Workaround

Change the capitalization of the file's extension to .igs or .iges from .IGS.

Maya doesn’t recognize scene files prior to 3.0

Maya 2010 doesn’t recognize scene files prior to Maya 3.0.

Workaround

To load a scene file from an earlier version of Maya, first load the scene into
an intermediate release between up to Maya 5.0 and re-save the file.

File referencing limitations
Proxy references do not support renaming prefixes

Renaming prefixes do not work with proxy references for name clash
resolution.

Workaround

Use the namespace option when working with proxy references.

Namespaces and loading of referenced nodes

Maya always loads referenced nodes into a temporary namespace, then moves
them into their permanent namespace. Therefore, the name returned by the
node added callback is different than the name returned by the node removed
callback.

Workaround

In order to track nodes consistently, you must use the nameChanged callback
to find the name of the object after it has been put in its permanent
namespace.

Referencing multiple scenes that contain mental ray data produces
unexpected results

Referencing multiple scenes that contain mental ray for Maya data may cause
the following issues:

■ The Script Editor displays multiple warning messages regarding already
connected nodes when the referenced files are loaded.
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■ Rendering the scene produces an image based on unexpected render
settings.

Maya does not correctly distinguish between the shared nodes that exist for
mental ray Render Settings. Each time a reference within one of these nodes
is loaded, it applies the setAttrs and connectAttrs from that file to the shared
node. The mental ray for Maya Render Settings that result will depend on the
last reference that gets loaded.

Workaround

■ In Maya, set the same Render Settings for each file you intend to reference
for your scene.

■ Reference the files into your parent scene, ignoring the warning messages.

■ Confirm the mental ray for Maya Render Settings prior to rendering.

When a reference is locked, animation on compound attributes, such as
translate and rotate, may not play back.

Workaround

If you need the animation for feedback, but want to make sure that the
reference is not accidentally modified, you can customize your locking by
adding the parent compound attributes to the Excluded attributes script.
Alternatively, instead of locking the reference, you can put it in a display layer
with the appropriate settings to avoid accidentally selecting it.

Export As Reference not working with file references containing multiple
layers

It is not possible to Export As Reference multiple objects from a scene where
multiple layers exist.

Workaround

Remove the multiple layers and export the objects as references and reassign
the layers afterwards.

Poly mesh geometry must have construction history to be modified within
the parent scene

If you reference a scene containing a poly mesh and perform modifications
to that mesh from within the parent scene, those modifications will not be
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respected unless the poly mesh had an existing construction history before it
was referenced.

Workaround

Ensure that any referenced poly mesh geometry has at least one history node
in the referenced file prior to referencing.

Reference edits may be lost when using identical node names

In order to apply an edit to a node from a reference it must be able to uniquely
identify the node. In the following case this is not possible:

■ Using renaming prefixes and you add a node to the parent file that has
the same name as the renaming prefix and the reference node name.

Workaround

Make sure the names of your nodes are unique before you start applying edits
in the parent scene.

Hypergraph layouts of objects from referenced files ignored

The Hypergraph layouts of objects from referenced files are ignored when the
file is referenced.

Workaround

Make any adjustments to the layout of the objects in the referencing file. Keep
your Hypergraph closed when importing/referencing, and then clean up
afterwards.

Expressions and back-quoted commands limitation

If a referenced or imported file contains expressions and the expressions
contain back-quoted commands, then the part in back-quotes will not have
any node names prefixed properly.

Workaround

Use namespaces when referencing or importing files. Alternatively, you can
modify your expressions to not use MEL commands or back-quoted
expressions. C style expressions such as “foo.x = 0.5” are treated correctly in
references and the nodes will be correctly renamed. However, MEL style
commands such as “setAttr foo.x 0.5” will not work correctly.
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Limitations with using prefixes for name clash resolution

When referencing a file using a renaming prefix that in turn references a file
using a namespace, the outer renaming prefix will be turned into a namespace
instead.

Referencing a file into the same scene multiple times using the default
renaming prefix will result in ambiguous references to the objects contained
within that file. Note that referencing a file multiple times into the same scene
can happen indirectly if a file being referenced or imported references that
scene.

Workaround

Use namespaces for all your file references. For import though, once you use
namespaces, everything gets put in a namespace, whether it's clashing or not
(even if it already has a namespace, it gets another one added on). But if you
use prefixes, it will strip out existing namespaces, and then resolve clashes
with prefixes. So you may wish to choose your method of clash resolution
depending on what's in your file already. Alternatively, you can ensure that
you assign unique rename prefixes to files that will be imported multiple
times. You can do this by going to the File > Import options box or by using
the -renamingPrefix flag on the file command in the Script Editor.

Problems importing and referencing the same file with the same prefix

There are problems with importing and referencing the same file with the
same prefix. If the file is referenced and then imported then all is well.
However, if the file is imported and then referenced, there are ambiguities in
object names. Also, if the same renaming prefix is used with multilevel
references, the resulting file may contain errors.

Workaround

Use namespaces when importing or referencing files. Alternatively, you can
either reference the file before importing it or change the renaming prefix
between importing and referencing.

Namespace or name-clash mechanisms limitation

When creating a reference in the current scene, and this reference in turn
contains a referenced MEL script, the namespace or name-clash mechanisms
will not be applied to any node names referred to in the script. This can cause
problems if the MEL script relies on explicit names that are contained in the
referenced file.
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Workaround

Try to create MEL scripts that are not dependent on the actual naming of
nodes contained in the scene.

Can't replace nested reference

Replacing a nested reference file (i.e., a reference which is not a child of the
main scene) is a temporary action. The reference to the new file will not be
saved with the main scene.

Workaround

Open the parent file of the reference and replace it there.

Can’t save reference edits with Shared Shading Networks or Shared Display
Layers on

If a reference is created with the Shared Shading Networks or Shared Display
Layers options, you will not be able to Save Reference Edits to it. The menu
item in the UI is not available, and an error will be returned when using the
file -saveReference command.

Changing the structure of shading networks prevents sharing

When creating references with the Shared Shading Networks option you should
avoid changing the structure of any resulting shared shading networks. If
nodes are added or removed from the shading network in the parent scene
(for example, by creating a node in the parent scene and connecting it to one
of the referenced shading network nodes), the network may not be correctly
shared the next time a reference is reloaded.

This limitation does not apply to the modification of attributes or attribute
values: attributes can be added or deleted, and attribute values changed.

Problems with nodes when exporting animation

The export animation flags of the file command only write out animation
nodes. When you have animation nodes parented under other nodes which
are not exported, Maya writes out connectAttr commands that reference these
missing nodes. A relative path is used for these connectAttrs because the most
common scenario is when these missing nodes actually belong to some other
referenced file.

In cases where there are non-unique node names involved, the relative paths
for non-exported nodes can be the same if the exported nodes are parented
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under different nodes with the same name. This creates incorrect results when
the exported animation is re-imported to Maya.

Workaround

Make sure that parent (non-animation) nodes, such as locators, are uniquely
named, or choose a way of exporting (such as export selected) that also exports
the parented non-animation nodes.

UV values with no history may not be retrieved properly when file
referencing

Tweaked UV values on polygonal geometry with no history may not retrieve
properly in cases where that geometry comes from a referenced file.

Workaround

Introduce some minimal and benign construction history on the object in its
referenced file. For example, open the referenced file in Maya, select a vertex,
and execute the Edit Mesh > Transform Component command with
construction history enabled, without actually moving the vertex.
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Utilities and peripherals

RIB Export limitations
The following limitations and workarounds relate to Rib Export.

Not all Maya objects are converted by RIB plug-in

Not all Maya objects are converted by the RIB plug-in. Most notably, textures
and particles are not converted. However, cameras, lights, geometry and their
animation are translated correctly. A very simple algorithm maps Maya’s lambert,
phong, and blinn shaders to their RenderMan equivalents and copies the color
attribute. If a texture is mapped to the shader in Maya, then the resulting
RenderMan color will be indeterminate. Also note that this version of the plug-in
does not support per-face shading groups, thus shaders assigned to specific faces
will not be converted, and those faces will be white when rendered by
RenderMan.

Maya light decays and RenderMan default settings

RenderMan’s lights all have a decay of 2, which may cause illumination
mismatches in lighting if you have your light’s decay set to anything other than
2 in Maya.

Workaround

Set all Maya light decays to 2.

Maya’s ambient lights are not well represented in RenderMan

Maya’s ambient lights are not well represented in RenderMan and will tend to
wash out the RenderMan rendered scene once translated.
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Workaround

Reduce the intensity of your ambient lights before translation, remove them
altogether, or set the ambient shade parameter to 0 in Maya to better match
the RenderMan look.

Warnings for scene written to RIB with disabled motion blur

If a scene is written to RIB with motion blur disabled, when that file is rendered
by RenderMan it will generate warnings of the form: “R07005 Premature
RiMotionEnd”.

Workaround

These can be safely ignored. This problem will be corrected in a future Maya
release.

172 | Chapter 26   Utilities and peripherals



API and Devkit

API and Devkit limitations
The following lists limitations and workarounds for the API and Devkit for Maya
2010. We also recommend that you read the API guide documentation before
attempting a major project using Maya.

(Windows) Incorrect compiler listed in API guide

An incorrect compiler is listed for Windows in the Compiler Requirements section
of the API guide. If you are developing plug-ins for Maya 2010 on Windows,
use the Visual Studio 2008 SP1 compiler.

It is not possible to distinguish between the color black and an unassigned
color in an MPxHwShaderNode plug-in

There currently is no way of setting what value to use for an unassigned color
of an MPxHwShaderNode plug-in. Currently, the color black or 0,0,0,1 is used as
the unassigned color.

Unable to unload an MPxNode plug-in if MPxData is specified

If a MPxNode plug-in creates an MPxData in its initialize() method, you will
receive a warning that the plug-in is in use when trying to unload it even if you
have not created a node. This is because the proxy MPxData type is in use.

Workaround

Do not create the MPxData until it is required in the compute() method.
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MItMeshPolygon::getColors(colorArray) does not provide access to all
colors

There is a second parameter to the MItMeshPolygon::getColors() method.
This parameter specifies the list of color sets that should be considered in the
method. If not specified, this method will operate on the current color set.

Workaround

Specify the list of color sets that should be considered by the
MItMeshPolygon::getColors() method.

Plugs are deleted upon deleting or disconnecting nodes

When deleting or disconnecting nodes that are connected to other nodes, the
plugs that are connected to the deleted or disconnected nodes gets deleted as
well.

Workaround

Create a new plug for every attribute.

Attribute changed callbacks limitation

Attribute changed callbacks are not invoked if the modification to the attribute
is made by a tool such as Move.

MFnDependencyNode flags limitation

MFnDependencyNode flags are not reset when they are deallocated. Resetting
these flags requires an entire DG traversal.

For best performance, it is better for you to control this operation since you
may only be interested in a subset of the depend nodes in the scene.

MFnMesh::assignUVs() does not support history

The method MFnMesh::assignUVs() does not support history. As a result,
modifications made to UVs with this method may be overwritten as the
dependency graph updates.

Long names of attributes can be incorrectly re-used

It is possible to create new attributes on a node that have the same long name
as an already existing attribute but differs by the short name. This will cause
updating problems for the Channel Box and Attribute Editor.
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API plugs and dependencies hierarchy limitation

The API does not support hierarchies of plugs and their dependencies in a
single dependency node. Dirty propagation works correctly across connections
between nodes, but not between internal attributes on a user-defined node
made with MPxNode.

Workaround

Use the method attributeAffects() to “flatten hierarchies” when declaring
their affects behavior between all inputs and outputs on your node.

OBJ files need “.obj” extension

Wavefront OBJ files need the .obj extension to be recognized automatically
when the File > Open Scene Import option is set to Best Guess.

Workaround

Set the Import option to OBJ to import a file without the .obj extension.

Batch rendering scenes with plug-ins

If you have a Maya scene that uses two (or more) plug-ins, both of which fail
in their “initializePlugin” method (due to a missing license for example), and
both plug-ins require one of the libraries OpenMayaUI, OpenMayaAnim or
OpenMayaFX, when attempting to batch render the scene Maya may produce
a fatal error.

Workaround

Manually add the following lines at the end of your userPrefs.mel file.

dynamicLoad OpenMayaUI

dynamicLoad OpenMayaAnim

dynamicLoad OpenMayaFX

Unloading and reloading plug-in

If a plug-in command is called from an expression or a MEL procedure, and
after the expression or procedure has been parsed, the plug-in is unloaded (or
unloaded and then reloaded), Maya may produce a fatal error if the expression
is triggered or the procedure is re-executed. When MEL parses the expression
or procedure, it saves a pointer to the doIt method of the plug-in command.
The value of this pointer is not normally recalculated, so if the plug-in is
unloaded or reloaded at a different location, the pointer is no longer valid.
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Similar issues will occur if MFnPlugin::registerUI() is used to register a
command defined by a plug-in.

Workaround

Enclose the call to the plug-in command in a MEL eval statement. This forces
MEL to compile the statement each time the expression is evaluated or the
procedure is run. If the plug-in has been unloaded this is detected and an error
results. If the plug-in has been reloaded, the new location of the doIt method
is computed during the recompile.

Custom material shader plug-in with a glow intensity attribute

If a custom material shader plug-in is implemented with a glow intensity
attribute, this attribute will be ignored by the software renderer unless an
internal Maya material shader in the scene (e.g. lambert, blinn, phong) has a
glowIntensity value greater than zero. Currently the software renderer only
queries material shader nodes that match the internal types for a
glowIntensity value that is greater than zero. There is no way to directly
override this limitation.

Workaround

In order to assure the rendering of a custom shader's glowIntensity attribute
an MSceneMessage::kBeforeSoftwareRender callback and an
MSceneMessge::kAfterSoftwareRender callback must be registered. The first
callback must create an internal material shader node via “shadingNode
-asShader lambert;” and it must retrieve the node name returned. Then it
must set that node's glowIntensity attribute to a value greater than zero. The
second callback will simply remove this “dummy” node.

Connecting the plugs of two nodes and breaking the connection

There may be situations in which it is desirable to connect the plugs of two
nodes and then soon after break this connection. If MDGModifier::connect()
is used to connect geometry data between two nodes and if this connection
is broken before the screen is refreshed the data will not be cached on the
downstream node.

Workaround

A call to

M3dView::active3dView().refresh();
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before disconnecting the plugs will force the dependency graph to evaluate.
This will cause the downstream geometry node to read the input data, and
after this evaluation the data is available for caching to the node if the
connection is subsequently broken.

Incomplete MPlugs

The plug passed to the user defined method that is registered with
MNodeMessage::addAttributeAddedOrRemovedCallback() is an incomplete
MPlug. Complex data type values will not be accessible via
MPlug::getValue(MObject value).

Workaround

This problem can be circumvented by using code similar to the following.

MFnDependencyNode fnDn(plug.node());

/*where "plug" is the name of the plug passed in as a parameter

*/

MString newPlugName(plug.name());

/* MPlug::name() will actually return a string containing the

"nodeName.attributeName" so it may need to be parsed for the fol

lowing call. */

MPlug realPlug = fnDn.findPlug(newPlugName);

In the above example, “realPlug” is a fully functional and accessible MPlug.

Custom nodes with store-able internal attributes that are arrays

Custom nodes with store-able internal attributes that are arrays may display
incorrect array indices when they are read into Maya from a scene file
containing the node. This will be apparent in the
MPxNode::setInternalValue() method if the number of array elements is
compared to the plug's logical index and they are found to be equal in value.
It is important to note that this will occur only with internal attributes.

Type of MObject that Maya passes

The type of MObject that Maya passes to the following methods will always
be MFn::kInvalid.
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virtual MPxGeometryIterator * iterator (MObjectArray & componentL

ist, MObject & component, bool useComponents)

virtual MPxGeometryIterator * iterator (MObjectArray & componentL

ist, MObject & component, bool useComponents, bool world) const

These routines are used in classes derived from MPxGeometryData. There is
currently no workaround for this problem.

No hooks for creating light shader nodes

There are currently no hooks from within the API for creating light shader
nodes with properties similar to Maya's area light node.

Creating a blendShape

If a blendShape is created from within the API using
MFnBlendShapeDeformer::create(), the method
MFnBlendShapeDeformer::addBaseObject() will fail if used with the MObject
of a curve that was newly created using MFnNurbsCurve::create().

Workaround

A simple workaround is to locate the MDagPath of the newly created NURBS
curve and obtain the MObject from that class. This object can be used
successfully with addBaseObject().

Tools performing “add pick”

Tools made with MPxSelectionContext perform an “add pick” by default as
opposed to the built in Maya selection tools which perform a “replace pick”
by default. An “add pick” adds a selection to the active selection list while a
“replace pick” replaces the current selection list with the selected object or
objects.

Workaround

Use MGlobal::displayInfo() to instruct the user to left click the mouse in an
empty part of the scene in order to begin a new selection.

Method setCursor()

When the method setCursor() is called with an instance of an
MPxSelectionContext class the method will fail. The same method called with
an instance of MPxContext will function as documented.
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Method MDrawRequestQueue::isEmpty()

Using the method MDrawRequestQueue::isEmpty() on an instance of
MDrawRequestQueue to which no MDrawRequests have been added will cause
Maya to crash.

Workaround

The method operates as documented if called on a queue to which one or
more MDrawRequests have been added. Incorporate state checking code to
assure that an MDrawRequest has been appended before make a call to
isEmpty().

Assigning a texture shader as an input to a built-in Maya material shader

When a user assigns a texture shader as an input to a built-in Maya material
shader (for example, lambert) a connection is automatically made between
the texture node's message attribute and the downstream materialInfo node's
texture[0] attribute. This is necessary for accurate hardware rendering. This
does not happen automatically with custom material shaders and procedures
will have to be implemented to make the connection. Unfortunately when
the scene is saved and re-opened the texture will no longer be connected to
the materialInfo node's texture[0] attribute. Instead the material shader's
message attribute will have this connection.

Workaround

Procedures will have to be implemented to break this connection and reconnect
the texture node's message attribute with the texture[0] attribute. Possible
solutions may include: the registering of a callback in the plug-in's initialize
method to check for this connection and alter it if necessary, or the
modification of the AE template script to make such connections when
necessary.

Monitoring the desired hardware resolution of a Texture2d node

To monitor the desired hardware resolution of a Texture2d node the renderer
queries its resolution attribute. This attribute is added dynamically to a texture
when the user sets the Hardware Texturing >Texture Quality of a built in
material shader node (e.g. lambert.). This is not the case with custom material
shader plug-ins.
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Workaround

A procedure must be implemented that will dynamically add the resolution
attribute (type kLong) to an input texture. The resolution attribute can have
the values: 32, 64, 128, or 256.

MPxContext::doHold() method

The MPxContext::doHold() method is called on a context tool even if the Alt
key is pressed. Ordinarily the use of the Alt key should override the context
tool and allow exclusive use of the tumble mechanism. Instead, both happen
simultaneously.

Shader plug-ins and using float2 compound attributes

Shader plug-ins that make use of float2 compound attributes may occasionally
receive incorrect data from the data block.

Workaround

It is best to extract the data as a compound attribute, and retrieve the contents
individually. In other words, the first example is preferred over the second
equivalent example.

float2& uv = block.inputValue( aUVCoord ).asFloat2();

float u = uv[0];

float v = uv[1];

vs.

float& u = block.inputValue( aUCoord ).asFloat();

float& v = block.inputValue( aVCoord ).asFloat();

Coding it the second way may result in the u and v values being the same in
certain cases.

Calling MFnMesh::deleteFace()

A call to MFnMesh::deleteFace() will insert a deleteComponent node as
construction history upstream from the affected mesh, however a call to
MFnMesh::addPolygon() does not insert a corresponding construction history
node.

Workaround

MFnMesh::addPolygon() should only be used from within the compute method
of a node that is placed upstream from the affected mesh object. Within the
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compute method the MFnMesh instance will act upon the kMeshData that is
passed through as input and output data.

Querying the active view port within the API

There is no way within the API to query the active view port to find out if
textures are currently displayed, nor is it possible to set this option.

MPxCommand and complex data types

When writing an MPxCommand that is intended to receive arguments from the
MEL command line, please be aware that there is no way to hand a command
plug-in a complex data type by pointer value.

Workaround

The class MArgList contains several methods that permit the passing of
complex data types from the MEL command line to a plug-in command. These
are:

MStatus get( unsigned& indexReadAndUpdate, MVector&, unsigned

numElements=3 ) const

MStatus get( unsigned& indexReadAndUpdate, MPoint&, unsigned

numElements=3 ) const

MStatus get( unsigned& indexReadAndUpdate, MMatrix& ) const

MStatus get( unsigned& indexReadAndUpdate, MIntArray& ) const

MStatus get( unsigned& indexReadAndUpdate, MDoubleArray& ) const

MStatus get( unsigned& indexReadAndUpdate, MStringArray& ) const

MFnPluginData::create() will fail to maintain a reference to an MObject

MFnPluginData::create() will fail to maintain a reference to an MObject if
the assignment is not done at the time of creation. For example this will fail:

fnPluginDat.create(id, &stat);

MObject obj = fnPluginDat.object();

Workaround

Always assign the MObject at the time of creation so that a reference will be
maintained internally. For example:

MObject obj = fnPluginDat.create(id, &stat);
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MFnFreePointTriadManipulator::setSnapMode(false)

If MFnFreePointTriadManipulator::setSnapMode(false) is set to false, it will
remain in snapMode if a single axis handle is manipulated. If the central
handle is used the manipulator will move freely.

Global selection list does not preserve selection order of mesh object
components

The global selection list does not preserve selection order of mesh object
components. For example, a tool designed to operate selected mesh vertices
should not depend on the selection order.

MItDependencyGraph only traverses connections that affect the specified
starting plug or node

MItDependencyGraph only traverses connections that affect the specified
starting plug or node. Therefore, it may not traverse some connected nodes,
such as connections to message attributes or dynamic attributes. Also,
connections to a transform node's translate, rotate, scale attributes will not
be found if traversing upstream through the worldMatrix output. Additionally,
since AnimUtil::isAnimated() relies on MItDependencyGraph for its
functionality, it will not find animCurves connected to the translate, rotate
or scale if getting there requires traversing the transform node's worldMatrix
attribute.

Workaround

When using MItDependencyGraph, when a transform node or message plug is
reached, prune the current iteration and start another MItDependencyGraph.
When using MAnimUtil::isAnimated(), when a transform node or message
plug is reached, call MAnimUtil::isAnimated() again.

Invoking the objExists MEL command limitation

Invoking the objExists MEL command with MGlobal::executeCommand()
during the retrieval of a scene file can produce incorrect results.

MArgDatabase::getFlagArgument() and MArgParser::getFlagArgument()
usage limitation

The methods MArgDatabase::getFlagArgument() and
MArgParser::getFlagArgument() require that numbers larger than 2^31 be
enclosed in quotes.
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MPxSurfaceShape related problems

The following lists MPXSurfaceShape related problems.

User defined shapes created with MPxSurfaceShape

User defined shapes created with MPxSurfaceShape cannot support
per-components texturing or shading.

MFileObject resolvedName empty if file not found

The resolved path and name for MFileObject are now empty if the file was
not found. Previously, they used to be the same as the raw path and name.

The following functions now return an empty string if the file was not found:

■ name()

■ path()

■ fullPath()

■ resolvedName()

■ resolvedPath()

■ resolvedFullName()

References to basic types

The API Guide notes that when an API method requires a pointer or a reference
to a basic type, such as 'int' or 'float', the MScriptUtil class must be used to
generate that pointer/reference since Python knows nothing about pointers
and cannot pass references to basic types.

The following example should help to clarify the usage of MScriptUtil. It
shows how to get the x, y and z values from a call to MFnLattice.getDivisions():
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import maya.OpenMaya as OpenMaya

import maya.OpenMayaAnim as Anim

xutil = OpenMaya.MScriptUtil()

xptr = xutil.asUintPtr()

yutil = OpenMaya.MScriptUtil()

yptr = yutil.asUintPtr()

zutil = OpenMaya.MScriptUtil()

zptr = zutil.asUintPtr()

it = OpenMaya.MItDependencyNodes(om.MFn.kFFD)

while not it.isDone():

latDefFn = Anim.MFnLatticeDeformer( it.thisNode() )

latFn = Anim.MFnLattice( latDefFn.deformLattice() )

latFn.getDivisions(xptr, yptr, zptr)

x = xutil.getUint(xptr)

y = yutil.getUint(yptr)

z = zutil.getUint(zptr)

doSomethingUseful(x, y, z)

it.next()

Since getUint() is a static method of MScriptUtil, an alternative way of
retrieving the final values is to call it directly from the class. For example:

x = OpenMaya.MScriptUtil.getUint(xptr)
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Documentation

Maya Help limitations
Selecting Help > Autodesk DirectConnect Help does not load DirectConnect
Help correctly

For Windows, selecting Help > Autodesk DirectConnect Help from the main
menu bar loads an old version of the DirectConnect help. On Mac OS X, selecting
Help > Autodesk DirectConnect Help launches the DirectConnect Web page.

Workaround

Navigate to the following directory and double-click the index.html file to open
the Autodesk DirectConnect help:

■ (Windows) C:\Program Files\Common Files\Autodesk

Shared\DirectConnect2010\docs

■ (Mac OS X) /Library/Application
Support/Autodesk/DirectConnect/3.0/Docs/

Page-internal links broken in Online Help on Safari and Firefox

When you view the Maya Online Help with Safari or Firefox, a problem with
the Help stylesheet prevents links to headings on the same page from working
correctly.

Workaround

While this problem does not prevent you from using the Online Help, you can
edit the stylesheet to repair the issue. It is recommended that you save a backup
copy of the stylesheet before making the following changes.
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To edit the stylesheet

1 Open the cpm.css stylesheet in a text editor. You can find the stylesheet
in the following locations:

■ (Windows) C:\Program
Files\Autodesk\Maya2010\docs\Maya2010\en_US\style

■ (Mac OS X) /Applications/Autodesk/maya2010/docs/en_US/style

■ (Linux) /usr/autodesk/maya2010-x64/docs/Maya2010/en_US/style

2 Remove the line display: none; from the following section:

.anchor_wrapper {

display: none;

}

3 Save and close the stylesheet file.

The next time you launch the Online Help using Safari or Firefox, page-internal
links will work as expected.

(Mac OS X) Maya Online Help search unavailable on some versions of Safari
4

You cannot search the Maya Help using the Search tab on some versions of
Safari 4.

Workaround

To ensure that you can search the Online Help from the Search tab, update
your Safari browser to version 4.0.3 or later.

(Linux) FBX Help does not launch

The FBX Help does not launch correctly when you select Help > Autodesk FBX
Help from the main menu bar in Maya.

Workaround

Launch the FBX Help from the following location:
/usr/autodesk/maya2010-x64/docs/Maya2010/en_US/fbx/en_US/index.html

(Windows) Microsoft Internet Explorer blocks help content

The Maya Help for Autodesk Maya uses JavaScript, which Microsoft Internet
Explorer blocks by default for HTML pages on My Computer.
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By default, each time the help is accessed from My Computer, you see a security
warning message asking you if you want to show active content. Clicking on
the message and selecting Allow Blocked Content allows the page to load.

To turn off this message permanently:

Within Internet Explorer, go to Tools > Internet Options, click the Advanced
tab, and scroll down to the Security section. Turn on “Allow active content
to run in files on My Computer.”

(Windows) Microsoft Internet Explorer shows a warning about an ActiveX
control

When you have registered the browser plug-in COM object on Windows
(seeInstall the Maya Web browser plug-in in the Basics guide) loading the Maya
Help system from My Computer may show the following warning:

“An ActiveX control on this page might be unsafe to interact with other parts
of this page. Do you want to allow this interaction?”

Click Yes to continue loading the help page.

Essential skills movies require QuickTime 7.1 or later

Please upgrade your version of QuickTime if you experience any problems
viewing the movies.

(Windows) Essential skills movies do not playback normally across network
with QuickTime 7

The Essential skills movies may not playback consistently if Maya is accessed
across a network when using QuickTime 7 for Windows. The movies will
playback normally if Maya is installed on your computer’s hard drive. This
was a known issue with Apple QuickTime 7 for Windows when Maya 7 was
shipped.

(Windows) Essential Skills Movies caption text may not appear at the
beginning of a movie when played

The caption text that normally appears at the bottom of the Essential Skills
Movies may not appear at the beginning of the movie on Windows computers
when the movie is first launched if the QuickTime Player options are set to
automatically play the movie when opened. This issue appears to only occur
on Windows.
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Workaround

On Windows computers, do the following in your QuickTime Player:

Select Edit > Preferences > Player preferences, and turn off Automatically play
movies when opened.

Select Edit > Preferences > QuickTime Preferences, select the Browser tab, and
turn off Play Movies Automatically.

(Windows) Essential Skills Movies caption text may appear incorrect when
the codepage setting and language setting for the movie are mismatched

The text captions for the Essential Skills movies may appear incorrectly when
played back on Windows computers when the codepage setting and language
setting for the movie are mismatched. For example, when playing back a
movie with the movie’s language set to Chinese, on a computer whose
codepage setting is Japanese, the Chinese caption text may appear incorrectly.
The audio works correctly in all cases. This was a known limitation with Apple
QuickTime 7 when Maya 8.5 was shipped.

Workaround

Play back movies in the language for which your computer is currently set.

(Mac OS X) Comments link generates corrupted page in Japanese Safari

If you click the Please send us your comments about this page link at the
bottom of a topic in the documentation in Japanese Safari, the help system
returns a corrupt page.

Workaround

Use another browser (such as Mozilla Firefox) to send comments.

Installing to a path with Japanese or other multibyte characters may prevent
the Maya Help from loading

If you install to Maya and the Maya docs to a path that contains Japanese or
other multibyte characters, you may encounter problems loading the Maya
Help, depending on your browser.

Workaround

Install the documentation to a path with no multibyte characters and use the
Window > Settings/Preferences > Preferences > Help > Help Location to point
Maya to the new help location using the Remote help option.
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Double byte space causes error in search in Japanese help

If you input a double byte space character in the search field of the Japanese
Maya Help, the search function won’t work.

Workaround

Avoid using the double byte space character in the search field.

Maya Help search engine errors in Japanese Internet Explorer

In Internet Explorer, searching common terms such as “UV Editor” with the
OR parameter on may result in a “Stop running this script?” warning. Clicking
Yes in this dialog causes the search to stall.

Workaround

Do one of the following:

■ Click No in the warning dialog box until the search results appear.

■ Switch the search parameter from OR to AND. If the same warning appears,
click No in the warning dialog until the search results appear.

■ Use another supported browser, like Mozilla Firefox (this error does not
occur on Firefox).

Incorrect file path in Linux compiler requirement

In the Developer Resources > API Guide > Setting up your build environment
> Linux compiler requirement section, the gcc compiler instructions state to
run the following on 1 line.

../files/gcc-4.1.2/configure --prefix=/opt/gcc412 --program-suf

fix=412 --enable-shared --enable-threads=posix --enable-checking=re

lease --with-system-zlib --disable-libunwind-exceptions --enable-

__cxa_atexit

However, the first part should be ../gcc-4.1.2/configure instead of
../files/gcc-4.1.2/configure.
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