Skip to content

[Feature] Improve naming, since load-image.js and load-image.min.js are not the same  #63

@raul782

Description

@raul782

The name of the core library load-image.js is misleading from a Developer Experience perspective (Specially for newcomers or people that is using this library as part of file-upload library).

I suggest to rename the core component as load-image.core.js or some name that distance itself from the load-image.min.js which contains the whole suit of components.

Or the other way around, we could use load-image.full.min.js to put emphasis that this minified version has all the components needed.

I know it's stated on the doc's page, but unless you are contributing directly to this library, it's not as straightforward as I think. Most of the time you use it as part of jQuery-File-Upload library.

If you compare this project with jQuery-File-Upload, there is direct correlation between the core component and it's minified version

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Projects

    No projects

    Milestone

    No milestone

    Relationships

    None yet

    Development

    No branches or pull requests

    Issue actions