-
-
Notifications
You must be signed in to change notification settings - Fork 25.8k
MNT Avoid catastrophic cancellation in mean_variance_axis #19766
New issue
Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.
By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.
Already on GitHub? Sign in to your account
Merged
ogrisel
merged 8 commits into
scikit-learn:main
from
jeremiedbb:improve-sparse-variance-precision
Mar 31, 2021
Merged
Changes from all commits
Commits
Show all changes
8 commits
Select commit
Hold shift + click to select a range
7d5c4a8
compute weight sum manually to reduce rounding errors
jeremiedbb 2057369
use weights shape
jeremiedbb 4d6ba86
avoid catastrophic cancellation
jeremiedbb 3947456
cln
jeremiedbb eb52ff5
add what's new
jeremiedbb 5c06cc0
Merge branch 'master' into improve-sparse-variance-precision
jeremiedbb fce4257
improve readability, remove 1 unecessary array
jeremiedbb 7b43f52
add comments
jeremiedbb File filter
Filter by extension
Conversations
Failed to load comments.
Loading
Jump to
Jump to file
Failed to load files.
Loading
Diff view
Diff view
There are no files selected for viewing
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Add this suggestion to a batch that can be applied as a single commit.
This suggestion is invalid because no changes were made to the code.
Suggestions cannot be applied while the pull request is closed.
Suggestions cannot be applied while viewing a subset of changes.
Only one suggestion per line can be applied in a batch.
Add this suggestion to a batch that can be applied as a single commit.
Applying suggestions on deleted lines is not supported.
You must change the existing code in this line in order to create a valid suggestion.
Outdated suggestions cannot be applied.
This suggestion has been applied or marked resolved.
Suggestions cannot be applied from pending reviews.
Suggestions cannot be applied on multi-line comments.
Suggestions cannot be applied while the pull request is queued to merge.
Suggestion cannot be applied right now. Please check back later.
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
A more explicit name:
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
sum_weights
is the sum of all weights where X is not nansum_weights_nan
is the sum of weights where X is nansum_weights_nz
is the sum of weights where X is non zeroFollowing the same scheme:
counts
is the number of elements which are not nancounts_nz
is the number of elements which are non zeroI'd rather keep that. Maybe you missed that the increment is negative (
counts[col_ind] -= 1
).Let me try to reorder the code such that the match is clearer (and remove
sum_weights_nan
, we actually need only 2 out the 3 arrays).There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Yes I was mistaken with the suggestion. I was thinking about the negation of it, so it the suggestion should have been
counts_non_nan
.If we do not change the name, I think we should at least put a comment above
counts
to say that it is the number of elements which are not nan.There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
I added comments to describe the different arrays