Routing Technique
Routing Technique
Routing Technique
This module provides configuration procedures for Cisco 3900 series, Cisco 2900 series, and Cisco 1900
series integrated services routers (ISRs). It also includes configuration examples and verification steps
whenever possible.
Note
See Appendix A, Cisco IOS CLI for Initial Configuration for information on how to perform the initial
configuration using the Cisco Internet Operating System (IOS) command line interface on Cisco 3900
series, Cisco 2900 series, and Cisco 1900 series integrated services routers.
Basic Configuration
Interface Configuration
Routing Configuration
Cisco 3900 Series, Cisco 2900 Series, and Cisco 1900 Series Integrated Services Routers Generation 2 Software Configuration Guide
13
Chapter
Default Configuration
Default Configuration
When you boot up your Cisco router for the first time, you notice some basic configuration has already
been performed. Use the show running-config command to view the initial configuration, as shown in
the following example.
Router# show running-config
Building configuration...
Current configuration : 723 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
multilink bundle-name authenticated
!
!
archive
log config
hidekeys
!
!
!
!
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
Cisco 3900 Series, Cisco 2900 Series, and Cisco 1900 Series Integrated Services Routers Generation 2 Software Configuration Guide
14
Chapter
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 3
login
!
exception data-corruption buffer truncate
scheduler allocate 20000 1000
end
SUMMARY STEPS
1.
configure terminal
2.
hostname name
3.
4.
no ip domain-lookup
DETAILED STEPS
Step 1
Command
Purpose
configure terminal
Example:
Router> enable
Router# configure terminal
Router(config)#
Step 2
hostname name
Example:
Router(config)# hostname Router
Router(config)#
Cisco 3900 Series, Cisco 2900 Series, and Cisco 1900 Series Integrated Services Routers Generation 2 Software Configuration Guide
15
Chapter
Step 3
Command
Purpose
Example:
Router(config)# enable secret cr1ny5ho
Router(config)#
Step 4
no ip domain-lookup
Example:
Router(config)# no ip domain-lookup
Router(config)#
For complete information on global parameter commands, see the Cisco IOS Release configuration
guide documentation set.
Tip
Syntax
Description
i/o-memory-percentage
We recommend that you configure the memory-size iomem below 25%. Any value above 25% should be
used only for enhancing IPSec performance.
When you specify the percentage of I/O memory in the command line, the processor memory
automatically acquires the remaining percentage of DRAM memory.
Example
The following example allocates 25% of the DRAM memory to I/O memory and the remaining 75% to
processor memory:
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# memory-size iomem 5
IO memory size too small: minimum IO memory size is 201M
Router(config)#
Router(config)# memory-size iomem ?
<5-50> percentage of DRAM to use for I/O memory: 5, 10, 15, 20, 25, 30, 40, 50
Router(config)# memory-size iomem 25
Smart-init will be disabled and new I/O memory size will take effect upon reload.
Router(config)# end
Cisco 3900 Series, Cisco 2900 Series, and Cisco 1900 Series Integrated Services Routers Generation 2 Software Configuration Guide
16
Chapter
Interface Ports
Table 1 lists the interfaces that are supported on Cisco 3900 series, Cisco 2900 series, and Cisco 1900
series integrated services routers.
Table 1
1941
29011
Onboard WLAN
Wlan-ap0
not supported
not supported
not supported
not supported
Onboard WLAN GE
connection to MGF2
Wlan-Gi0/0
not supported
not supported
not supported
not supported
Onboard ISM GE
service-module service-moduleinterface on the PCIe -name-ISM 0/0 name-ISM 0/0
service-modulename-ISM 0/0
service-modulename-ISM 0/0
not supported
Onboard ISM GE
connection to MGF
service-modulename-ISM 0/1
service-modulename-ISM 0/1
not supported
USB
usbflash0,
usbflash1
usbflash0,
usbflash1
usbflash0,
usbflash1
usbflash0,
usbflash1
usbtoken0,
usbtoken1
usbtoken0,
usbtoken1
usbtoken0,
usbtoken1
usbtoken0,
usbtoken1
Interfaces on HWIC
and VWIC
interface0/0/
port
interface0/1/
port
interface0/0/port
interface0/1/port
interface0/2/port
interface 0/3/port
interface0/0/port
interface0/1/port
interface0/2/port
interface 0/3/port
interface0/0/port
interface0/1/port
interface0/2/port
interface 0/3/port
<int>0/0/<port>
<int>0/1/<port>
<int>0/2/<port>
Interfaces on Double
Wide-HWIC
interface0/1
port
interface0/1/port
interface0/1/port
interface0/1/port
<int>0/1/<port>
interface0/3/port
interface0/3/port
interface0/3/port
interface1/port
interface1-2/port3
interface1-4/port4
not supported
Gi0/0,Gi0/1,GI0/2
Gi0/0,Gi0/1
not supported
Gi0/0,Gi0/1,GI0/2
Onboard GE ports
Interfaces on SM
Gi0/0,Gi0/1
Gi0/0,Gi0/1,GI0/2,
GI0/3
usbflash0, usbflash1
usbtoken0,
usbtoken1
interface1-2/port
interface1-4/port
Cisco 3900 Series, Cisco 2900 Series, and Cisco 1900 Series Integrated Services Routers Generation 2 Software Configuration Guide
17
Chapter
Table 1
29011
1941
Interfaces on Double
Wide-SM
not supported
not supported
not supported
Interfaces HWIC on
SM
not supported
not supported
interface1wic-slot/ interface1-2/wicport
slot/port7
Interfaces VWIC on
SM
interface 2/port
interface4/port6
interface1-4/wicslot/port8
1. On the Cisco 2901 router, the numbering format for configuring an asynchronous interface is 0/slot/port. To configure the line associated with an
asynchronous interface, simply use the interface number to specify the asynchronous line. For example, line 0/1/0 specifies the line associated with
interface serial 0/1/0 on a WIC-2A/S in slot 1. Similarly, line 0/2/1 specifies the line associated with interface async 0/2/1 on a WIC-2AM in slot 2.
2. MGF = multi-gigabit fabric
3. Applies only to Cisco 2951, Cisco 3925, and Cisco 3925E routers.
4. Applies only to Cisco 3945 and Cisco 3945E routers.
5. Applies only to Cisco 2951, Cisco 3925, and Cisco 3925E routers.
6. Applies only to Cisco 3945 and Cisco 3945E routers.
7. Applies only to Cisco 2951, Cisco 3925, and Cisco 3925E routers.
8. Applies only to Cisco 3945 and Cisco 3945E routers.
SUMMARY STEPS
1.
2.
3.
no shutdown
4.
exit
DETAILED STEPS
Step 1
Command
Purpose
Example:
Router(config)# interface gigabitethernet 0/1
Router(config-if)#
Step 2
Example:
Router(config-if)# ip address 192.168.12.2
255.255.255.0
Router(config-if)#
Cisco 3900 Series, Cisco 2900 Series, and Cisco 1900 Series Integrated Services Routers Generation 2 Software Configuration Guide
18
Chapter
Step 3
Command
Purpose
no shutdown
Example:
Router(config-if)# no shutdown
Router(config-if)#
Step 4
exit
Example:
Router(config-if)# exit
Router(config)#
SUMMARY STEPS
1.
2.
3.
exit
Cisco 3900 Series, Cisco 2900 Series, and Cisco 1900 Series Integrated Services Routers Generation 2 Software Configuration Guide
19
Chapter
DETAILED STEPS
Step 1
Command
Purpose
Example:
Router(config)# interface Loopback 0
Router(config-if)#
Step 2
Example:
Router(config-if)# ip address 10.108.1.1
255.255.255.0
Router(config-if)#
Step 3
exit
Example:
Router(config-if)# exit
Router(config)#
Example
The loopback interface in this sample configuration is used to support Network Address Translation
(NAT) on the virtual-template interface. This configuration example shows the loopback interface
configured on the gigabit ethernet interface with an IP address of 200.200.100.1/24, which acts as a static
IP address. The loopback interface points back to virtual-template1, which has a negotiated IP address.
!
interface loopback 0
ip address 200.200.100.1 255.255.255.0 (static IP address)
ip nat outside
!
interface Virtual-Template1
ip unnumbered loopback0
no ip directed-broadcast
ip nat outside
!
Verifying Configuration
To verify that you have properly configured the loopback interface, enter the show interface loopback
command. You should see verification output similar to the following example.
Router# show interface loopback 0
Loopback0 is up, line protocol is up
Hardware is Loopback
Internet address is 200.200.100.1/24
MTU 1514 bytes, BW 8000000 Kbit, DLY 5000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation LOOPBACK, loopback not set
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/0, 0 drops; input queue 0/75, 0 drops
Cisco 3900 Series, Cisco 2900 Series, and Cisco 1900 Series Integrated Services Routers Generation 2 Software Configuration Guide
20
Chapter
Note
The TTY lines are asynchronous lines used for inbound or outbound modem and terminal connections
and can be seen in a router or access server configuration as line x. The specific line numbers are a
function of the hardware built into or installed on the router or access server. In Cisco ISR G2 series
routers, the TTY lines are incremented by 1 and start with line number3 instead of line number 2 in Cisco
ISR G1 series routers. In ISR G2 series routers, line number 2 cannot be accessed since it has been used
for the second core feature.TTY lines are not static and line numbers can be changed in future when more
features are added similar to the second core.
SUMMARY STEPS
1.
2.
password password
3.
login
4.
5.
6.
password password
7.
login
8.
end
Cisco 3900 Series, Cisco 2900 Series, and Cisco 1900 Series Integrated Services Routers Generation 2 Software Configuration Guide
21
Chapter
DETAILED STEPS
Step 1
Command
Purpose
Example:
Step 2
password password
Example:
Router(config-line)# password 5dr4Hepw3
Router(config-line)#
Step 3
login
Example:
Router(config-line)# login
Router(config-line)#
Step 4
Step 5
Example:
Router(config-line)# line vty 0 4
Router(config-line)#
Step 6
password password
Example:
Router(config-line)# password aldf2ad1
Router(config-line)#
Step 7
login
Example:
Router(config-line)# login
Router(config-line)#
Step 8
end
Example:
Router(config-line)# end
Router#
Cisco 3900 Series, Cisco 2900 Series, and Cisco 1900 Series Integrated Services Routers Generation 2 Software Configuration Guide
22
Chapter
Example
The following configuration shows the command-line access commands.
You do not need to input the commands marked default. These commands appear automatically in the
configuration file generated when you use the show running-config command.
!
line con 0
exec-timeout 10 0
password 4youreyesonly
login
transport input none (default)
stopbits 1 (default)
line vty 0 4
password secret
login
!
SUMMARY STEPS
1.
2.
end
DETAILED STEPS
Step 1
Command
Purpose
Example:
Router(config)# ip route 192.168.1.0
255.255.0.0 10.10.10.2
Router(config)#
Step 2
end
Example:
Router(config)# end
Router#
Cisco 3900 Series, Cisco 2900 Series, and Cisco 1900 Series Integrated Services Routers Generation 2 Software Configuration Guide
23
Chapter
Example
In the following configuration example, the static route sends out all IP packets with a destination IP
address of 192.168.1.0 and a subnet mask of 255.255.255.0 on the Gigabit Ethernet interface to another
device with an IP address of 10.10.10.2. Specifically, the packets are sent to the configured PVC.
You do not need to enter the command marked (default). This command appears automatically in the
configuration file generated when you use the show running-config command.
!
ip classless (default)
ip route 192.168.1.0 255.255.255.0 10.10.10.2!
Cisco 3900 Series, Cisco 2900 Series, and Cisco 1900 Series Integrated Services Routers Generation 2 Software Configuration Guide
24
Chapter
Verifying Configuration
To verify that you have properly configured static routing, enter the show ip route command and look
for static routes signified by the S.
You should see verification output similar to the following:
Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 1 subnets
C
10.108.1.0 is directly connected, Loopback0
S* 0.0.0.0/0 is directly connected, FastEthernet0
SUMMARY STEPS
1.
router rip
2.
version {1 | 2}
3.
network ip-address
4.
no auto-summary
5.
end
Cisco 3900 Series, Cisco 2900 Series, and Cisco 1900 Series Integrated Services Routers Generation 2 Software Configuration Guide
25
Chapter
DETAILED STEPS
Step 1
Command
Task
router rip
Example:
Router> configure terminal
Router(config)# router rip
Router(config-router)#
Step 2
version {1 | 2}
Example:
Router(config-router)# version 2
Router(config-router)#
Step 3
network ip-address
Example:
Step 4
no auto-summary
Example:
Router(config-router)# no auto-summary
Router(config-router)#
Step 5
end
Example:
Router(config-router)# end
Router#
Example
The following configuration example shows RIP version 2 enabled in IP network 10.0.0.0 and
192.168.1.0.
To see this configuration, use the show running-config command from privileged EXEC mode.
!
Router# show running-config
router rip
version 2
network 10.0.0.0
network 192.168.1.0
no auto-summary
!
Cisco 3900 Series, Cisco 2900 Series, and Cisco 1900 Series Integrated Services Routers Generation 2 Software Configuration Guide
26
Chapter
Verifying Configuration
To verify that you have properly configured RIP, enter the show ip route command and look for RIP
routes signified by R. You should see a verification output like the example shown below.
Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
C
R
SUMMARY STEPS
1.
2.
network ip-address
3.
end
DETAILED STEPS
Step 1
Command
Purpose
Example:
Router(config)# router eigrp 109
Router(config)#
Step 2
network ip-address
Example:
Step 3
end
Example:
Router(config-router)# end
Router#
Cisco 3900 Series, Cisco 2900 Series, and Cisco 1900 Series Integrated Services Routers Generation 2 Software Configuration Guide
27
Chapter
Example
The following configuration example shows the EIGRP routing protocol enabled in IP networks
192.145.1.0 and 10.10.12.115. The EIGRP autonomous system number is 109.
To see this configuration use the show running-config command, beginning in privileged EXEC mode.
Router# show running-config
...
!
router eigrp 109
network 192.145.1.0
network 10.10.12.115
!
...
Verifying Configuration
To verify that you have properly configured IP EIGRP, enter the show ip route command, and look for
EIGRP routes indicated by D. You should see verification output similar to the following:
Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
C
D
Cisco 3900 Series, Cisco 2900 Series, and Cisco 1900 Series Integrated Services Routers Generation 2 Software Configuration Guide
28