CCIE SD-WAN Lab 1 Workbook
CCIE SD-WAN Lab 1 Workbook
CCIE SD-WAN Lab 1 Workbook
0 PRACTICAL BOOK
SD-WAN-Lab-1
Topology:
Here we are defining which hard drive will be used for configuration and policy data base, once we select that, it will
format that drive and reload the vmanage.
system
host-name vManage
system-ip 10.1.1.1
site-id 255
organization-name "Orhan LLC"
clock timezone Asia/Kolkata
vbond 172.16.30.103
ntp
server 172.16.30.105
version 4
prefer
exit
!
We need to configure all the SDWAN component system level configuration in which
we will configure the below configurations:
1. Organisation Name : Should be same as per the license file.
2. System-IP – it’s a kind of loopback address which needs to be configured
uniquely one each device.
3. Site-ID: This used to define the site domain, and it should be same on all the
components of the same site.
4. vBond: IP Address of vBond, as WAN edge firstly communicate vBond address,
and this address should be reachable.
5. NTP Server: this is required to synchronize the time across all the components of
the SDWAN.
VPN in SDWAN components are the other name of VRF, unlike VRF they
cannot be configured with name.
VPN 0 is reserved for all the control connection as well as the management
traffic, whereas they also have VPN 512, which is just responsible for
handling management traffic.
Management ports are kept separate as well and maintain a separate VPN, which
is internally maintained as VPN 512
VPN 0 is the transport VPN. It carries control traffic over secure DTLS or TLS
connections between vSmart controllers and vEdge routers, and between vSmart
controllers and vBond orchestrators. Initially, VPN 0 contains all a device's
interfaces except for the management interface, and all the interfaces are
disabled. For the control plane to establish itself so that the overlay network can
function, you must configure WAN transport interfaces in VPN 0.
system
host-name vSmart
system-ip 10.1.1.2
site-id 255
organization-name "Orhan LLC"
clock timezone Asia/Kolkata
vbond 172.16.30.103
ntp
server 172.16.30.105
version 4
prefer
exit
!
!
system
host-name vBond
system-ip 10.1.1.3
site-id 255
organization-name "Orhan LLC"
clock timezone Asia/Kolkata
vbond 172.16.30.103 local
ntp
server 172.16.30.105
version 4
prefer
exit
!
!
When we configure vBond IP address on vBond itself we need use its local address and
specify local keyword there.
vpn 0
interface ge0/0
ip address 172.16.30.103/24
ipv6 dhcp-client
tunnel-interface
encapsulation ipsec
no allow-service bgp
allow-service dhcp
allow-service dns
allow-service icmp
no allow-service sshd
no allow-service netconf
no allow-service ntp
no allow-service ospf
no allow-service stun
allow-service https
!
no shutdown
!
ip route 0.0.0.0/0 172.16.30.254
!
If you can see here, we are using ge0/0 instead of eth0, this is because vBond is the
same image as vEdge, the only difference is we enable vBond features in it.
vBond interface is configured default as tunnel-interface just like all the WAN edges, so
that it can accept all the type of traffic and able to terminate and initiate the IPSEC as
well as Control connections on it.
Here we found multiple ways to configure root CA in vmanage, lets talk about them:
1. Cisco – In this case Cisco will automatically PUSH the root CA certificate to the
controllers once they are able to communicate with Cisco ROOT CA server.
2. Symantic (Manual) – Here you need to download Root CA certitificate from
Symantic portal and upload on vManage Manually.
3. Symantic (Automatically) – In this mode same Symantic ROOT ca will be
uploaded to vManage automatically once its able to reach symantic Portal
4. Enterprise CA – this is the way in which you can use your internal enterprise CA
server to provide Root Cert and authenticate between the components. (this is the way
we are using in our LAB).
Step-9: Call API for Auto Sync the Root CA Cert. between all the components:
API: https://172.16.30.101/dataservice/system/device/sync/rootcertchain
With the help of this vManage API, we can sync the Root CA from vManage to other
controllers (vSmart and vBond), otherwise we have to upload the Root CA to all other
controller manually.
Other than root CA Certificate, we also need individual device certificates as well which
will be used for authenticating between the controllers as well as authenticating the
new onboarding WAN Edge devices.
Login into CA Server > Request a Certificate > Advance Certificate Request
Change the interface mode of vManage, vSmart and vBond to Tunnel Mode:
vBond(config)# vpn 0
vBond(config-vpn-0)# interface ge0/0
vBond(config-interface-ge0/0)# tunnel-interface
vBond(config-tunnel-interface)# encapsulation ipsec
vBond(config-tunnel-interface)# allow-service all
vBond(config-tunnel-interface)# commit
Commit complete.
In vBond we also need to configure encapsulation type as its vEdge image only and it needs
encapsulation type for the tunnel termination/Initialization.
We can see both the controllers are added but showing certificate installed, here its
device certificate because Root CA Cert. will be sync automatically as we have called
API for Auto Sync.
Generate and Install Device Certificates for vBond and vSmart:
Generate CSR for vBond:
Configuration > Certificates > Controller > vBond > Generate CSR:
Login into CA Server and generate Certificate by vBond CSR Same way you did for
vManage:
You can see all the three controllers are added with device certificate installed
Main Dashboard view:
Verification:
certificate-status Installed
certificate-validity Valid
certificate-not-valid-before Apr 22 05:52:59 2020 GMT
certificate-not-valid-after Apr 22 05:52:59 2022 GMT
dns-name 172.16.30.103
site-id 255
domain-id 0
protocol dtls
tls-port 23456
system-ip 10.1.1.1
chassis-num/unique-id 592f61ae-d65a-4cd4-8f31-9d4ffe9d1e48
serial-num 3F00000007A2A30292D3A8192E000000000007
cloud-hosted no
token -NA-
retry-interval 0:00:00:19
no-activity-exp-interval 0:00:00:20
dns-cache-ttl 0:00:02:00
port-hopped FALSE
time-since-last-port-hop 0:00:00:00
number-vbond-peers 1
INDEX IP PORT
-----------------------------------------------------
0 172.16.30.103 12346
number-active-wan-interfaces 4
Step-2: Configure WAN Edge (BR1) Interface (Internet) and Routing (BGP)
Configuration:
vpn 0
router
bgp 101
address-family ipv4-unicast
network 101.1.1.0/30
!
neighbor 101.1.1.1
no shutdown
remote-as 1001
address-family ipv4-unicast
!
!
interface ge0/0
ip address 101.1.1.2/30
ipv6 dhcp-client
tunnel-interface
encapsulation ipsec
allow-service all
no allow-service bgp
allow-service dhcp
allow-service dns
allow-service icmp
no allow-service sshd
no allow-service netconf
no allow-service ntp
no allow-service ospf
no allow-service stun
allow-service https
!
no shutdown
Verification:
There are two ways two upload serial number file on vManage:
1. Sync Smart Account – You should have valid credentials for using this feature of
your smartnet account, this way requires direct internet access.
2. Upload WAN Edge list – this way can be done offline in which file can be
download from cisco plug-n-play portal and uploaded to vmanage.
Step-4: Activate WAN Edge with Chassis Number and Serial Number:
BR1# request vedge-cloud activate chassis-number <Chassis Number from vManage> token <Serial Number from
vManage>
Verification:
Follow the same approach and register the Other WAN Edges:
We are using just MPLS links to connect with WAN Edges, INET link will be configured
later with help of Templates.
After registration, all nodes should be up and running
Event Status:
Event Status:
Audit Logs:
Device Templates:
Step-1: Configure Feature Template:
What is Device template?
Device templates define a device's complete operational configuration. A
device template consists of a number of feature templates. Each feature
template defines the configuration for a particular Cisco SD-WAN software
feature. Some feature templates are mandatory, indicated with an asterisk
(*), and some are optional. Each mandatory feature template, and some of
the optional ones too, have a factory-default template. For software features
that have a factory-default template, you can use either the factory-default
template (named Factory_Default_feature-name_Template) or you can
create a custom feature template.
When you click Device Specific, the Enter Key box opens. This box displays a
key, which is a unique string that identifies the parameter in a CSV file that
you create. This file is an Excel spreadsheet that contains one column for
each key. The header row contains the key names (one key per column),
and each row after that corresponds to a device and defines the values of
the keys for that device. You upload the CSV file when you attach a Viptela
device to a device template. For more information, see Use Variable Values
in Configuration Templates.
Configuration > Template > Feature > Create Template:
We have to create templates for both the interfaces MPLS & INTE, I know MPLS is
configured already but when we push template, we have to configure that again from
template.
Select VPN:
Tunnel Interface:
All service:
Confiure same tunnel and service parameters for INET interface as well.
Configure System Parameters:
BR1-2:
VRRP Configuration: