11-BGP Synchronization

Download as pdf or txt
Download as pdf or txt
You are on page 1of 3

BGP Synchronization:

o BGP will not advertise something that it learns from IBGP neighbor to EBGP neighbor.
o If the prefix can’t be validated in its IGP and by default, BGP synchronization is disabled.
o The BGP Synchronization mostly applies to interactions between two (2) separate AS.
o No synchronization command tells Routers that don't want them to "synchronize" iBGP.
o A Route learned via BGP will not be used nor advertised to an external neighbor BGP.
o And unless that same prefix is learned via an Interior Gateway Protocol (IGP) as well.
o A BGP border Router will not propagate a BGP-learned prefix to an eBGP neighbor.
o Unless that same IP prefix has been learned via an Interior Gateway Protocol (IGP).
o The BGP synchronization rule refers to prefix synchronization between BGP and IGP.
o If it is enabled, a BGP speakers will not advertise routes learned from an iBGP peer.
o Unless the destination described in the route is also reachable through the local IGP.

R1 Basic Configuration
R1(config)# interface ethernet 0/0
R1(config-if)# ip address 192.168.12.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# interface loopback 1
R1(config-if)# ip address 1.1.1.1 255.0.0.0
R1(config-if)# no shutdown
R2 Basic Configuration
R2(config)# interface ethernet 0/0
R2(config-if)# ip address 192.168.12.2 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# exit
R2(config)# interface ethernet 0/1
R2(config-if)# ip address 192.168.23.2 255.255.255.0
R2(config-if)# no shutdown
R3 Basic Configuration
R3(config)# interface ethernet 0/0
R3(config-if)# ip address 192.168.23.3 255.255.255.0
R3(config-if)# no shutdown

1 | P a g e Created by Ahmad Ali E-Mail: ahmadalimsc@gmail.com , Mobile: 056 430 3717


R1 BGP Configuration
R1(config)#router bgp 12
R1(config-router)#neighbor 192.168.12.2 remote-as 12
R1(config-router)#network 1.0.0.0 mask 255.0.0.0
R2 BGP Configuration
R2(config)#router bgp 12
R2(config-router)#neighbor 192.168.12.1 remote-as 12
R2(config-router)#neighbor 192.168.23.3 remote-as 3
R3 BGP Configuration
R3(config)#router bgp 3
R3(config-router)#neighbor 192.168.23.2 remote-as 12

R1 BGP configuration BGP Synchronization is disable by default.

R2 BGP configuration BGP Synchronization is disable by default.

BGP Synchronization is disable by default on R1 and R2 that’s why R3 get R1 Routes 1.0.0.0

R2 also getting R1 route in Routing table and BGP table as well.

2 | P a g e Created by Ahmad Ali E-Mail: ahmadalimsc@gmail.com , Mobile: 056 430 3717


R1 enable Synchronization
R1(config)#router bgp 12
R1(config-router)#synchronization
R2 enable Synchronization
R2(config)#router bgp 12
R2(config-router)#synchronization
R3 enable Synchronization
R2(config)#router bgp 3
R2(config-router)#synchronization

R3 is not receiving anymore R1 1.0.0.0 network in Routing table nor in BGP table.

R2 is still receiving R1 route 1.0.0.0 in BGP table but not in Routing Table anymore, also R2 stop
to advertise R1 routes to R3 Router.

3 | P a g e Created by Ahmad Ali E-Mail: ahmadalimsc@gmail.com , Mobile: 056 430 3717

You might also like