Router ConfigurationUpdate2

Download as docx, pdf, or txt
Download as docx, pdf, or txt
You are on page 1of 15

Cables required

Copper cross over cable ------------------


Copper straight Through ____________
Serial DTE / Serial DTC

R1 Commands

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1

R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit
R1(config)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit
R1(config)#interface FastEthernet0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#exit
R1(config)#interface Serial0/0/0
R1(config-if)#ip address 192.168.2.1 255.255.255.0
R1(config-if)#no sh
R1(config-if)#description R2 LAN

R1(config-if)#end
R1#copy running-config startup-config
R1#show running-config
R1# show interfaces fastEthernet 0/0
R1#show version
R1#show ip interface brief
____________

R2 Commands

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2

R2(config)#line console 0
R2(config-line)#password cisco
R2(config-line)#login
R2(config-line)#exit
R2(config)#line vty 0 4
R2(config-line)#password cisco
R2(config-line)#login
R2(config-line)#exit
R2(config)#interface FastEthernet0/0
R2(config-if)#ip address 192.168.3.1 255.255.255.0
R2(config-if)#exit
R2(config)#interface Serial0/0/0
R2(config-if)#ip address 192.168.2.2 255.255.255.0
R2(config-if)#clock rate 64000

R2(config-if)#no sh
R2(config-if)#description R2 LAN

R2(config-if)#end
R2#copy running-config startup-config
R2#show running-config
R2# show interfaces fastEthernet 0/0
R2#show version
R1#show ip interface brief

Ping (Verify connection)


Step 2: Repeat the ping from R1 to PC1.
R1#ping 192.168.1.10

Step 2: Use the tracert command at the Windows command prompt to discover the path that a
packet will take from the R1 router to PC1.
C:\>tracert 192.168.1.1
Erasing Router settings
R1#erase startup-config

R1#copy running-config startup-config

Test connection
R1#show ip route
R1#show ip int brief

LAB 3

Router>en
Router>config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#

Task 1: Cable, Erase, and Reload the Routers.

Router#erase startup-config
Router#reload

Task 2: Perform Basic Router Configuration.

R1- R2 – R3 - Configuration

Step 1: Use global configuration commands.

Router1(config)#hostname R1
R1(config)#no ip domain-lookup
R1(config)#enable secret class

Step 2: Configure the console and virtual terminal line passwords on each of the routers.

R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exec-timeout 0 0
R1(config-line)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exec-timeout 0 0
R1(config-line)#logging synchronous

Step 3: Add the logging synchronous command to the console and virtual terminal lines.
Repeat the same commands for R2 and R3
Task 3- configure interface router

R1(config)#interface fa0/0
R1(config-if)#ip address 172.16.3.1 255.255.255.0
R1(config-if)#no sh

Configure Serial port

R1(config)#interface s0/0/0
R1(config-if)#ip address 172.16.2.1 255.255.255.0
R1(config-if)#clock rate 64000
R1(config-if)#no sh
R1(config-if)#description

R2 Interface

R2(config)#interface fa0/0
R2(config-if)#ip address 172.16.1.1 255.255.255.0
R2(config-if)#no sh

Configure serial ports

R2(config)#interface s0/0/0
R2(config-if)#ip address 172.16.2.2 255.255.255.0
R2(config-if)#no sh

Connecting DTE
R2(config)#interface s0/0/1
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#clock rate 64000
R2(config-if)#no sh

R3 Interface

R3(config)#interface fa0/0
R3(config-if)#ip address 192.168.2.1 255.255.255.0
R3(config-if)#no sh

R3(config)#interface s0/0/1
R3(config-if)#ip address 192.168.1.1 255.255.255.0
R2(config-if)#no sh

The subnet mask of PC1 is wrong. In real world, should be 255.255.255.0


Pc 1

The subnet mask of PC2 is wrong. In real world, should b 255.255.255.0


Pc2

Pc 3
Static Routing
R1(config)#interface Serial0/0/0
R1(config-if)#ip route 0.0.0.0 0.0.0.0 172.16.2.2
R1 with default route

R2(config)#ip route 192.168.2.0 255.255.255.0 192.168.1.1


R2(config)#ip route 172.16.3.0 255.255.255.0 s0/0/0

R2 with next hub and exit interface


R3(config)#ip route 172.16.0.0 255.255.255.0 192.168.1.2
R3(config)#ip route 172.16.1.0 255.255.255.0 192.168.1.2
R3(config)#ip route 172.16.2.0 255.255.255.0 Serial0/0/1

Configuring simple E-Mail server. Automatic cable configuration

Device Interface IP Address Subnet Mask Default Gateway


GigabitEthernet0/0/0 192.168.1.1 255.255.255.0
R1
GigabitEthernet0/0/1 192.168.2.1 255.255.255.0
PC 1 NIC 192.168.1.2 255.255.255.0 192.168.1.1
PC 2 NIC 192.168.1.3 255.255.255.0 192.168.1.1
SW FastEthernet0/1 - - -
Sever0 NIC 192.168.2.2 255.255.255.0 192.168.2.1
Email Server Configuration
Make sure you configure email for clients in the server and set the domain name.

Client PC configuration
DHCP DNS and Web Server configuration in
cisco packet tracer 1

Default DNS
Device Interface IP Address Subnet Mask
Gateway Server
PT- FastEthernet0/0/0 192.168.2.2 255.255.255.0
Router FastEthernet0/0/1 192.168.1.2 255.255.255.0
DHCP NIC 192.168.1.4 255.255.255.0 192.168.1.2 192.168.1.9
DNS NIC 192.168.1.9 255.255.255.0 192.168.1.2 192.168.1.9
WEB NIC 192.168.1.7 255.255.255.0 192.168.1.2 192.168.1.9

DHCP SETTINGS
Router Settings
Router(config-if)# ip dhcp pool p1
Router(config)# network 192.168.1.0 255.255.255.0
Router(dhcp-config)# default-router 192.168.1.2
Router(dhcp-config)#exit

Router(config)# ip dhcp pool p2


Router(config)# network 192.168.2.0 255.255.255.0
Router(dhcp-config)# default-router 192.168.2.2
Router(dhcp-config)#exit
Dual Server is Self Integrated DNS Server Open Source Freeware for Windows/Linux. It has build in
Optional DHCP Server.

DHCP Server allots the IP addresses to computers, while DNS server resolves them. You need DHCP
Server if you do not want to manually maintain IP Addresses or you have less IP Addresses than
number of machines you have, as dynamic DHCP Server will recycle IP Addresses on machines.

DNS Server is needed for resolving hostnames to their IP addresses. Normally your ISP will provide
you with DNS Service. You may have your own DNS Server, which will resolve hostnames by
forwarding them to ISP's DNS Server and cache the addresses also.

If you have home/small office network with Unix/Linux machines, these machines will not be
resolved from each other, as Unix/Linux machines do not support NBNS protocol and you need your
own DNS Server. But how about resolving your local machines ?. Your ISP's DNS Server will not have
this list and your own DNS Server wont have them either. Most DNS Servers cannot do this.(unless
you configure dynamic updates, or use static IP addresses and manually enter them).

This server resolves dhcp alloted local machines automatically in addition to external hosts, with the
added advantage being both dhcp and dns server are allways in sync. Also there is no need to create
and maintain cumbersome zone files. Dual DHCP DNS Server is an Open-Source Freeware. In
addition, this server is designed for Load Sharing Replicated Operation

DNS Features include Forward and Reverse Lookup, Zone Transfer, Primary/Secondary Mode of
Operation, MX Records, Wildcard Records, Conditional and Default forwarding.

DHCP Fearures support Static and Dynamic 125 DHCP Ranges, Range Filters, Relay Agents and
BOOT, Options can be specified for DHCP Ranges, Global or for Static Hosts.

Either DHCP or DNS Service can be used. If both services are used, DHCP allotted hosts are
automatically added in DNS zones.
DNS+DHCP+HTTP Server & DHCP Service 2

Add device to router fastEthernet to use with copper media

DNS 192.168.30.10
HTTP 192.168.40.10
DHCP1 192.168.10.10
DHCP2 192.168.20.10

Default DNS Server


Device Interface IP Address Subnet Mask
Gateway
F/0 192.168.10.1 255.255.255.0
R1
Serial 10.0.0.1 255.255.255.0
F/0 192.168.20.1 255.255.255.0
Serial 10.0.0.2 255.255.255.0
R2
F1/0 192.168.40.1
6/0 192.168.30.1
DNS NIC 192.168.30.10 255.255.255.0 192.168.20.1 0.0.0.0
HTTP 192.168.40.10 255.255.255.0 192.168.20.1 192.168.30.10
DHCP1 NIC 192.168.10.10 255.255.255.0 192.168.10.1 192.168.30.10
DHCP2 NIC 192.168.20.10 255.255.255.0 192.168.20.1 192.168.30.10

CONFIGURE DHCP1 SERVICE


Default gateway 192.168.10.1
DNS Server 192.168.30.10
Start IP address 192.168.10.3

CONFIGURE DHCP2 SERVICE


Default gateway 192.168.20.1
DNS Server 192.168.30.10
Start IP address 192.168.20.3

CONFIGURE DNS SERVICE


Default gateway 192.168.20.1
DNS Server 192.168.30.10
Start IP address 192.168.20.3

CONFIGURE ROUTER 1 SERVICE

Router>en
Router# config t
Router(config)#hostname R1
R1(config)#enable secret class
R1(config)#int f0/0
R1(config-if)#ip address 192.168.10.1 255.255.255.0
R1(config-if)#no shutdown

R1(config)#int serial 2/0


R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown

On R1 CONFIGURE RIP
NETWORK 192.168.10.0 click on add
10.0.0.0 click on add

CONFIGURE ROUTER 2 SERVICE


Router>en
Router# config t
Router(config)#hostname R2
R2(config)#enable secret class
R2(config)#int f0/0
R2(config-if)#ip address 192.168.20.1 255.255.255.0
R2(config-if)#no shutdown

R2(config)#int serial 2/0


R2(config-if)#ip address 10.0.0.2 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#int f1/0
R2(config-if)#ip address 192.168.40.1 255.255.255.0
R2(config-if)#no shutdown
R2(config)#int f6/0
R2(config-if)#ip address 192.168.30.1 255.255.255.0
R2(config-if)#no shutdown

On R2 CONFIGURE RIP
NETWORK 192.168.10.0 click on add
192.168.20.0 click on add
192.168.30.0 click on add
192.168.40.0 click on add
10.0.0.0 click on add

On PC 0
C:\>ping 192.168.20.4

You might also like