01-BCMSN-Initial Config

Download as pdf or txt
Download as pdf or txt
You are on page 1of 9

BCMSN LAB 1

IOS Switching Initial Configuration

BCMSN LABS
Lab 1: IOS Switching Initial Configuration
Objective
Become familiar with the lab access menu, learn the lab topology, and provide the switches with
an initial configuration.

Lab Topology
For this lab, your network design will include two pods of devices. You will be responsible for
configuring the devices in both pods. The devices on the left side of the topology are in Pod 1.
The devices on the right side of the topology are in Pod 2. P1PC1 and P2PC2 are PC workstations.
P1ASW1 and P2ASW2 are access-layer switches. P1DSW1 and P2DSW2 are distribution-layer
switches. The access and distribution layers are two of the three layers in the Cisco three-layer
hierarchical network model, which also includes the core layer.
The Topology diagram below represents the NetMap in the Simulator. To access each of the devices from
within the Simulator, select the device name from the appropriate menu in the Simulator. For example,
to access P1ASW1, click the eSwitches button and select P1ASW1 from the drop-down menu.

P1PC1 172.16.1.1 P2PC2 172.16.2.2

Fa0/5 Fa0/5

P1ASW1 172.16.1.10 P2ASW2 172.16.1.2

Fa0/1 Fa0/2 Fa0/3 Fa0/4 Fa0/1 Fa0/2 Fa0/3 Fa0/4

Fa0/1 Fa0/2 Fa0/3 Fa0/4 Fa0/1 Fa0/2 Fa0/3 Fa0/4

Fa0/11 Fa0/11

P1DSW1 Fa0/12 Fa0/12 P2DSW2


172.16.1.100 172.16.1.200

Boson NetSim for CCNP Lab Manual 141


BCMSN LAB 1
IOS Switching Initial Configuration

Command Summary
Command Description
configure terminal enters global configuration mode
copy running-config startup-config backs up the active configuration to NVRAM
description description_text assigns a description to an interface
duplex duplex_mode sets the duplex configuration for an interface
enable password enters the privileged EXEC mode
exec-timeout 0 0 sets the timeout for the EXEC session to never logout
exit exits the current mode
hostname name sets the host name
interface fastethernet slot/port enters interface configuration mode
interface range fastethernet selects a range of interfaces to configure
slot/starting_port – ending_port
interface vlan 1 enters interface configuration mode, and enters the VLAN to which
ip address ip_address the IP information is assigned
line [aux | console | vty ] beginning_line_ specifies the line to be configured
number [ending_line_number]
logging console enables logging messages to the console port
logging synchronous enables synchronous logging of messages
login enables password checking
no ip domain-lookup disables IP Domain Name System host_name translation
password password specifies the password that is required for a user to log in
ping ip_address sends an ICMP echo request
service timestamps [log | debug] uptime enables log and debugging time stamps
service timestamps [log | debug] datetime
[msec] [localtime] [show-timezone]
show cdp neighbor {detail} displays the cdp neighbor entries
show interfaces fastethernet mod/port displays switchport information
switchport
show interfaces status displays the line status of all interfaces
show running-config displays the active configuration
shutdown; no shutdown disables an interface; enables an interface
speed speed sets the line speed
switchport mode access sets the trunking mode to access unconditionally
telnet ip_address starts the terminal emulation program from a PC, router, or switch
that permits you to access devices remotely over the network

142 Boson NetSim for CCNP Lab Manual


BCMSN LAB 1
IOS Switching Initial Configuration

Lab Tasks
Task 1: Discover Lab Topology and Make Port Assignments
Complete the following diagram with the appropriate port assignments for the devices that you
will be configuring. Use CDP to gather the necessary information.

P1PC1 P2PC2

P1ASW1 P2ASW2

P1DSW1 P2DSW2

Task 2: Reset and Configure Lab Devices


In this lab, you will return all of the devices to a default configuration and apply a basic
configuration.
1. On every device, enter the global configuration mode.
2. Assign a host name to each device, per the network topology diagram.
3. On every device, configure the enable password to cisco.
4. Assign the addresses in the Lab Topology diagram to the appropriate interfaces on each
device. For the ASWs and the DSWs, this will be the VLAN1 interface. The subnet mask
will be 255.255.0.0 for all devices. Be sure to enable the ASW and DSW interfaces.
5. On each device, configure the console port to process logins. Configure a console
password of cisco.
6. On each device, configure vty ports 0 through 4 to process logins. Configure a vty
password of cisco.

Boson NetSim for CCNP Lab Manual 143


BCMSN LAB 1
IOS Switching Initial Configuration

7. On each ASW, enable the interface that connects the ASW to the PC router. Set the speed
and duplex to their proper settings. Set a description on each ASW. For instance, set the
following description on P1ASW1: description student P1PC1 on P1ASW1.
8. On each ASW, enable the interfaces that connect the ASW to the DSWs. Set the speed and
duplex to their proper settings. Set a description on each ASW interface. For instance, set
the following description on P1ASW1 fa0/1: description P1ASW1 to P1DSW1.
9. On each DSW, enable the interfaces that connect the DSW to the ASWs. Set the speed and
duplex to their proper settings. Set a description on each DSW interface. For instance, set
the following description on P1DSW1 fa0/1: description P1DSW1 to P1ASW1.
10. Enable the interfaces that connect P1DSW1 to P2DSW2. Set the speed and duplex to
their proper settings. Set a description on each interface. For instance, set the following
description on P1DSW1 fa0/11: description P1DSW1 to P2DSW2.
11. On the ASWs and the DSWs, configure all Fast Ethernet ports to be access ports. Use the
show interfaces status command to verify that interface configurations are correct.
12. On the ASWs, use the following command to verify that switchport configurations are
correct: show interfaces fastethernet 0/1 switchport.
13. On every device, save your configurations to NVRAM.
Note: At this stage in the lab, it is advisable to save all device configurations for later use. To
accomplish this, select the Save Multi Devices Configs menu option from the File menu. Save
these files as Lab 1.

Lab Solutions
Task 2: Reset and Configure Lab Devices
1. configure terminal
2. hostname P1ASW1
3. enable password cisco
4. P1PC1:
ipconfig/ip 172.16.1.1 255.255.0.0
P1ASW1 and P1DSW1:
interface vlan1
ip address 172.16.1.1 255.255.0.0
no shut
5. line console 0
login
password cisco
6. line vty 0 4
login
password cisco
7. P1ASW1:
interface fa0/5
no shut
speed 10

144 Boson NetSim for CCNP Lab Manual


BCMSN LAB 1
IOS Switching Initial Configuration

duplex half
description student P1PC1 on P1ASW1
8. P1ASW1:
interface fa0/1
no shut
speed 100
duplex full
description P1ASW1 to P1DSW1
interface fa0/2
no shut
speed 100
duplex full
description P1ASW1 to P2DSW2
interface fa0/3
no shut
speed 100
duplex full
description P1ASW1 to P2DSW2
interface fa0/4
no shut
speed 100
duplex full
description P1ASW1 to P1DSW1
9. P1DSW1:
interface fa0/1
no shut
speed 100
duplex full
description P1DSW1 to P1ASW1
interface fa0/2
no shut
speed 100
duplex full
description P1DSW1 to P1ASW1
interface fa0/3
no shut
speed 100
duplex full
description P1DSW1 to P2ASW2
interface fa0/4
no shut

Boson NetSim for CCNP Lab Manual 145


BCMSN LAB 1
IOS Switching Initial Configuration

speed 100
duplex full
description P1DSW1 to P2ASW2
10. P1DSW1:
int fa0/11
no shut
speed 100
duplex full
description P1DSW1 to P2DSW2
int fa0/12
no shut
speed 100
duplex full
description P1DSW1 to P2DSW2
11. P1ASW1:
interface range fa0/1 – 5
switchport mode access
P1DSW1:
interface range fa0/1 – 10
switchport mode access
P1ASW1:
p1asw1#show interfaces status
Port Name Status Vlan Duplex Speed Type
Fa0/1 P1ASW1 to P1DSW1 connected 1 full 100 10/100BaseTX
Fa0/2 P1ASW1 to P1DSW1 connected 1 full 100 10/100BaseTX
Fa0/3 P1ASW1 to P2DSW2 connected 1 full 100 10/100BaseTX
Fa0/4 P1ASW1 to P2DSW2 connected 1 full 100 10/100BaseTX
Fa0/5 student P1PC1 on connected 1 half 10 10/100BaseTX
Fa0/6 notconnect 1 half 10 10/100BaseTX
Fa0/7 notconnect 1 auto auto 10/100BaseTX
Fa0/8 notconnect 1 auto auto 10/100BaseTX
Fa0/9 notconnect 1 auto auto 10/100BaseTX
Fa0/10 notconnect 1 auto auto 10/100BaseTX
Fa0/11 notconnect 1 auto auto 10/100BaseTX
Fa0/12 notconnect 1 auto auto 10/100BaseTX
12. P1ASW1#show interfaces fastEthernet 0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off

146 Boson NetSim for CCNP Lab Manual


BCMSN LAB 1
IOS Switching Initial Configuration

Access Mode VLAN: 1 (default)


Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Voice VLAN: none (Inactive)
Appliance trust: none
13. copy running-config startup-config

Sample Configuration Scripts


P1PC1
version 12.1
service timestamps debug datetime msec localtime
show-timezone
service timestamps log datetime msec localtime
show-timezone
no service password-encryption
!
hostname C:
!
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0
ip address 172.16.1.1 255.255.0.0
!
ip classless
ip http server
!
line con 0
exec-timeout 0 0
password cisco
logging synchronous
login
line aux 0
line vty 0 4
exec-timeout 0 0
password cisco
logging synchronous
login
!
end

Boson NetSim for CCNP Lab Manual 147


BCMSN LAB 1
IOS Switching Initial Configuration

Sample Configuration Scripts


P1ASW1 P1ASW1 (Continued)
version 12.1 !
no service pad interface FastEthernet0/7
! switchport mode access
hostname P1ASW1 no ip address
! !
enable password cisco interface FastEthernet0/8
! switchport mode access
ip subnet-zero no ip address
! !
interface FastEthernet0/1 interface FastEthernet0/9
description P1ASW1 to P1DSW1 switchport mode access
switchport mode access no ip address
no ip address !
duplex full interface FastEthernet0/10
speed 100 switchport mode access
! no ip address
interface FastEthernet0/2 !
description P1ASW1 to P1DSW1 interface FastEthernet0/11
switchport mode access switchport mode access
no ip address no ip address
duplex full !
speed 100 interface FastEthernet0/12
! switchport mode access
interface FastEthernet0/3 no ip address
description P1ASW1 to P2DSW2 !
switchport mode access interface Vlan1
no ip address ip address 172.16.1.10 255.255.0.0
duplex full no ip route-cache
speed 100 !
! ip http server
interface FastEthernet0/4 !
description P1ASW1 to P2DSW2 line con 0
switchport mode access password cisco
no ip address login
duplex full line vty 0 4
speed 100 password cisco
! login
interface FastEthernet0/5 line vty 5 15
description student P1PC1 on P1ASW1 login
switchport mode access !
no ip address end
speed 10
!

148 Boson NetSim for CCNP Lab Manual


BCMSN LAB 1
IOS Switching Initial Configuration

Sample Configuration Scripts


P1DSW1 P1DSW1 (Continued)
version 12.1 interface FastEthernet0/8
no service pad no ip address
! !
hostname P1DSW1 interface FastEthernet 0/9
! no ip address
ip subnet-zero !
! interface FastEthernet0/10
interface FastEthernet0/1 no ip address
description P1DSW1 to P1ASW1 !
no ip address interface FastEthernet0/11
duplex full description P1DSW1 to P2DSW2
speed 100 no ip address
! duplex full
interface FastEthernet0/2 speed 100
description P1DSW1 to P1ASW1 !
no ip address interface FastEthernet0/12
duplex full description P1DSW1 to P2DSW2
speed 100 no ip address
! duplex full
interface FastEthernet0/3 speed 100
description P1DSW1 to P2ASW2 !
no ip address interface Vlan1
duplex full ip address 172.16.1.100 255.255.0.0
speed 100 !
! ip classless
interface FastEthernet0/4 ip http server
description P1DSW1 to P2ASW2 !
no ip address line con 0
duplex full password cisco
speed 100 login
! line vty 0 4
interface FastEthernet0/5 password cisco
no ip address login
! line vty 5 15
interface FastEthernet0/6 login
no ip address !
! end
interface FastEthernet0/7
no ip address
!

Boson NetSim for CCNP Lab Manual 149

You might also like