-
Notifications
You must be signed in to change notification settings - Fork 881
feat: update language on workspace page #2220
New issue
Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.
By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.
Already on GitHub? Sign in to your account
Conversation
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Looks great!
@@ -79,7 +81,7 @@ const useStyles = makeStyles((theme) => ({ | |||
alignItems: "center", | |||
color: theme.palette.text.secondary, | |||
fontFamily: MONOSPACE_FONT_FAMILY, | |||
border: `1px solid ${theme.palette.divider}`, | |||
margin: "0px", |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
I'm pretty sure you can just pass the number 0
like margin: 0
. No idea if that's preferred or not, just thought I'd mention it for knowledge-share/curiosity
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Yeah, you're right. I always add them because I used to get NITed at an old job when I left them off. A brief google search doesn't reveal any strong opinions. I'm open to any convention!
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Yea I have no strong feelings either, I really don't know what's best hence curiosity.
I never want to unintentionally nit though, so I try to use conventional comments. I should've said
Thought(curiosity)
because code is like a beautiful article that creates interesting discussion, sometimes of which leads to edits, but often just leads to better understandings for future articles.
IDK.
It's friday.
* feat: update build url to @username/workspace/builds/buildnumber (#2234) * update build url to @username/workspace/builds/buildnumber * update errors thrown from the API * add unit tests for the new API * add t.parallel * get username and workspace name from params * fix: update icon (#2216) * feat: Show template description in `coder template init` (#2238) * fix: workspace schedule time displays (#2249) Summary: Various time displays weren't quite right. Details: - Display date (not just time) of upcoming workspace stop in workspace page - Fix ttlShutdownAt for various cases + tests - manual to non-manual - unchanged/unmodified - isBefore --> isSameOrBefore - use the delta (off by _ error) - pluralize units in dayjs.add * fix: Remove easter egg mentioning competitor (#2250) This is more confusing than helpful! * feat: Warn on coderd startup if access URL is localhost (#2248) * feat: use custom wireguard reverse proxy for dev tunnel (#1975) * fix: use correct link in create from template button (#2253) * feat: store and display template creator (#2228) * design commit * add owner_id to templates table * add owner information in apis and ui * update minWidth for statItem * rename owner to created_by * missing refactor to created_by * handle errors in fetching created_by names * feat: update language on workspace page (#2220) * fix: ensure config dir exists before reading tunnel config (#2259) * fix(devtunnel): close `http.Server` before wireguard interface (#2263) * fix: ensure `agentResource` is non-nil (#2261) * chore: add hero image to OSS docs homepage (#2241) * fix: Do not write 2 errors to api on template fetch error (#2285) * feat: add tooltips to templates page resolves #2242 Co-authored-by: Abhineet Jain <AbhineetJain@users.noreply.github.com> Co-authored-by: Joe Previte <jjprevite@gmail.com> Co-authored-by: Mathias Fredriksson <mafredri@gmail.com> Co-authored-by: G r e y <grey@coder.com> Co-authored-by: Kyle Carberry <kyle@coder.com> Co-authored-by: David Wahler <david@coder.com> Co-authored-by: Colin Adler <colin1adler@gmail.com> Co-authored-by: Garrett Delfosse <garrett@coder.com> Co-authored-by: Katie Horne <katie@coder.com> Co-authored-by: Steven Masley <Emyrk@users.noreply.github.com>
A small little tweak to language after some confusion about the workspace status field earlier this week. Feedback welcome.