-
-
Notifications
You must be signed in to change notification settings - Fork 25.8k
[MRG] LogisticRegression convert to float64 (sag) #9020
New issue
Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.
By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.
Already on GitHub? Sign in to your account
Closed
Closed
Changes from all commits
Commits
Show all changes
26 commits
Select commit
Hold shift + click to select a range
3e25392
Remove unused code
492bbd2
Squash all the PR 9040 commits
f10f250
Append 64 when the templated type is a double
f34879c
Add templating
1e8ec39
Add missing stuff
d781d5e
Fix tempita
7e2e417
Working templated version of sag_fast
1c10728
32 64 bit _finite macros (there should be a better way)
ce0f5dc
Import sag64 as sag to mimic the default behavior
43510cf
add saga and group the asserts
26a5ede
allow direct coef inspection from the pudb
cfdb2bb
test 64 bits first
5e302f8
Use [float64, float32] as default
90c0454
Allow sag to be 64 or 32
0011fd8
Change the parent function types so that single floats remain 64 like…
f647e39
fix np_types
10efe52
relax the almost equal assert up to 4 decimals
f34b80f
test newton-cg and saga
6c99f3e
Relax almost equal only for SAGA case
57675df
make the sag call more readable
6cae75a
Revert 3e25392
ccc89dc
update gitignore
c854204
Address @raghavrv comments
8655f4a
add a test for y
3a4ed49
Merge branch 'master' into is/8769
raghavrv 0a5eda0
Merge branch 'master' into is/8769
raghavrv File filter
Filter by extension
Conversations
Failed to load comments.
Loading
Jump to
Jump to file
Failed to load files.
Loading
Diff view
Diff view
There are no files selected for viewing
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Oops, something went wrong.
Add this suggestion to a batch that can be applied as a single commit.
This suggestion is invalid because no changes were made to the code.
Suggestions cannot be applied while the pull request is closed.
Suggestions cannot be applied while viewing a subset of changes.
Only one suggestion per line can be applied in a batch.
Add this suggestion to a batch that can be applied as a single commit.
Applying suggestions on deleted lines is not supported.
You must change the existing code in this line in order to create a valid suggestion.
Outdated suggestions cannot be applied.
This suggestion has been applied or marked resolved.
Suggestions cannot be applied from pending reviews.
Suggestions cannot be applied on multi-line comments.
Suggestions cannot be applied while the pull request is queued to merge.
Suggestion cannot be applied right now. Please check back later.
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Should we keep the name "ArrayDataset"? Why not write explicitly the number of bits?
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
IMHO that's how I would do it for the moment. Like this you ensure that we don't break anything.
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
+1 for preserving backward compatibility. The ArrayDataset class of scikit-learn 0.18.2 is 64 bit float based. Let's keep the same name as an alias. We could even setup the alias in sklearn/utils/seq_dataset even if Cython code is not official part of the project public API.
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
this also needs to be addressed