Cisco IOS Quick Reference Cheat Sheet 2.1
Cisco IOS Quick Reference Cheat Sheet 2.1
Cisco IOS Quick Reference Cheat Sheet 2.1
1
CISCO IOS QUICK REFERENCE CHEAT SHEET 2.1 ..............1 ROUTER MODES ...................................................................... 1 QUICK START .......................................................................... 1 RESTRICT ACCESS TO ROUTER .................................................... 1 PERFORM PASSWORD ENCRYPTION SERVICE................................. 1 SETUP SSH AND DISABLE TELNET ............................................... 1 DOING THE DO COMMAND ........................................................ 1 CONFIGURATIONS: VIEW, SAVE, ERASE ....................................... 1 SDM BASIC SETUP FOR HTTP, HTTPS ........................................... 1 CONFIGURE AN INTERFACE ........................................................ 2 CONNECTIVITY ......................................................................... 2 TELNET ................................................................................... 2 DEFAULT AND STATIC ROUTES.................................................... 2 DHCP SERVER ........................................................................ 2 NAT / PAT ............................................................................ 2 PRIVILEGE LEVEL ACCOUNT ........................................................2 SWITCH: BASICS .......................................................................2 SWITCH: PORT SECURITY ...........................................................2 SWITCH: VLAN ........................................................................3 SWITCH: CONFIGURE PORT AS A TRUNK PORT ...............................3 SWITCH: VTP (VERSION 1) ........................................................3 INTER-VLAN ROUTING .............................................................3 RIP ........................................................................................3 BGP.......................................................................................3 EIGRP....................................................................................3 OSPF: ....................................................................................3 ACCESS LIST: ............................................................................4 SEND LOGGING TO SYSLOG SERVER...............................................4 SET CLOCK...............................................................................4
Router Modes
R> (User-mode prompt) R# (Privileged-mode prompt) R(config)# (Global configuration mode) R(config-if)# (Interface mode) R(config-subif)# (Sub interface mode) R(config-line)# (Line mode) R(config-router)# (Router configuration mode)
Quick Start
R> enable R# config terminal R(config)# hostname [Router1] R(config)# exit R# R# ? (Help with commands)
User-mode
(Select a line) R(config)# line console 0 R(config)# line vty 0 4 R(config)# line aux 0 R(config)# password [password] R(config)# login R(config)# exec-timeout [10] [0] (M, S) Cisco IOS Quick Reference Cheat Sheet 2.1
R(config)# username [cisco] privilege 15 password 0 [cisco] R(config)# line console 0 R(config-line)# login local R(config)# line vty 0 4 R(config-line)# privilege level 15 R(config-line)# login local R(config-line)# transport input ssh
NAT
R(config)# ip nat inside source static [10.10.10.2 209.165.200.224] R(config)# int [fa0/0] (Inside interface) R(config-if)# ip nat inside R(config)# int [serial0/0] (Outside interface) R(config-if)# ip nat outside
Dynamic NAT
R(config)# access-list 1 permit 172.17.0.0 0.0.0.255 R(config)# ip nat pool pub-addr 209.165.202.131 209.165.202.140 R(config)# ip nate inside source list 1 pool pud-addr R(config)# int fa0/0 R(config)# ip address 172.17.0.1 255.255.255.0 R(config)# ip nat inside R(config)# int ser0/0/0 R(config)# ip address 209.165.202.1 255.255.255.0 R(config)# ip nat outside
Configure an Interface
R(config)# interface [fa0/0] R(config-if)# description [Sales VLAN] R(config-if)# ip address [192.168.1.10 255.255.255.0] R(config-if)# no shutdown R(config-if)# clock rate [64000] (only for Serial DCE) PPP Encapsulation (Phases: LCP, Authentication, NCP) R(config-if)# encapsulation ppp
PAT
R(config)# access-list 1 permit 172.17.0.0 0.0.0.255 R(config)# ip nat inside source list 1 int ser0/0/0 overload R(config)# int fa0/0 (inside) R(config)# ip nat inside R(config)# int ser0/0/0 (outside) R(config)# ip nat outside R# show ip nat translations (Verify NAT translation)
Connectivity
R# ping [172.16.0.1] R# traceroute [172.16.0.1] R# telnet [172.16.0.1] R# show interface [fa0/0] R# show ip interface [fa0/0] (layer 3)
Switch: Basics
S# erase start S# delete vlan.dat S# reload S# show run S# show ip interface
Telnet
R> telnet 172.16.0.1 R1# terminal monitor (Displays console messages) R1# terminal no monitor
DHCP Server
R(config)# ip dhcp pool [Pool_Name] R(dhcp-config)# network [172.16.0.0 255.255.0.0] R(dhcp-config)# dns-server [172.16.0.1 172.16.0.2] R(dhcp-config)# default-router [172.16.0.1] R(config)# ip dhcp excluded-address [172.16.0.1 172.16.1.99]
NAT / PAT
Cisco IOS Quick Reference Cheat Sheet 2.1
R# debug ip route
Switch: VLAN
S(config)# vlan [vlan_number] S(config-vlan)# name[vlan_name]
RIP: Troubleshoot
R# show ip route R# show ip protocol R# show running-config R# show interfaces R# show ip interface R# show ip route R# debug ip rip
Remove a VLAN
S(config)# no vlan [vlan_number] S(config)# interface fa0/1 S(config-if)# no switchport access vlan [vlan_number]
Verify VLAN
S# show vlan ?
BGP
R(config)# router bgp [100-AS number] R(config-router)# neighbor [10.10.10.10] remote-as [100] R(config-router)# network [172.19.0.0]
EIGRP
R(config)# router eigrp [AS_Number] (AS must match) R(config-router)# network [172.16.0.0] R(config-router)# network [172.19.0.0]
Inter-VLAN Routing
R(config)# interface fa0/1 R(config-if)# no ip address R(config-if)# no shutdown R(config)# interface fa0/1.10 R(config-subif)# encapsulation dot1q10 R(config-subif)# ip address 192.168.10.1 255.255.255.0
OSPF:
Enable and Advertise Networks
R(config)# router ospf [process_id] (1-65535) R(config-router)# network 192.168.10.0 0.0.0.3 area [0] R(config-router)# area [0] authentication message-digest
RIP
R(config)# router rip R(config-router)# version 2 R(config-router)# network [192.168.4.0] R# show ip route Cisco IOS Quick Reference Cheat Sheet 2.1
3 of 4
R(config-if)# ip address 10.0.1.1 255.255.255.0 R(config-if)# ip ospf message-digest-key 10 md5 [area_password] R# show ip ospf ? R# debug ip ospf ?
Named
R(config)# access-list [standard|extended] SALES-ONLY R(config-ext-nacl)# permit 192.168.20.0 0.0.0.255 R(config-ext-nacl)# permit host 192.168.10.3 R(config-ext-nacl)# deny any
Tuning Priority
R(config-if)# ip ospf priority [1-255]
Access List:
Standard (Place close to destination)
R(config)# access-list [1-99|1300-1999] remark [To servers] R(config)# access-list 1 [deny|permit] [source] [mask] R(config)# access-list 1 permit any R(config)# no access-list 1 Extended (Place close to source) R(config)# access-list [100-199|2000-2699] remark [to servers] R(config)# access-list 100 [permit|deny] [tcp|ip|ospf] [source] [mask] host [destination] [mask] [eq|gt|lt] [tcp_port] R(config)# access-list 100 permit ip host 192.168.1.10 host 192.168.5.10 R(config)# access-list 100 permit tcp any host 10.10.10.250 eq 80 R(config)# access-list 101 permit tcp any any established R(config)# access-list 123 tcp host 172.16.1.2 any range ftp-data ftp
Set Clock
R# clock set 18:30:00 sep 17 2008 R# clock timezone EST -8
4 of 4