Configure EIGRP and Verify Path Control Using Policy Based Routing PBR

Download as pdf or txt
Download as pdf or txt
You are on page 1of 8

Download PNETLab Platform

PNETLAB Store
PNETLab.com

Configure EIGRP and Verify Path Control


Using Policy Based Routing PBR

Lab Topology:
Please use the following topology to complete this lab exercise:

Lab Objective:
The objective of lab exercise is for you to learn and understand step-by-step config EIGRP and
Configure and verify policy-based routing.

1
Download PNETLab Platform
PNETLAB Store
PNETLab.com

Task:
1. Configure loopbacks and assign addresses
2. Routing EIGRP
3. Verify the current path
4. Configure PBR to provide path control
5. Test the policy

Solution:
Task 1: Configure loopbacks and assign addresses
On R1:
hostname R1
!
interface Lo0
ip address 192.168.1.1 255.255.255.0
!
interface e0/0
ip address 172.16.12.1 255.255.255.0
bandwidth 128
no shutdown
!
Interface e0/1
ip address 172.16.13.1 255.255.255.0
bandwidth 64
no shutdown
On R2:
hostname R2
!
interface Lo0
ip address 192.168.2.1 255.255.255.0
!
Interface e0/0
ip address 172.16.12.2 255.255.255.0
bandwidth 128
no shutdown
!
Interface e0/1
ip address 172.16.23.1 255.255.255.0
bandwidth 128
no shutdown

2
Download PNETLab Platform
PNETLAB Store
PNETLab.com

On R3:
hostname R3
!
interface Lo0
ip address 192.168.3.1 255.255.255.0
!
interface e0/1
ip address 172.16.13.3 255.255.255.0
bandwidth 64
no shutdown
!
Interface
ip address e0/0172.16.23.3 255.255.255.0
bandwidth 128
no shutdown
!
Interface e0/2
ip address 172.16.34.3 255.255.255.248
bandwidth 64
no shutdown
On R4:
hostname R4
!
interface Lo0
ip address 192.168.4.1 255.255.255.128
!
interface Lo1
ip address 192.168.4.129 255.255.255.128
!
Interface e0/0
ip address 172.16.34.4 255.255.255.0
bandwidth 64
no shutdown

3
Download PNETLab Platform
PNETLAB Store
PNETLab.com

Task 2: Routing EIGRP


R1 R2 R3 R4

router eigrp 10 router eigrp 10 router eigrp 10 router eigrp 10

network 192.168.1.0 network 192.168.2.0 network 192.168.3.0 network 192.168.4.0

network 172.16.12.0 network 172.16.12.0 network 172.16.13.0 network 172.16.34.0


0.0.0.255 0.0.0.255 0.0.0.255 0.0.0.255

network 172.16.13.0 network 172.16.23.0 network 172.16.23.0 no auto-summary


0.0.0.255 0.0.0.255 0.0.0.255

no auto-summary no auto-summary network 172.16.34.0


0.0.0.255

no auto-summary

Task 3: Verify the current path


R1#show ip route | begin Gateway
Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks


C 172.16.12.0/24 is directly connected, Ethernet0/0
L 172.16.12.1/32 is directly connected, Ethernet0/0
C 172.16.13.0/24 is directly connected, Ethernet0/1
L 172.16.13.1/32 is directly connected, Ethernet0/1
D 172.16.23.0/24 [90/307200] via 172.16.13.3, 00:09:20, Ethernet0/1
[90/307200] via 172.16.12.2, 00:09:20, Ethernet0/0
D 172.16.34.0/24 [90/307200] via 172.16.13.3, 00:09:19, Ethernet0/1
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.0/24 is directly connected, Loopback0
L 192.168.1.1/32 is directly connected, Loopback0
D 192.168.2.0/24 [90/409600] via 172.16.12.2, 00:09:19, Ethernet0/0
192.168.4.0/25 is subnetted, 2 subnets
D 192.168.4.0 [90/435200] via 172.16.13.3, 00:05:59, Ethernet0/1
D 192.168.4.128 [90/435200] via 172.16.13.3, 00:05:59, Ethernet0/1

R4#traceroute 192.168.1.1 source 192.168.4.1


Type escape sequence to abort.
4
Download PNETLab Platform
PNETLAB Store
PNETLab.com

Tracing the route to 192.168.1.1


VRF info: (vrf in name/id, vrf out name/id)
1 172.16.34.3 1 msec 1 msec 0 msec
2 172.16.23.2 0 msec 3 msec 1 msec
3 172.16.12.1 8 msec 1 msec *

R4#traceroute 192.168.1.1 source 192.168.4.129


Type escape sequence to abort.
Tracing the route to 192.168.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 172.16.34.3 0 msec 1 msec 1 msec
2 172.16.23.2 1 msec 1 msec 1 msec
3 172.16.12.1 1 msec 1 msec * 1 172.16.34.3 2 msec 0 msec 1 msec

Task 4: Configure PBR to provide path control

R3(config)# ip access-list standard PBR_ACL

R3(config-std-nacl)# remark ACL matches R4 LAN B traffic

R3(config-std-nacl)# permit 192.168.4.128 0.0.0.127

R3(config-std-nacl)# exit

R3(config)# route-map R3-to-R1 permit

R3(config-route-map)# description RM to forward LAN B traffic to R1

R3(config-route-map)# match ip address PBR-ACL

R3(config-route-map)# set ip next-hop 172.16.13.1

R3(config-route-map)# exit

R3(config)# interface e0/2

R3(config-if)# ip policy route-map R3-to-R1

R3# show route-map

route-map R3-to-R1, permit, sequence 10

Match clauses:

5
Download PNETLab Platform
PNETLAB Store
PNETLab.com

ip address (access-lists): PBR-ACL

Set clauses:

ip next-hop 172.16.13.1

Policy routing matches: 0 packets, 0 bytes

Task 5: Test the policy

R3(config)# access-list 1 permit 192.168.4.0 0.0.0.255

R3(config)# exit

R3# debug ip policy 1

Policy routing debugging is on for access list 1

Verification:

R4#traceroute 192.168.1.1 source 192.168.4.1

Type escape sequence to abort.

Tracing the route to 192.168.1.1

VRF info: (vrf in name/id, vrf out name/id)

1 172.16.34.3 2 msec 1 msec 1 msec

2 172.16.23.2 0 msec 1 msec 1 msec

3 172.16.12.1 1 msec 1 msec *

R4#traceroute 192.168.1.1 source 192.168.4.129

Type escape sequence to abort.

Tracing the route to 192.168.1.1

6
Download PNETLab Platform
PNETLAB Store
PNETLab.com

VRF info: (vrf in name/id, vrf out name/id)

1 172.16.34.3 1 msec 1 msec 1 msec

2 172.16.13.1 1 msec 1 msec *

On R3:
*Oct 23 04:39:42.466: IP: s=192.168.4.1 (Ethernet0/2), d=192.168.1.1, len 28, policy reject
ed -- normal forwarding
*Oct 23 04:39:42.467: IP: s=192.168.4.1 (Ethernet0/2), d=192.168.1.1, len 28, policy reject
ed -- normal forwarding
*Oct 23 04:39:42.468: IP: s=192.168.4.1 (Ethernet0/2), d=192.168.1.1, len 28, FIB policy re
jected(no match) - normal forwarding
R3#
*Oct 23 04:39:51.475: IP: s=192.168.4.1 (Ethernet0/2), d=192.168.1.1, len 28, FIB policy re
jected(no match) - normal forwarding
*Oct 23 04:39:51.477: IP: s=192.168.4.1 (Ethernet0/2), d=192.168.1.1, len 28, FIB policy re
jected(no match) - normal forwarding
*Oct 23 04:39:51.478: IP: s=192.168.4.1 (Ethernet0/2), d=192.168.1.1, len 28, FIB policy re
jected(no match) - normal forwarding

On R3:
*Oct 23 04:37:07.009: IP: s=192.168.4.129 (Ethernet0/2), d=192.168.1.1, len 28, policy matc
h
*Oct 23 04:37:07.009: IP: route map R3-to-R1, item 10, permit
*Oct 23 04:37:07.009: IP: s=192.168.4.129 (Ethernet0/2), d=192.168.1.1 (Ethernet0/1), len 2
8, policy routed
*Oct 23 04:37:07.009: IP: Ethernet0/2 to Ethernet0/1 172.16.13.1
*Oct 23 04:37:07.009: IP: s=192.168.4.129 (Ethernet0/2), d=192.168.1.1, len 28, policy matc
h
*Oct 23 04:37:07.009: IP: route map R3-to-R1, item 10, permit
*Oct 23 04:37:07.009: IP: s=192.168.4.129 (Ethernet0/2), d=192.168.1.1 (Ethernet0/1), len 2
8, policy routed
*Oct 23 04:37:07.009: IP: Ethernet0/2 to Ethernet0/1 172.16.13.1

7
Download PNETLab Platform
PNETLAB Store
PNETLab.com

On R3, display the policy and matches using the show route-map command:
R3#show route-map
route-map R3-to-R1, permit, sequence 10
Match clauses:
ip address (access-lists): PBR_ACL
Set clauses:
ip next-hop 172.16.13.1
Nexthop tracking current: 0.0.0.0
172.16.13.1, fib_nh:0,oce:0,status:0

Policy routing matches: 18 packets, 1080 bytes

You might also like