Day 3
Day 3
Day 3
Basic Configuration
A. Interface configuration
B. Security Levels
C. Management [Telnet / SSH]
D. Routing
- Static Routes
- RIPv2
- EIGRP
- OSPF
- BGP
2. NAT
A. Dynamic NAT
B. Static NAT
C. Dynamic PAT
D. Static PAT
E. Manual NAT
3. Access Policies (ACL & Basic Inspection)
4. Transparent firewall
A. Initialization
B. Access policies
C. Ethertype ACLs
5. Redundancy
A. Redundant Interfaces
B. Port-channels
C. Security Contexts
==================================================
-----------------------------------------------------------------------------------
------------------------------------------------------------------------
Lab # 1 - Initialize the ASA Firewall based on the Diagram. Make sure it can reach
the routers around it.
-----------------------------------------------------------------------------------
------------------------------------------------------------------------
ASA
Verification Commads:
Show interface ip brief
Show nameif
Inside - To - Outside
DMZ-3 - To - DMZ4
No traffic is allowed as they have the same Security-Level. Even an ACL will not
help.
-----------------------------------------------------------------------------------
---
Lab # 2 - Controlling Traffic Thru & To the Firewall - ICMP
-----------------------------------------------------------------------------------
---
Requirement # 1 : The Inside Network should be allowed to Ping the Outside Network.
- An ACL on the firewall is a Named Extended ACL. It uses a Normal Mask. It only
affects THRU traffic. It has no affect on traffic destined to the the Firewall
Interfaces.
policy-map global_policy
class inspection_default
inspect icmp
Requirement # 2 : Block ICMP on the Outside Interface. The firewall should be able
to Ping the Outside Networks. Allow a Node on the Internet (150.5.5.1) to ping the
outside interface
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
Lab # 3 - Allow full access between R3 & R4 without changing the Security level or
applying an ACL
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
Note : By default, all traffic going between 2 interfaces with the same security
levels is blocked completely. Even an ACL will not help.
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
Lab # 4 - Management Access
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
Requirement # 1 : Allow the Inside & DMZ-3 Administrator to manage the Firewall
remotely. Configure the ASA with a Telnet password of cisco123 and allow the
10.11.11.0/24 & 192.168.3.0/24 networks to access it for Telnet.
Enable the Telnet Service on the Inside & DMZ-3 interface and specify the allowed
Network
passwd cisco123
Requirement # 2 : Allow the Outside & DMZ-3 Administrator to manage the Firewall
remotely. Configure the ASA with a Username admin1 with a password of cisco123 and
allow the 192.1.20.0/24 & 192.168.3.0/24 networks to access it for SSH.
domain-name cisco.com
crypto key generate rsa modulus 1024
Enable the SSH Service on the Outside & DMZ-3 interface and specify the allowed
Network
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
Lab # 5 - Static Routes
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
- Create a static route for the 10.10.10.0/24. This network is behind R1.
route inside 10.10.10.0 255.255.255.0 10.11.11.1
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
Lab # 6 - Configure RIPv2 on the ASA to communicate to R3 & R4. Authenticate using
MD5 the RIP neighbor relationships
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
R3
router rip
version 2
no auto-summary
network 192.168.3.0
network 10.0.0.0
R4
router rip
version 2
no auto-summary
network 192.168.4.0
network 10.0.0.0
ASA
router rip
version 2
no auto-summary
network 192.168.4.0
network 192.168.3.0
Authentication
R3
R4
ASA
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
Lab # 7 - Configure EIGRP on the ASA in AS 111 to communicate to R1. Authenticate
using MD5 the EIGRP neighbor relationship
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
R1
ASA
Authentication
R1
ASA
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
Lab # 8 - Configure OSPF on the ASA in Area 0 to communicate to R2. Authenticate
using MD5 the OSPF neighbor relationship
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
Basic OSPF Configuration on the ASA & R2
R2
router ospf 1
router-id 0.0.0.2
network 10.2.2.0 0.0.0.255 area 0
network 192.1.20.0 0.0.0.255 area 0
ASA
router ospf 1
router-id 0.0.0.10
network 192.1.20.0 255.255.255.0 area 0
Authentication
R2
Interface E 0/0
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco123
ASA
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
Lab # 9 - Redistribute the Routing Domains on the ASA Firewall
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
ASA
Into RIP
router rip
redistribute static
redistribute ospf 1 metric 1
redistribute eigrp 111 metric 1
Into EIGRP
Into OSPF
router ospf 1
redistribute static subnets
redistribute eigrp 111 subnets
redistribute Rip subnets
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
Lab # 10 - Configure BGP between R2 (AS 200) and the ASA (AS 1000) to exchange BGP
updates
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
R2
ASA
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
Lab # 11 - Configuring Dynamic NAT
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
Configuration:
! 2. Specify the NAT Statement to link the internal network that is allowed to use
the POOL
Syntax :
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
Lab # 12 - Configuring Static NAT
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
Requirement:
Configuration:
! 1. Specify the NAT Statement to link the internal address to the Public address.
Syntax :
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
Lab # 13 - Configuring Destination NAT
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
Lab # 14 - Configuring Dynamic PAT
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
- Dynamic PAT allow multiple Internal devices to go out to the Internet using a
Single Common IP.
- The translation table uses the randomnly generated source Port number in the
translation table to keep the entry unique.
- In case, 2 internal devices use the same random source port, the ASA will change
the Source IP and the Source Port number in the outgoing packet to keep it unique.
Configuration:
Requirement:
or
Configuration:
Requirement:
Configuration:
! 1. Specify the NAT Statement to link the internal address to the Public address.
Syntax :
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
Lab # 15 - Configuring Policy NAT / Manual NAT
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
- Normally when translation is taking place, the Firewall looks at either the
Source or the Destination IP address in the packet to match for NAT entries.
- Policy NAT allows you the ability to match a flow to perform NAT Lookups.
- This is also referred to as Manual NAT. Manual NAT has the highest priority in
case of a conflict.
Requirement:
Configuration:
object network R1
host 10.11.11.1
object network D1
host 199.1.1.1
object network D2
host 200.1.1.1
object network X1
host 192.1.20.36
object network X2
host 192.1.20.37
! 2. Create the manual/policy nat entries to define the translations based on the
flow
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
Lab # 16 - Initializing a Transparent Firewall
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
R1
host R1
!
no ip domain-loo
line con 0
logg sync
no exec-timeout
!
Interface E 0/0
ip address 192.1.10.1 255.255.255.0
no shut
!
Interface loopback 0
ip add 1.1.1.1 255.0.0.0
!
line vty 0 4
password cisco
login
transport input all
R2
host R2
!
no ip domain-loo
line con 0
logg sync
no exec-timeout
!
Interface E 0/0
ip address 192.1.10.2 255.255.255.0
no shut
!
Interface loopback 0
ip add 2.2.2.2 255.0.0.0
!
line vty 0 4
password cisco
login
transport input all
R3
host R3
!
no ip domain-loo
line con 0
logg sync
no exec-timeout
!
Interface E 0/0
ip address 192.1.10.3 255.255.255.0
no shut
!
Interface loopback 0
ip add 3.3.3.3 255.0.0.0
!
line vty 0 4
password cisco
login
transport input all
Requirement:
Configure the ASA as a Transparent Firewall. Link the Gig 0/0 and Gig 0/1
interfaces into a single Bridge Group. Configure a Bridge Virtual Interface (BVI)
on the ASA with an IP Address of 192.1.10.10.
firewall transparent
Interface E0
nameif Outside
bridge-group 11
no shut
!
Interface E1
nameif Inside
bridge-group 11
no shut
! 3. Configure the BVI Interface to enable IP on the Firewall. This can also be
used for Remote Management of the Firewall
Interface BVI 11
ip address 192.1.10.10
Note: At this point, the firewall works with the same default policies as a normal
L3 ASA
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
Lab # 17 - Access Policies thru the ASA
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
Lab # 18 - Configure Routing between R1, R2 & R3.
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
R1
R2
R3
ASA
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
Lab # 19 - Configure the ASA to allow MPLS to work thru the Firewall
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
Lab # 20 - Configure Redundant Interfaces for the ASA
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
Configuration:
Switch Configuration
Interface E2
no shut
!
Interface E3
no shut
! 2. Create the Redundant Interface and assign the Physical Ports to it.
Interface redundant 1
member-interface E2
member-interface E3
no shut
Interface Redundant 1
nameif Inside
ip add 10.11.11.10 255.255.255.0
mac-address 0001.1111.AAAA
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
Lab # 21 - Configure Port-channel for the ASA
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
Switch Configuration
Note: On Eve, make sure to manually do the VLAN Assignment command under the
Physical ports
ASA
Interface E0
channel-group 1 mode active
no shut
!
Interface E1
channel-group 1 mode active
no shut
Interface port-channel 1
nameif Outside
ip address 192.1.20.10
mac-address 0001.aaaa.bbbb
no shut
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
Lab # 22 - Configure ASA in a Multi-Context Mode
-----------------------------------------------------------------------------------
-------------------------------------------------------------------
mode multiple
Notes:
- This will restart the device in Multi-Context Mode. You will be put into the
System Context. It will have one additional context created by default. It is the
Admin Context called Admin.
- You now need to create the other context with the appropriate interfaces and
specify the Startup-Config name for each context.
Interface E0
no shut
Interface E1
no shut
Interface E2
no shut
Interface E3
no shut
context SALES
allocate-interface E0
allocate-interface E1
config-url flash:SALES.cfg
!
context MARK
allocate-interface E2 OUT
allocate-interface E3 INS
config-url flash:MARK.cfg
! 3. Configure the individual contexts
SALES
MARK