Basic Network Training Program Presentation
Basic Network Training Program Presentation
Basic Network Training Program Presentation
Layering Approach
Breaks down communication into smaller, simpler parts
In the three-layer network design model, network devices and links are grouped according to
three layers:
Core
Distribution
Access
10.1.1.1
Each device on a network is
assigned an IP address.
00001010 00000001 00000001 00000001
Each IP address has two
fundamental parts:
Network
Host
• The network portion, which
describes the physical wire
the device is attached to.
• The host portion, which
identifies the host on that
wire.
• How can we tell the
difference between the two
sections?
Basic Addressing
10.1.1.1
The network mask shows us
where to split the network and 00001010 00000001 00000001 00000001
host sections.
Network
Host
Each place there is a 1 in the
network mask, that binary digit
belongs to the network portion
of the address.
Each place there is a 0 in the 11111111 11111111 11111111 00000000
network mask, that binary digit
belongs to the host portion of
the address. 255.255.255.0
Basic Addressing
10.1.1.1
An alternative set of
terminology is: 00001010 00000001 00000001 00000001
• The network portion of the
address is called the prefix.
Prefix
Host
• The host portion of the address
is called the host.
• The network mask is
expressed as a prefix length, 11111111 11111111 11111111 00000000
which is a count of the number
of 1’s in the subnet mask. 8 + 8 + 8 = 24
10.1.1.1/24
Basic Addressing
10 1 1 0/24
00001010 000000011 00000001 00000000
The network address is the
prefix host
IP address with all 0’s in
the host bits. these bits are 0, so this is the network address
The broadcast address is
the IP address with all 1’s 10 1 1 255/24
in the host bits. 00001010 000000011 00000001 11111111
address will be delivered to these bits are 1, so this is the broadcast address
all the hosts connected to
the wire.
192 == 11000000
First, if you are using a network
mask, convert it to a prefix length.
For each octet in the network mask 255.255.255.192
that is 255, add 8 to the prefix length. 8 +8 +8 +2 == 26
For the one octet that isn’t 255,
convert to binary and add the right
number of bits--or use a chart!
8 7 6 5 4 3 2 1
Take the remainder, and find the 1 2 4 8 16 32 64 128
corresponding “multiple” on the
chart; in this case, 64.
The largest multiple of 64 that will fit 64 x 1 == 64
into 80 is 64, so the network is 64. 64 x 2 == 128
Add the three octets we “set aside” Network is 64!
earlier, and the network (prefix!) is
192.168.100.64/26. 192.168.100.64/26
80 - 64 == 16, so the host address is 80 - 64 == 16
16. 16 Hosts!
8 7 6 5 4 3 2 1
How many hosts are in this network? The 1 2 4 8 16 32 64 128
remainder tells us there are 64 addresses,
minus the network and broadcast
addresses, so 62 hosts.
64 addresses
To find the broadcast address, subtract 1
from the number of hosts, and add that 64 - 2 == 62 hosts
number to the network address. 64 + (64 - 1) == 127
The key is to work in octets, rather than 192.168.100.127 is the
trying to work with the entire IP address
broadcast address
at once!
8 7 6 5 4 3 2 1
Take the remainder, and find the 1 2 4 8 16 32 64 128
corresponding “multiple” on the
chart; in this case, 4.
The largest multiple of 64 that will fit 4 x 25 == 100
into 80 is 64, so the network is 64. 4 x 26 == 104
Add the two octets we “set aside” Third octet is 100!
earlier, and make any octets after the Set the fourth octet to 0.
network 0’s (the fourth octet).
The network (prefix!) is 192.168.100.0/22
192.168.100.0/22.
10.1.1.8
10.1.1.7
10.1.1.4
10.1.1.2
A single network address (prefix!)
represents a set of hosts attached to a
wire.
We can abstract this, and simply say
that a prefix represents a set of
reachable addresses.
We can say that we’ve “summarized” 10.1.1.0/26
information about the hosts attached
to the physical wire by referring to
the entire group as a single network.
10.1.1.0/24
VLSM: Variable Length Subnet 10.1.2.0/25
Masking
10.1.2.128/26
It simply means that the entire IP 10.1.2.192/27
address space is treated as one flat
address space.
All of these are valid in
Any prefix length is allowed in the the same network!
network at any point.
Internet
NAT
192.168.0.0
192.168.0.0
Dilivered By Waqas Sajjad 66.31.210.69
Basic NAT Operation
Private Network Internet
Source: 192.168.0.1 Source: 66.31.210.69
Dest: 74.125.228.67 Dest: 74.125.228.67
The Domain Name System (DNS) is a hierarchical decentralized naming system for
computers, services, or any resource connected to the Internet or a private network
In simple words DNS is the process by which a URL like google.com.au is translated
into its IP, 74.125.136.94l
Basically it is hard to Memorize the IP address for every site, So DNS is helpful as it is
easy to remember in Verbal Language.
When a switch starts up it sends a broadcast out of all ports to learn host MAC addresses
When a frame is received for an unknown destination a broadcast is sent to discover
Addresses are added to a switching table mapping them to the port on which they were
learned
When a frame is received for a known destination it is switched to the appropriate port
find path
forward packet, forward packet, forward packet, forward packet...
find alternate path
forward packet, forward packet, forward packet, forward packet…
repeat until powered off
10/8 announced
Based on destination IP address R3 from here
R1 R2
Packet: Destination
R4
IP address: 10.1.1.1 10/8 R3
10.1/16 announced
10.1/16 R4
from here
20/8 R5
30/8 R6
…..
R2’s IP routing table
Dilivered By Waqas Sajjad
Routing and Routing Protocols
A static route is simply a route that is added using a configuration command in a router.
After it is configured, IOS adds the route, including details such as the subnet number,
mask, output interface, and next-hop router, into a new entry in that router’s IP routing
table.
After it is added, the router can then route packets whose destination IP address
matches the static route.
Engineers use static routes for several reasons. They could configure static routes for
all routes in any internetwork, but typically it is not worth the effort.
The show ip route command now lists the new static route.
R2: Configuring a Static Route Using
the Next-Hop IP Address
Default route tells a router where to send packets that do not match any of
that router’s other IP routes.
With a default route, the router forwards the packet based on the
instructions in the default route.
Example on the next slide shows sample traceroute command output, with
the traceroute command never completing, which requires the user to stop
the command by using a break sequence.
In the case of a routing protocol algorithms are used for facilitating routing information and
best path determination
Routing protocol messages
These are messages for discovering neighbors and exchange of routing information
-Cost
-Delay
-Hop count
-Load
-Reliability
RAM – holds packet buffers, ARP cache, routing table, software and data structure
that allows the router to function; running-config is stored in RAM, as well as the
decompressed IOS in later router models
Flash memory – holds the IOS; is not erased when the router is reloaded; is an
EEPROM [Electrically Erasable Programmable Read-Only Memory] created by Intel,
that can be erased and reprogrammed repeatedly through an application of higher than
normal electric voltage
NVRAM – Non-Volatile RAM - holds router configuration; is not erased when router
is reloaded
Config-Register
controls how router boots;
value can be seen with “show version” command;
is typically 0x2102, which tells the router to load the IOS from flash memory and the
startup-config file from NVRAM
Console
Direct PC serial access
Auxiliary port
Modem access
Virtual terminals
Telnet/SSH access
TFTP Server
Copy configuration file into router RAM
Network Management Software
e.g. CiscoWorks
Connect your machine to the console port using the rollover serial cable provide
Go to /etc/remote to see the device configured to be used with "tip”. you will see at the
end, a line begin with com1
RouterA#(config-line)password cisco
RouterA#(config-line)login
Dilivered By Waqas Sajjad
New Router Configuration Process
Configure interfaces
RouterA#(config)interface ethernet 0/0
RouterA#(config-if)ip address n.n.n.n m.m.m.m
RouterA#(config-if)no shutdown
Configure routing/routed protocols
Save configuration parameters to NVRAM
RouterA#copy running-config startup-config
(or write memory)
router(config-if)#
Global:
enable secret e2@fnog
Interface:
interface ethernet 0/0
ip address n.n.n.n m.m.m.m
Router:
router ospf 1
network n.n.n.n w.w.w.w area 0
Line:
line vty 0 4
hostname e2-@fnog
enable secret tracke2
service password-encryption
logging facility local0
logging n.n.n.n
ip domain-lookup
no ip domain-lookup
router ospf 1
no router ospf 1
Description
router(config-if)#description ethernet link to admin building
router
router#configure terminal
router(config)#ip classless
router(config)#ip subnet-zero
router(config)#int e0/1
router(config-if)#ip addr n.n.n.n m.m.m.m
router(config-if)#no shut
router(config-if)#^Z
router(config)#int e0/0
router(config-if)#ip a?
access-group accounting address
Are used with access lists to specify a host, network or part of a network
To specify an address range, choose the next largest block size e.g.
Are used with the host/network address to tell the router a range of addresses to filter
Examples:
To specify a host:
196.200.220.1 0.0.0.0
To specify a small subnet:
196.200.220.8 – 196.200.220.15 (would be a /29)
Block size is 8, and wildcard is always one number less than the block size
Cisco access list then becomes 196.200.220.8 0.0.0.7
To specify all hosts on a /24 network:
196.200.220.0 0.0.0.255
E0 S0
s0
196.200.220.82
e0
interface ethernet 0
ip access-group 1 out
interface serial 0
ip access-group 1 out
Dilivered By Waqas Sajjad
Extended IP ACLs:
Deny FTP access through Interface
196.200.220.10
E1
196.200.220.225
Non 196.200.220.0
E0 S0 e1
196.200.220.226
Router>enable
Router#conf m OR copy start run (only!!!)
Router#show running OR write terminal
Router#conf t
Router(config)enable secret forgotten
Router(config)int e0/0…
Router(config-if)no shut
Router(config)config-register 0x2102
Router(config)Ctrl-Z or end
Router#copy run start OR write memory
Router#reload