-
-
Notifications
You must be signed in to change notification settings - Fork 7.7k
Blink documentation update #2293
New issue
Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.
By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.
Already on GitHub? Sign in to your account
Conversation
Added force_update service and increased time between server calls
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
There quite a few formatting errors in this. Have you even tried this on a local instance?
source/_components/blink.markdown
Outdated
@@ -33,15 +33,16 @@ Once loaded, your front end will have the following components: | |||
* A sensor per camera that reports battery level. | |||
* A sensor per camera that reports unread notification (ie. detected motion events). | |||
|
|||
Since the cameras are battery operated, the images are only updated in Home Assistant when the user manually forces a new photo. The image can only be updated in Home Assistant every 60 seconds in order to not overwhelm Blink's servers with API requests. | |||
Since the cameras are battery operated, the images are only updated in Home Assistant when the user manually forces a new photo. This image can be updated with the ``blink.snap_picture`` service followed by a ``blink.force_update`` service call to force Home Assistant to request an update from Blink's servers. If the ``blink.force_update`` service is not called, the image will be updated within a 180 second interval, set so that automatic server requests don't overwhelm the Blink API. Any camera-specific sensor typically only has its value updated when the image is updated, so relying on, for example, the temperature sensor reporting accurate data is not recommended. |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Double spaces between sentences.
Unsure what your trying to say in the last sentence.
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Yeah that sentence is poorly written. Basically, each camera has a built in temp sensor that is only updated when an image is pulled from the camera so if you wanted to use it as an accurate sensor (something you could base automatons on, for example) is not a great idea.
source/_components/blink.markdown
Outdated
|
||
For arm_system, the value sent can be either "True" or "False" and will arm and disarm the whole blink system, respectively | ||
For ``blink.arm_system``, the value sent can be either "True" or "False" and will arm and disarm the whole blink system, respectively |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
One set of ` is enough.
source/_components/blink.markdown
Outdated
@@ -50,21 +51,23 @@ Arm system example | |||
} | |||
``` | |||
|
|||
Arm camera follows a similar structure, but each indidivual camera can have motion detection enabled or disabled. Because of this, you also need to supply a name. For example, if I have a camera named "Living Room" and I want to turn off motion detection on that camera, I'd call the blink.arm_camera service with the following payload: | |||
Arm camera follows a similar structure, but each indidivual camera can have motion detection enabled or disabled. Because of this, you also need to supply a name. For example, if I have a camera named "Living Room" and I want to turn off motion detection on that camera, I'd call the ``blink.arm_camera`` service with the following payload: |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
One set of ` is enough.
source/_components/blink.markdown
Outdated
```json | ||
{ | ||
"friendly_name": "Living Room", | ||
"device_armed": "False" | ||
} | ||
``` | ||
|
||
The blink.snap_picture service takes the camera name as the payload and with take a new picture with your camera. | ||
The ``blink.snap_picture`` service takes the camera name as the payload and with take a new picture with your camera. |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
One set of ` is enough.
source/_components/blink.markdown
Outdated
``` | ||
{ | ||
"friendly_name": "Living Room" | ||
} | ||
``` | ||
|
||
The ``blink.force_update`` service can simply be called with no payload to force a server update. |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
One set of ` is enough.
@Landrash pushed the requested changes (forgot to mention it). Hopefully my rewording makes sense now? Let me know. |
Description:
Added force_update service and increased time between server calls
Pull request in home-assistant (if applicable): home-assistant/core#6696