2.9.2 Lab - Basic Switch and End Device Configuration - ILM
2.9.2 Lab - Basic Switch and End Device Configuration - ILM
2.9.2 Lab - Basic Switch and End Device Configuration - ILM
Version)
Instructor Note: Red font color or gray highlights indicate text that appears in the instructor copy only.
Topology
Addressing Table
Device Interface IP Address Subnet Mask
Objectives
Set Up the Network Topology
Configure PC Hosts
Configure and Verify Basic Switch Settings
Background / Scenario
In this lab, you will build a simple network with two hosts and two switches. You will also configure basic
settings including hostname, local passwords, and login banner. Use show commands to display the running
configuration, IOS version, and interface status. Use the copy command to save device configurations.
You will apply IP addressing for this lab to the PCs and switches to enable communication between the
devices. Use the ping utility to verify connectivity.
Note: The switches used are Cisco Catalyst 2960s with Cisco IOS Release 15.0(2) (lanbasek9 image). Other
switches and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the
commands available and output produced might vary from what is shown in the labs.
2013 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 1 of 12 www.netacad.com
Lab - Basic Switch and End Device Configuration
Note: Make sure that the switches have been erased and have no startup configurations. Refer to Appendix A
for the procedure to initialize and reload a switch.
Required Resources
2 Switches (Cisco 2960 with Cisco IOS Release 15.0(2) lanbasek9 image or comparable)
2 PCs (Windows with terminal emulation program, such as Tera Term)
Console cables to configure the Cisco IOS devices via the console ports
Ethernet cables as shown in the topology
Instructor Note: The Ethernet ports on the 2960 switches are autosensing and will accept either a straight-
through or a cross-over cable for all connections. If the switches used in the topology are other than the 2960
model, then it is likely that a cross-over cable will be needed to connect the two switches.
Instructions
Step 1: Set Up the Network Topology
In this step, you will cable the devices together according to the network topology.
a. Power on the devices.
Power on all devices in the topology. The switches do not have a power switch; they will power on as
soon as you plug in the power cord.
b. Connect the two switches.
Connect one end of an Ethernet cable to F0/1 on S1 and the other end of the cable to F0/1 on S2. You
should see the lights for F0/1 on both switches turn amber and then green. This indicates that the
switches have been connected correctly.
c. Connect the PCs to their respective switches.
Connect one end of the second Ethernet cable to the NIC port on PC-A. Connect the other end of the
cable to F0/6 on S1. After connecting the PC to the switch, you should see the light for F0/6 turn amber
and then green, indicating that PC-A has been connected correctly.
Connect one end of the last Ethernet cable to the NIC port on PC-B. Connect the other end of the cable to
F0/18 on S2. After connecting the PC to the switch, you should see the light for F0/18 turn amber and
then green, indicating that the PC-B has been connected correctly.
d. Visually inspect network connections.
After cabling the network devices, take a moment to carefully verify the connections to minimize the time
required to troubleshoot network connectivity issues later.
2013 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 2 of 12 www.netacad.com
Lab - Basic Switch and End Device Configuration
Repeat the previous steps to assign the IP address information for PC-B.
b. Verify PC settings and connectivity.
From PC-A, open a Command Prompt to verify the PC settings and connectivity using the ipconfig /all
command at the prompt.
C:\Users\Student> ipconfig /all
Windows IP Configuration
To test the connectivity to PC-B, enter ping 192.168.1.11 at the prompt. The ping should be successful. If
not, troubleshoot as necessary.
C:\Users\Student> ping 192.168.1.11
Instructor Note: If your student did not get a reply from PC-B, it may be necessary to disable the PC
firewall to ping between PCs. (Navigate to Control Panel > click System and Security > click Windows
2013 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 3 of 12 www.netacad.com
Lab - Basic Switch and End Device Configuration
Firewall > click Turn Windows Firewall on or off > click Turn off Windows Firewall (not
recommended).
Instructor Note: If the first ICMP packet times out, this could be a result of the PC resolving the
destination address. This should not occur if you repeat the ping as the address is now cached.
Establish a console connection to the switch from PC-A using Tera Term.
You can access all switch commands in privileged EXEC mode. The privileged EXEC command set
includes those commands contained in user EXEC mode, as well as the configure command through
which access to the remaining command modes are gained. Enter privileged EXEC mode by entering the
enable command.
Switch> enable
Switch#
The prompt changed from Switch> to Switch# which indicates privileged EXEC mode.
Use the configuration terminal command to enter configuration mode.
Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#
The prompt changed to reflect global configuration mode.
b. Give the switch a name according to the Addressing Table.
Use the hostname command to change the switch name to S1.
Switch(config)# hostname S1
c. Prevent unwanted DNS lookups.
To prevent the switch from attempting to translate incorrectly entered commands as though they were
hostnames, disable the Domain Name System (DNS) lookup.
S1(config)# no ip domain-lookup
d. Enter local passwords. Use class as the privileged EXEC password and cisco as the password for
console access.
To prevent unauthorized access to the switch, configure passwords.
S1(config)# enable secret class
S1(config)# line con 0
S1(config-line)# password cisco
S1(config-line)# login
S1(config-line)# exit
e. Configure and enable the SVI according to the Addressing Table.
S1(config)# interface vlan 1
S1(config-if)# ip address 192.168.1.1 255.255.255.0
S1(config-if)# no shut
f. Enter a login MOTD banner to warn about unauthorized access.
A login banner, known as the message of the day (MOTD) banner, should be configured to warn anyone
accessing the switch that unauthorized access will not be tolerated.
2013 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 4 of 12 www.netacad.com
Lab - Basic Switch and End Device Configuration
The banner motd command requires the use of delimiters to identify the content of the banner message.
The delimiting character can be any character as long as it does not occur in the message. For this
reason, symbols, such as the #, are often used.
S1(config)# banner motd #
Enter TEXT message. End with the character '#'.
Unauthorized access is strictly prohibited and prosecuted to the full extent
of the law. #
S1(config)# exit
g. Save the configuration.
Use the copy command to save the running configuration to the startup file on non-volatile random access
memory (NVRAM).
S1# copy running-config startup-config
Destination filename [startup-config]? [Enter]
Building configuration...
[OK]
S1#
h. Display the current configuration.
The show running-config command displays the entire running configuration, one page at a time. Use the
spacebar to advance paging. The commands configured in Steps a - h are highlighted below.
S1# show running-config
Building configuration...
<output omitted>
interface Vlan 1
2013 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 5 of 12 www.netacad.com
Lab - Basic Switch and End Device Configuration
ip http server
ip http secure-server
!
banner motd ^C
Unauthorized access is strictly prohibited and prosecuted to the full extent of the
law. ^C
!
line con 0
password cisco
login
line vty 0 4
login
line vty 5 15
login
!
end
A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
2013 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 6 of 12 www.netacad.com
Lab - Basic Switch and End Device Configuration
2013 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 7 of 12 www.netacad.com
Lab - Basic Switch and End Device Configuration
F0/1 Up Up Up Up
F0/6 Up Up Down Down
F0/18 Down Down Up Up
VLAN 1 Up Up Up Up
Reflection Question
Why some FastEthernet ports on the switches are up and others are down?
Type your answers here.
The FastEthernet ports are up when cables are connected to the ports unless they were manually shutdown
by the administrators. Otherwise, the ports would be down.
What could prevent a ping from being sent between the PCs?
Type your answers here.
Wrong IP address, media disconnected, switch powered off or ports administratively down, firewall.
End of Document
2013 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 8 of 12 www.netacad.com
Lab - Basic Switch and End Device Configuration
Device Configs
Switch S1 (complete)
S1#sh run
Building configuration...
Current configuration : 1514 bytes
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname S1
boot-start-marker
boot-end-marker
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
system mtu routing 1500
!
no ip domain-lookup
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
2013 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 9 of 12 www.netacad.com
Lab - Basic Switch and End Device Configuration
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
!
ip http server
ip http secure-server
!
banner motd ^C
Unauthorized access is strictly prohibited and prosecuted to the full extent of the
law. ^C
!
line con 0
password cisco
login
line vty 0 4
login
line vty 5 15
login
2013 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 10 of 12 www.netacad.com
Lab - Basic Switch and End Device Configuration
end
Switch S2 (complete)
S2# sh run
Building configuration...
Current configuration : 1514 bytes
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname S2
!
boot-start-marker
boot-end-marker
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
system mtu routing 1500
!
no ip domain-lookup
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
2013 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 11 of 12 www.netacad.com
Lab - Basic Switch and End Device Configuration
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 192.168.1.2 255.255.255.0
!
ip http server
ip http secure-server
!
banner motd ^C
Unauthorized access is strictly prohibited and prosecuted to the full extent of the
law. ^C
line con 0
password cisco
login
line vty 0 4
login
line vty 5 15
login
end
2013 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 12 of 12 www.netacad.com